Subject: [RTG-DIR] Review of draft-ietf-isis-layer2-09

From: Ross Callon <[email-masked]>
Date: Sun, 2 Jan 2011 19:53:43 -0500

Hello,
I have been asked to provide an additional Routing Directorate review for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html
Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.
Document: draft-ietf-isis-layer2-09.txt
Reviewer: Ross Callon
Review Date: 2011-01-02
IETF LC End Date: 2010-12-14
Intended Status: proposed standard
Summary:
I have only very minor concerns about this document. While these are of a nature that the RFC editor staff might be expected to identify and fix, you may nonetheless want to resolve these before publication.
Comments:
The document is well written and structured, and generally conforms to the conventional definition of IS-IS TLVs.
Major Issues:
No major issues found.
Minor Issues:

Section 2.2, The bullet item "Type: TLV Type, set to MT-PORT-CAP TLV 143 [TBD]."

My understanding is that the value 143 was incorrectly picked (and overlaps with a different meaning of the same value). My understanding is also that the "TBD" means that this was tentative. This will need to be corrected prior to publication, and you might want to add an RFC editor's note to this effect (or at least make sure that you check this during auth-48).

Section 6.2, informative references. The third reference. I believe that this is to "draft-ietf-trill-rbridge-protocol-16.txt", which is in the RFC editor's queue waiting on a normative reference to this document. It would be less confusing to include the draft name. My understanding is that the RFC editor will then replace this with the RFC when both are published together.

---

From: Ayan Banerjee <[email-masked]>
Date: Mon, 03 Jan 2011 11:11:25 -0800

Ross,

Thanks much for the comments. Regarding the minor issues:

The MT-PORT-CAP-TLV with the suggested value is fine. The MAC-reachability
TLV was in conflict and version 09 of this draft moved it to a
non-conflicting value.

Yes, this is accurate, the suggested reference is to
³draft-ietf-trill-rbridge-protocol-16.txt². I am hoping that we can fix this
up in the RFC editor queue.

Thanks,
Ayan

On 1/2/11 4:53 PM, "Ross Callon" <[email-masked]> wrote:

> Hello,
> I have been asked to provide an additional Routing Directorate review for this
> draft. The Routing Directorate seeks to review all routing or routing-related
> drafts as they pass through IETF last call and IESG review. The purpose of the
> review is to provide assistance to the Routing ADs. For more information about
> the Routing Directorate, please see
> http://www.ietf.org/iesg/directorate/routing.html
> <http://www.ietf.org/iesg/directorate/routing.html>
> Although these comments are primarily for the use of the Routing ADs, it would
> be helpful if you could consider them along with any other IETF Last Call
> comments that you receive, and strive to resolve them through discussion or by
> updating the draft.
> I have only very minor concerns about this document. While these are of a
> nature that the RFC editor staff might be expected to identify and fix, you
> may nonetheless want to resolve these before publication.
> Comments: 
> Section 2.2, The bullet item ³Type: TLV Type, set to MT-PORT-CAP TLV 143
> [TBD].²
>  
> My understanding is that the value 143 was incorrectly picked (and overlaps
> with a different meaning of the same value). My understanding is also that the
> ³TBD² means that this was tentative. This will need to be corrected prior to
> publication, and you might want to add an RFC editor¹s note to this effect (or
> at least make sure that you check this during auth-48).
>  
>  
> Section 6.2, informative references. The third reference. I believe that this
> is to ³draft-ietf-trill-rbridge-protocol-16.txt², which is in the RFC editor¹s
> queue waiting on a normative reference to this document. It would be less
> confusing to include the draft name. My understanding is that the RFC editor
> will then replace this with the RFC when both are published together.
>  
>