Subject: [RTG-DIR] RtgDir review: draft-ietf-mpls-rsvp-te-no-php-oob-mapping-08.txt

From: John E Drake <[email-masked]>
Date: Thu, 11 Aug 2011 14:36:21 -0700

Hello, 

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html 

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft. 

Document:  draft-ietf-mpls-rsvp-te-no-php-oob-mapping-08.txt 
Reviewer: John Drake 
Review Date: 11-Aug-11 
IETF LC End Date: 11-Aug-11 
Intended Status: Proposed Standard 

Summary: 

I have some minor concerns about this document that I think should be resolved before publication.

Comments: 

The document is well-written and very readable, and is nicely focused on solving a specific problem that has existed for quite 
some time. 

Major Issues: 

No major issues found

Minor Issues:
 
There are several apparently normative references to {ATTRIBUTES-BNF] which I could not find in the References section.

It proposes an adjunct procedure to be performed by the ingress in addition to its checking of the setting of the 'Non-PHP behavior acknowledgement flag' in the Flags field of the RRO.  This procedure is to check the RRO to see whether the egress allocated a non-null label for the LSP;  it is unnecessary and I would suggest removing it.

Sent from my iPhone

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 17 Aug 2011 11:41:36 -0500

Hi John: 

Thanks for your kind review. Please see my response in-line. 

Thanks

Regards ... Zafar 

> -----Original Message-----
> From: John E Drake [mailto:[email-masked]]
> Sent: Thursday, August 11, 2011 5:36 PM
> To: [email-masked]
> Cc: [email-masked]; draft-ietf-mpls-rsvp-te-no-php-oob-
> [email-masked]
> Subject: RtgDir review: draft-ietf-mpls-rsvp-te-no-php-oob-mapping-
> 08.txt
> 
> Hello,
> 
> I have been selected as the Routing Directorate reviewer for this draft.
> The Routing Directorate seeks to review all routing or routing-related
> drafts as they pass through IETF last call and IESG review, and
> sometimes on special request. The purpose of the review is to provide
> assistance to the Routing ADs. For more information about the Routing
> Directorate, please see
> http://www.ietf.org/iesg/directorate/routing.html
> 
> Although these comments are primarily for the use of the Routing ADs, it
> would be helpful if you could consider them along with any other IETF
> Last Call comments that you receive, and strive to resolve them through
> discussion or by updating the draft.
> 
> The document is well-written and very readable, and is nicely focused on
> solving a specific problem that has existed for quite
> some time.
> 
> Major Issues:
> 
> No major issues found
> 
> Minor Issues:
> 
> There are several apparently normative references to {ATTRIBUTES-BNF]
> which I could not find in the References section.
> 

Sorry, this was missing by mistake. Adrian also pointed this out in his AD review. In the enclosed version, the reference as been added (as normative). 

> It proposes an adjunct procedure to be performed by the ingress in
> addition to its checking of the setting of the 'Non-PHP behavior
> acknowledgement flag' in the Flags field of the RRO.  This procedure is
> to check the RRO to see whether the egress allocated a non-null label
> for the LSP;  it is unnecessary and I would suggest removing it.
> 

As current RFCs allow ingress to look at the label recording in RRO, we thought it will be useful to allow it. This covers us for the case where egress does not implement the proposed extension but based on some local policy still allocates a non-Null label. We feel it is useful and hence was part of the text. 

At the very least, we need to talk about label recording in RRO to be complete. Disallowing ingress not to infer anything from label recording is also odd. 

In the light of the above, we would like to keep the RRO label recording text. Hope you are ok with that. 

Thanks

Regards... Zafar

---

From: John E Drake <[email-masked]>
Date: Wed, 17 Aug 2011 11:53:33 -0700

Zafar,

Snipped, comments inline.

Thanks,

John

Sent from my iPhone

> > acknowledgement flag' in the Flags field of the RRO.  This procedure
> > is to check the RRO to see whether the egress allocated a non-null
> > label for the LSP;  it is unnecessary and I would suggest removing
> it.
> >
> 
> As current RFCs allow ingress to look at the label recording in RRO, we
> thought it will be useful to allow it. This covers us for the case
> where egress does not implement the proposed extension but based on
> some local policy still allocates a non-Null label. We feel it is
> useful and hence was part of the text.

JD:  What would the ingress do differently in this case?  I thought it was to check for the case of an egress node that indicated support but allocated a Null label, and it seemed of marginal utility.

> 
> At the very least, we need to talk about label recording in RRO to be
> complete. Disallowing ingress not to infer anything from label
> recording is also odd.
> 
> In the light of the above, we would like to keep the RRO label
> recording text. Hope you are ok with that.

JD:  It's fine to keep it.

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 17 Aug 2011 22:27:24 -0500

Hi John- 

If the label recording indicates that the node has not allocated a Null label, the Ingress node will tear the setup (so not a different action). I agree that it's marginal addition but good to have it there for completeness. 

Thanks for agreeing to keep the text. 

Thanks

Regards ... Zafar 

> Sent: Wednesday, August 17, 2011 2:54 PM
> To: Zafar Ali (zali); [email-masked]
> Subject: RE: RtgDir review: draft-ietf-mpls-rsvp-te-no-php-oob-mapping-
> 08.txt
> 
> Zafar,
> 
> JD:  What would the ingress do differently in this case?  I thought it
> was to check for the case of an egress node that indicated support but
> allocated a Null label, and it seemed of marginal utility.
> 
> >