Subject: [RTG-DIR] RtgDir review: draft-ietf-pce-hierarchy-fwk-04.txt

From: Jamal Hadi Salim <[email-masked]>
Date: Sat, 18 Aug 2012 08:54:41 -0400

Hi,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related drafts
as they pass through IETF last call and IESG review, and sometimes on special
request. The purpose of the review is to provide assistance to the Routing ADs.
For more information about the Routing Directorate, please see
http://www.ietf.org/iesg/directorate/routing.html

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF Last
Call comments that you receive, and strive to resolve them through discussion
or by updating the draft.

Document: draft-ietf-pce-hierarchy-fwk-04.txt
Reviewer: Jamal Hadi Salim
Review Date: 2012-08-18
IETF LC End Date: 2012-08-24
Intended Status: Informational

Summary:
This document is basically ready for publication, but has minor
but important readability nits that should be considered prior to
publication.

Comments:
The document describes how the PCE architecture can be extended
through the use of hierarchical relationship between domains to
compute an optimum path over a sequence of domains.
The draft is well written with good clarity on the purpose and
functionality of the intended messages.

Major Issues:
None

Minor Issues:
None

Nits:
1) The term "antonymous" appears 5 times it almost made me believe
it was intended. I think that should be "autonomous".

2) Section 1.3.1
"See Section 5.1" should be "See Section 4.1"

3) Section 1.3.2.1
"Within a Carrier's Carrier ..."
should be:
"Within a Carrier's carrier .."
i.e second carrier is all lower-case

4) Section 2.2.
Unnecessary empty line after:
"from its entry BNs to its exit BNs that connect to the rest of the"

5) Section 4.6.2

i) "described in Section 5.6.1"
should be:
"described in Section 4.6.1"

ii) "(See Section 5.5)"
should be:
"(See Section 4.5)"

6) Section 4.7
".. path to the egress. The child PCE should return the relevant .."
should be:
".. path to the egress, the child PCE should return the relevant .."

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 29 Aug 2012 14:53:07 -0400

Acked-By: Me

cheers,
jamal

On Wed, Aug 29, 2012 at 1:35 AM, Daniel King <[email-masked]> wrote:
> Dear Jamal, Martin, Donald and Joerg,
>
> Thank you for your reviews and comments of draft-ietf-pce-hierarchy-fwk. We
> have addressed all the outstanding comments and recently uploaded a new (05)
> version of the document:
>
> http://tools.ietf.org/html/draft-ietf-pce-hierarchy-fwk-05
>
> Kind Regards,
> H-PCE Authors
>
> -----Original Message-----
> From: Jamal Hadi Salim [mailto:[email-masked]]
> Sent: 18 August 2012 13:55
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RtgDir review: draft-ietf-pce-hierarchy-fwk-04.txt
>
> Hi,
>
> The Routing Directorate seeks to review all routing or routing-related
> drafts as they pass through IETF last call and IESG review, and sometimes on
> special request. The purpose of the review is to provide assistance to the
> Routing ADs.
> Call comments that you receive, and strive to resolve them through
> discussion or by updating the draft.
>
> This document is basically ready for publication, but has minor but
> important readability nits that should be considered prior to publication.
>
> Comments:
> The document describes how the PCE architecture can be extended through the
> use of hierarchical relationship between domains to compute an optimum path
> over a sequence of domains.
> The draft is well written with good clarity on the purpose and functionality
> of the intended messages.
>
>
> Major Issues:
> None
>
> Minor Issues:
> None
>
> Nits:
> 1) The term "antonymous" appears 5 times it almost made me believe it was
> intended. I think that should be "autonomous".
>
> 2) Section 1.3.1