Subject: [RTG-DIR] What message does a QA review send?

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 21 Jun 2016 13:34:36 +0100

I've always wanted to start an email with "When I was an AD"...

When I was an AD I was really worried about the level of review that documents
received before the WG sent them for publication. In some cases this resulted in
sub-standard (hard to read, confusing, wrong) RFCs. In other cases it resulted
in high work-loads for the AD (me :-) as the documents were polished. And from
time to time the documents were sent back to the WG.

The QA review gets additional critical eyes on documents early and that has got
to be a good thing - the earlier issues are raised the easier they are to fix.

However one way we judge the need for a document is the level of review and
discussion it has had, and the maturity of the work. We do need to be careful
that the attention the QA reviewers pay a draft is not mistaken for WG support
or anyone's interest in the topic, and that the improvement in the document is
not a substitute for intention to implement and need for the document.

Adrian

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 21 Jun 2016 13:01:49 +0000

Hi Adrian,

Totally agree. I liked your intro to your RTG DIR QA review of draft-ietf-nvo3-gue. Not everyone on a mailing list is familiar with the RTG DIR and may interpret your review as interest in the document. Same for RTG DIR reviews requested by an AD after WG LC.

Deborah

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, June 21, 2016 8:35 AM
To: [email-masked]
Subject: [RTG-DIR] What message does a QA review send?

Adrian

---

From: Alia Atlas <[email-masked]>
Date: Tue, 21 Jun 2016 10:44:59 -0400

Hi Adrian,

Absolutely!  The reviews can trigger good discussion, but being clear that
the reviewer is doing this on request and not based on interest is critical.
I think that the WG Chairs are clear on this.

Regards,
Alia

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 21 Jun 2016 14:57:34 +0000

Adrian, Alia and all,
Suppose that the reviewer, in the process of review, finds out that he/she is interested in the draft even if originally he was not even aware of its existence.
This definitely can happen (in fact, this has happened to me at least once).

What should the reviewer do in this case?
The case of a QA review is of special interest, IMHO, because the QA reviewer is expected to provide the RTG-DIR review later.

Some clarification would be most useful.

Regards,  and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: rtg-dir [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, June 21, 2016 5:45 PM
To: Adrian Farrel <[email-masked]>
Cc: [email-masked]
Subject: Re: [RTG-DIR] What message does a QA review send?

Hi Adrian,

Regards,
Alia

On Tue, Jun 21, 2016 at 8:34 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
I've always wanted to start an email with "When I was an AD"...

Adrian

---

From: Alia Atlas <[email-masked]>
Date: Tue, 21 Jun 2016 11:03:30 -0400

Sasha,

If that happens, it's great.  But that can become clear by your own words
too -
such as "while I initially looked at this draft for a QA review, I'm
personally
quite interested in it because...."

Alia

On Tue, Jun 21, 2016 at 10:57 AM, Alexander Vainshtein <
[email-masked]> wrote:

> Adrian, Alia and all,
>
> Suppose that the reviewer, in the process of review, finds out that he/she
> is interested in the draft even if originally he was not even aware of its
> existence.
>
> The case of a QA review is of special interest, IMHO, because the QA
> reviewer is expected to provide the RTG-DIR review later.
>
>
>
> *From:* rtg-dir [mailto:[email-masked]] *On Behalf Of *Alia
> Atlas
> *Sent:* Tuesday, June 21, 2016 5:45 PM
> *To:* Adrian Farrel <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [RTG-DIR] What message does a QA review send?
>
>
>
> Hi Adrian,
>
>
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 21 Jun 2016 15:05:11 +0000

Alia,
Lots of thanks for the clarifying this.
If/when this situation happens again, I will know what to do about it.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: Alia Atlas [mailto:[email-masked]]
Sent: Tuesday, June 21, 2016 6:04 PM
To: Alexander Vainshtein <[email-masked]>
Cc: Adrian Farrel <[email-masked]>; [email-masked]
Subject: Re: [RTG-DIR] What message does a QA review send?

Sasha,

If that happens, it's great.  But that can become clear by your own words too -
such as "while I initially looked at this draft for a QA review, I'm personally
quite interested in it because...."

Alia

On Tue, Jun 21, 2016 at 10:57 AM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Adrian, Alia and all,
Suppose that the reviewer, in the process of review, finds out that he/she is interested in the draft even if originally he was not even aware of its existence.
This definitely can happen (in fact, this has happened to me at least once).

Office: +972-39266302<tel:%2B972-39266302>
Cell:      +972-549266302<tel:%2B972-549266302>
Email:   [email-masked]<mailto:[email-masked]>

From: rtg-dir [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Alia Atlas
Sent: Tuesday, June 21, 2016 5:45 PM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [RTG-DIR] What message does a QA review send?

Hi Adrian,

Regards,
Alia

Adrian