Subject: [RTG-DIR] draft-ietf-nvo3-use-case-15 review

From: Henning Rogge <[email-masked]>
Date: Sun, 15 Jan 2017 13:35:54 +0100

Hi,

I have been asked to review this draft as a Routing Directorate reviewer.

Document:  draft-ietf-nvo3-use-case-15
Reviewer: Henning Rogge
Review Date: 15 January 2017
Intended Status: Informational

Summary:
I have no major concerns about this document.

Minor Issues:
The document states that the NVO3 networks can be layer-2 or layer-3
entities. While layer-2 networks leave the complete IP addressing
scheme to the connected VMs/servers, a layer-3 NVO3 network will (if I
understand it correctly) set some restrictions on the IP addresses of
the VMs (because the addresses have to fit the routing tables used on
the NVO3 network).

The draft mention the use of iBGP or static routes for connecting a
customer server/VM over the internet (Section 3.1), but does not
mention any such thing within the NVO3 network and does also not
mention the any handing of addressing. Is this 'out of scope' for this
Use Case draft or should it maybe mention who is responsible for
defining the addressing scheme for a layer-3 NVO3 VM?

Henning Rogge

---

From: Lucy yong <[email-masked]>
Date: Sun, 15 Jan 2017 16:22:54 +0000

Hi Henning,

Please see inline below.

-----Original Message-----
From: Henning Rogge [mailto:[email-masked]] 
Sent: Sunday, January 15, 2017 6:36 AM
To: <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: draft-ietf-nvo3-use-case-15 review

Hi,

Summary:

Minor Issues:
The document states that the NVO3 networks can be layer-2 or layer-3 entities. While layer-2 networks leave the complete IP addressing scheme to the connected VMs/servers, a layer-3 NVO3 network will (if I understand it correctly) set some restrictions on the IP addresses of the VMs (because the addresses have to fit the routing tables used on the NVO3 network).
[Lucy] it is about host address assignment that is done by DC operator. The routing tables is fulfilled based on the address and VM location. To support host mobility, the routing table needs to support subnet and host based routing. IMO: address assignment rule/algorithm is out scope of this document. 

The draft mention the use of iBGP or static routes for connecting a customer server/VM over the internet (Section 3.1), but does not mention any such thing within the NVO3 network and does also not mention the any handing of addressing. Is this 'out of scope' for this Use Case draft or should it maybe mention who is responsible for defining the addressing scheme for a layer-3 NVO3 VM?
[Lucy] Addressing assignment in this case is the same as intra NOV3. Do you see any issue here?

Thanks,
Lucy 

Henning Rogge

---

From: Henning Rogge <[email-masked]>
Date: Tue, 24 Jan 2017 13:49:58 +0100

> [Lucy] it is about host address assignment that is done by DC operator. The routing tables is fulfilled based on the address and VM location. To support host mobility, the routing table needs to su…

Okay... addressing can be a "stumbling block" for complex routing
scenarios, that is why I asked.

> [Lucy] Addressing assignment in this case is the same as intra NOV3. Do you see any issue here?

"defined by the DC operator" is not well defined if a customer has
more than one NOV3 DC operators and wants to interconnect both DCs
because of a new service combining data from both of them.

But it might be still "out of scope" for this draft.

Henning Rogge