Subject: [RTG-DIR] Rtgdir early review of draft-ietf-ospf-ospfv3-lsa-extend-14

From: Min Ye <[email-masked]>
Date: Wed, 17 May 2017 02:22:18 -0700

Reviewer: IJsbrand Wijnands
Review result: Has Issues

Hi All,

I have been selected to do a routing directorate QA review of this
draft.
https://www.ietf.org/id/draft-ietf-ospf-ospfv3-lsa-extend-14.txt

Summary: 

This draft proposes a new addressing (TLV) format to more easily allow

additional information to be added as part of a particular LSA. 
Overall, well written, easy to understand what the objective is for
this draft.

Comments and Questions:

This looks like a pretty radical change to the OSPFv3 spec. I would 
almost argue to call it OSPFv4..

Its very unfortunate there are no ‘reserved’ fields in RFC5340 that 
would allow you keep the existing LSA’s format and have some way to 
extend it differently. The TLV approach look good, I can’t see a
better 
way to achieve the goal.

Minor Issues and Nits:
none.

Thx,

Ice.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 17 May 2017 12:07:03 +0000

Hi Min ,

>Review result: Has Issues

I think the result is “No Issues”.

Thanks,
Acee

---

From: "Yemin (Amy)" <[email-masked]>
Date: Thu, 18 May 2017 01:34:20 +0000

Hi Acee, 

Thanks for correction. I updated the result as "Ready". 

BR,
Amy

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, May 17, 2017 8:07 PM
To: Yemin (Amy) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Rtgdir early review of draft-ietf-ospf-ospfv3-lsa-extend-14

Hi Min ,

Thanks,
Acee
>extend it differently. The TLV approach look good, I can’t see a better 
>way to achieve the goal.
>
>Minor Issues and Nits:
>none.
>
>Thx,
>
>Ice.
>
>