Subject: [Rucus] Reading list for BoF

From: "Martin Stiemerling" <[email-masked]>
Date: Mon, 18 Feb 2008 16:08:26 +0100

Hi,

I'm currently trying to get an overview about what has happened in the field of SPIT mitigation, i.e., editing a useful reading list for the rucus bof. 

Some possible documents to read:
- RFC 5039
- SIP Extensions for SPIT identification (draft-niccolini-sipping-feedback-spit-03)
- Signaling TO Prevent SPIT (SPITSTOP) Reference Scenario draft-niccolini-sipping-spitstop-01)
- Completely Automated Public Turing Test to Tell Computers and Humans Apart (CAPTCHA) based Robot Challenges for the Session Initiation Protocol (SIP) (draft-tschofenig-sipping-captcha-00.txt)
- A Framework to tackle Spam and Unwanted Communication for Internet                        Telephony (draft-tschofenig-sipping-framework-spit-reduction-02.txt)
A Document Format for Expressing Authorization Policies to tackle Spam
and Unwanted Communication for Internet Telephony (draft-tschofenig-sipping-spit-policy-02.txt)
- Spam feedback for SIP (draft-niccolini-sipping-spam-feedback-00.txt)
- Spam Score for SIP (draft-wing-sipping-spam-score-01.txt)

  Martin

[email-masked]   <== NEW ADDRESS

NEC Laboratories Europe - Network Research Division

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 
_______________________________________________
Rucus mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rucus

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 18 Feb 2008 16:09:50 +0100

FYI, we are going to have more documents after the draft submission deadline. 

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von ext Martin Stiemerling
> Gesendet: Montag, 18. Februar 2008 17:08
> An: rucus BoF
> Betreff: [Rucus] Reading list for BoF
> 
> 
> Hi,
> 
> I'm currently trying to get an overview about what has 
> happened in the field of SPIT mitigation, i.e., editing a 
> useful reading list for the rucus bof. 
> 
> - SIP Extensions for SPIT identification 
> (draft-niccolini-sipping-feedback-spit-03)
> - Completely Automated Public Turing Test to Tell Computers 
> and Humans Apart (CAPTCHA) based Robot Challenges for the 
> Session Initiation Protocol (SIP) 
> (draft-tschofenig-sipping-captcha-00.txt)
> - A Framework to tackle Spam and Unwanted Communication for 
> Internet                        Telephony 
> (draft-tschofenig-sipping-framework-spit-reduction-02.txt)
> and Unwanted Communication for Internet Telephony 
> (draft-tschofenig-sipping-spit-policy-02.txt)
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014

---

From: "Saverio Niccolini" <[email-masked]>
Date: Mon, 18 Feb 2008 16:29:35 +0100

Hi,

there are already some drafts out:

-- new version for SPITSTOP draft (-01)
http://tools.ietf.org/html/draft-niccolini-sipping-spitstop-01
-- new version of the spam score draft (-01)
http://tools.ietf.org/html/draft-wing-sipping-spam-score-01
-- new draft on spam score semantics (-00)
http://www.ietf.org/internet-drafts/draft-seedorf-sipping-spam-score-semantics-00.txt
-- new draft on SIP spam feedback (-00)
http://tools.ietf.org/html/draft-niccolini-sipping-spam-feedback-00

Also an update to the CAPTCHA draft based on recent discussion
will follow, link will be posted as soons as it is submitted.

Cheers,
Saverio

============================================================
Dr. Saverio Niccolini
Senior Researcher
NEC Laboratories Europe, Network Research Division	
Kurfuerstenanlage 36, D-69115 Heidelberg
Tel.     +49 (0)6221 4342-118
Fax:     +49 (0)6221 4342-155
e-mail:  [email-masked] <-- !!! NEW ADDRESS !!!
============================================================
NEC Europe Limited Registered Office: NEC House, 1 Victoria
Road, London W3 6BL Registered in England 2832014

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Monday, February 18, 2008 4:10 PM
> To: Martin Stiemerling; rucus BoF
> Subject: Re: [Rucus] Reading list for BoF
> 
> happened in the 
> > field of SPIT mitigation, i.e., editing a useful reading 
> list for the 
> > rucus bof.
> > 
> and Humans 
> > Apart (CAPTCHA) based Robot Challenges for the Session Initiation 
> > Protocol (SIP)
> > - Spam feedback for SIP 
> (draft-niccolini-sipping-spam-feedback-00.txt)

---

From: "Saverio Niccolini" <[email-masked]>
Date: Mon, 18 Feb 2008 16:43:15 +0100

Hi, 

David just submitted a problem statement draft which I think it is interesting to read:
http://www.ietf.org/internet-drafts/draft-schwartz-rucus-problem-statement-01.txt
(even if my view is more to see RFC5039 as problem statement document legitimating RUCUS)

where there are some nice points made that are also reflected in:
http://www.ietf.org/internet-drafts/draft-seedorf-sipping-spam-score-semantics-00.txt

I see a very important point written there: "Unwanted communication is subjective - not objective"

This is really true and we can not forget it when talking about RUCUS.

A sentence taken from the spam score semantice draft also raises the issue:
"Whether a message is spam or not is not a binary proposition, both
in terms of identifying it (mechanisms will have false positives
and false negatives) and even in judging it (e.g., depending on
user preferences)."

Saverio

> On Behalf Of Saverio Niccolini
> Sent: Monday, February 18, 2008 4:30 PM
> To: rucus BoF

---

From: Dan York <[email-masked]>
Date: Tue, 19 Feb 2008 10:52:57 -0500

With the deadline now passed for new drafts (but with the other  
deadline next Monday for updated drafts), can we get a consolidated  
list of all the relevant updated drafts related to RUCUS?

Are there any others that we need to add to this list?

I think we have now:

-- new version for SPITSTOP draft (-01)
http://tools.ietf.org/html/draft-niccolini-sipping-spitstop-01
-- new version of the spam score draft (-01)
http://tools.ietf.org/html/draft-wing-sipping-spam-score-01
-- new draft on spam score semantics (-00)
http://www.ietf.org/internet-drafts/draft-seedorf-sipping-spam-score- 
semantics-00.txt
-- new draft on SIP spam feedback (-00)
http://tools.ietf.org/html/draft-niccolini-sipping-spam-feedback-00
-- new draft on RUCUS problem statement (-00)
http://www.ietf.org/internet-drafts/draft-schwartz-rucus-problem- 
statement-01.txt
-- new draft of SIP scenarios similar to SPIT (-00)
http://www.ietf.org/internet-drafts/draft-york-sipping-spit- 
similarity-scenarios-00.txt

Along with other existing drafts:

-- Framework for reducing unwanted communication
http://www.ietf.org/internet-drafts/draft-tschofenig-sipping- 
framework-spit-reduction-02.txt
-- CAPTCHA-based Robot Challenges for the Session Initiation Protocol  
(SIP)
http://tools.ietf.org/rfcmarkup?doc=draft-tschofenig-sipping-captcha
-- A Document Format for Expressing Authorization Policies to tackle  
Spam
and Unwanted Communication for Internet Telephony
http://tools.ietf.org/rfcmarkup?doc=draft-tschofenig-sipping-spit-policy

and of course RFC 5039:

   http://tools.ietf.org/rfcmarkup?doc=rfc5039

Regards,
Dan

-- 
Dan York, CISSP, Director of Emerging Communication Technology
Office of the CTO    Voxeo Corporation     [email-masked]
Phone: +1-407-455-5859  Skype: danyork  http://www.voxeo.com
Blogs: http://blogs.voxeo.com  http://www.disruptivetelephony.com

Bring your web applications to the phone.
Find out how at http://evolution.voxeo.com

---

From: Thomas Froment <[email-masked]>
Date: Tue, 19 Feb 2008 17:06:53 +0100

Hi,
I will submit really soon in the repository an update of 'spit policies 
requirements':http://tools.ietf.org/html/draft-froment-sipping-spit-requirements
 which is the requirement document associated to 
http://www.ietf.org/internet-drafts/draft-tschofenig-sipping-framework-spit-reduction-02.txt

Best regards,
Thomas

Dan York wrote:
> http://www.ietf.org/internet-drafts/draft-york-sipping-spit-similarity-scenarios-00.txt
>
> http://www.ietf.org/internet-drafts/draft-tschofenig-sipping-framework-spit-reduction-02.txt
> -- A Document Format for Expressing Authorization Policies to tackle Spam
> <mailto:[email-masked]>
> ------------------------------------------------------------------------
>