Subject: [Rucus] SPIT from operator

From: Pars Mutaf <[email-masked]>
Date: Wed, 8 Jul 2009 18:34:17 +0300

Hello,

I my country, subscribers receive a lot of SPIT from their operators.
In my cell phone experience, the operator itself is the most serious
SPIT problem.

This makes me think that SPIT solutions must be operator independent.

Would you have any comments on that? What is the situation in other
countries? Which solutions can be applied?

Thanks

pars

---

From: "Charzinski, Joachim (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 9 Jul 2009 09:01:30 +0200

Hi Pars,

> This makes me think that SPIT solutions must be operator independent.

I think this is generalizing too much. Solutions against the type of 
SPIT you mention will have to be operator independent (possibly also 
involving some regulatory power that forces operators to respect 
entries on "don't call" lists). The same will be true for the kind of 
Spam distribution services we find with the postal service ("distribute 
this to every household with a street address") - wherever the operator 
actually makes money from Spam or SPIT, it will be necessary to have an 
operator independent solution for fighting Spam and SPIT. 

On the other hand, it is probably the operators that are currently 
preventing large scale SPIT by performing ingress address filtering and 
enforcing rate caps on SIP signalling. Also, in a traditional telephony 
environment, it would be the operator that strips off the origin address 
for anonymous calls, so the operator has more power in filtering SPIT 
than the end user / end device would have. 

Therefore I think we need two solutions that help both parties - the 
operator and the end user - to fight SPIT independently. They may even 
cooperate, but they cannot completely substitute one another. 

> What is the situation in other countries? 

I am living in germany, and I used to get a lot of cold calls, most of 
them machine assisted but actually connecting to a personal agent. Only 
a few calls were completely automated. My cold calls frequency has dropped 
drastically since I started asking the callers for permission to record 
the calls for usage in court. They seem to have deleted my number from 
their address lists. 
If operators didn't interfer (see the above mentioned rate caps and 
address filters), we would probably get a lot more calls, as there are 
a lot of VoIP contracts around where you can reach most of the fixed 
phone network within a flat rate. 

Best regards

	Joachim. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Pars Mutaf
Sent: Wednesday, July 08, 2009 5:34 PM
To: Rucus BoF
Subject: [Rucus] SPIT from operator

Hello,

Thanks

pars
_______________________________________________
Rucus mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rucus

----------------------------------------------------------
Joachim Charzinski

Nokia Siemens Networks
Research, Technology and Platforms 
Research & Technology / Network Evolution
 
St.-Martin-Str. 53
Post box: D-80240 Muenchen
D-81541 Muenchen
Germany
Tel: +49 89 636 79902

[email-masked] 
http://www.nokiasiemensnetworks.com/global/

Think before you print

Nokia Siemens Networks GmbH & Co. KG
Sitz der Gesellschaft: München / Registered office: Munich
Registergericht: München / Commercial registry: Munich, HRA 88537
WEEE-Reg.-Nr.: DE 52984304

Persönlich haftende Gesellschafterin / General Partner: Nokia Siemens Networks Management GmbH
Geschäftsleitung / Board of Directors: Lydia Sommer, Olaf Horsthemke
Vorsitzender des Aufsichtsrats / Chairman of supervisory board: Lauri Kivinen
Sitz der Gesellschaft: München / Registered office: Munich
Registergericht: München / Commercial registry: Munich, HRB 163416

---

From: Pars Mutaf <[email-masked]>
Date: Thu, 9 Jul 2009 13:46:43 +0300

Hi Joachim,

To clarify, I don't receive calls but messages from the operator about
new services,
new songs available as ring tone, and various non-sense stuff. I would
like to filter
these messages on my cell phone. As far as I know, there this no easy way to
inform the operator that I'm not interested in these messages.

We seem to agree that the cell phone should be able to filter operator's SPIT.

Please see below for more...

> than the end user / end device would have.

I am not sure that the operator is willing to filter SPIT. This is
open to discussion.

By the way, I note here that in your operator-based filtering approach, the
operator should forward the messages marked as SPIT to the target cell phone
anyways. This is because the false positive probability is never zero.
The target user should make the decision whether or not a message is SPIT
before deleting a message from inbox.

As a consequence, this makes be believe that operator-based filtering is not
really necessary. Just forward all messages to the target cell phone, the
target cell phone can filter them and store the ones marked as SPIT for
eventual user inspection.

I missed something?

Thanks

pars

---

From: David Schwartz <[email-masked]>
Date: Thu, 9 Jul 2009 13:52:21 +0300

It's a shame Dan Wings proposal (http://tools.ietf.org/html/draft-wing-sipping-spam-score-02) never went anywhere. Basically, it argues that the operator simply "marks" or "scores" a call and passes it on to the recipient for him/her to make the actual accept/reject decision.

D.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pars Mutaf
Sent: Thursday, July 09, 2009 1:47 PM
To: Charzinski, Joachim (NSN - DE/Munich)
Cc: Rucus BoF
Subject: Re: [Rucus] SPIT from operator

Hi Joachim,

I missed something?

Thanks

pars

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Thu, 9 Jul 2009 19:00:30 +0800

Hi

Actually operator can come up with a service of helping the teminating users (called users) to identify the unwanted callers and help them register the unwanted caller identity with the network. Once registered, the calls from the particular caller who was registered as "unwanted" would be prevented from calling. This could be one way of reducing SPIT.

The draft: http://tools.ietf.org/html/draft-avasarala-sipping-reason-header-dynamic-icb-00 proposes a solution of appending a SIP Reason header with new protocol value "block" to indicate to network to block the calling user from future calling.

We are in the process of updating this document and hence comments are welcome.

Thanks

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Schwartz
Sent: Thursday, July 09, 2009 4:22 PM
To: Pars Mutaf; Charzinski, Joachim (NSN - DE/Munich)
Cc: Rucus BoF
Subject: Re: [Rucus] SPIT from operator

D.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pars Mutaf
Sent: Thursday, July 09, 2009 1:47 PM
To: Charzinski, Joachim (NSN - DE/Munich)
Cc: Rucus BoF
Subject: Re: [Rucus] SPIT from operator

Hi Joachim,

To clarify, I don't receive calls but messages from the operator about new services, new songs available as ring tone, and various non-sense stuff. I would like to filter these messages on my cell phone. As far as I know, there this no easy way to inform the operator that I'm not interested in these messages.

On Thu, Jul 9, 2009 at 10:01 AM, Charzinski, Joachim (NSN - DE/Munich)<[email-masked]> wrote:
> Spam distribution services we find with the postal service 
> ("distribute this to every household with a street address") - 
> wherever the operator actually makes money from Spam or SPIT, it will 
> be necessary to have an operator independent solution for fighting Spam and SPIT.
>
> preventing large scale SPIT by performing ingress address filtering 
> and enforcing rate caps on SIP signalling. Also, in a traditional 
> telephony environment, it would be the operator that strips off the 
> origin address for anonymous calls, so the operator has more power in 
> filtering SPIT than the end user / end device would have.

I am not sure that the operator is willing to filter SPIT. This is open to discussion.

By the way, I note here that in your operator-based filtering approach, the operator should forward the messages marked as SPIT to the target cell phone anyways. This is because the false positive probability is never zero.
The target user should make the decision whether or not a message is SPIT before deleting a message from inbox.

As a consequence, this makes be believe that operator-based filtering is not really necessary. Just forward all messages to the target cell phone, the target cell phone can filter them and store the ones marked as SPIT for eventual user inspection.

I missed something?

Thanks

pars

> them machine assisted but actually connecting to a personal agent. 
> Only a few calls were completely automated. My cold calls frequency 
> has dropped drastically since I started asking the callers for 
> permission to record the calls for usage in court. They seem to have 
> deleted my number from their address lists.
> Persönlich haftende Gesellschafterin / General Partner: Nokia Siemens 
> Networks Management GmbH Geschäftsleitung / Board of Directors: Lydia 
> Sommer, Olaf Horsthemke Vorsitzender des Aufsichtsrats / Chairman of 
> supervisory board: Lauri Kivinen Sitz der Gesellschaft: München / 
> Registered office: Munich