Subject: [Rucus] Operator-assisted SPIT filtering (was Re: SPIT from operator)

From: Pars Mutaf <[email-masked]>
Date: Thu, 9 Jul 2009 14:41:45 +0300

On Thu, Jul 9, 2009 at 1:52 PM, David Schwartz<[email-masked]> wrote:
> It's a shame Dan Wings proposal (http://tools.ietf.org/html/draft-wing-sipping-spam-score-02) never went anywhere. Basically, it
> argues that the operator simply "marks" or "scores" a call and passes it on to the recipient for him/her to make the actual
> accept/reject decision.

Sorry I believe I missed that document.

What is the advantage of operator marking and forwarding the message,
over the cell phone marking the message
and storing marked as SPIT?

Perhaps the operator would have more information about SPITers and can
perform better filtering on behalf of users? (I'm not sure about
that). This could be clarified?

Or it is an energy conservation issue?

Thanks,

pars

>
> D.
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Pars Mutaf
> Sent: Thursday, July 09, 2009 1:47 PM
> To: Charzinski, Joachim (NSN - DE/Munich)
> Cc: Rucus BoF
> Subject: Re: [Rucus] SPIT from operator
>
> Hi Joachim,
>
> To clarify, I don't receive calls but messages from the operator about
> new services,
> new songs available as ring tone, and various non-sense stuff. I would
> like to filter
> these messages on my cell phone. As far as I know, there this no easy way to
> inform the operator that I'm not interested in these messages.
>
> We seem to agree that the cell phone should be able to filter operator's SPIT.
>
> Please see below for more...
>
> On Thu, Jul 9, 2009 at 10:01 AM, Charzinski, Joachim (NSN -
> DE/Munich)<[email-masked]> wrote:
>> Hi Pars,
>>
>>> This makes me think that SPIT solutions must be operator independent.
>>
>> I think this is generalizing too much. Solutions against the type of
>> SPIT you mention will have to be operator independent (possibly also
>> involving some regulatory power that forces operators to respect
>> entries on "don't call" lists). The same will be true for the kind of
>> Spam distribution services we find with the postal service ("distribute
>> this to every household with a street address") - wherever the operator
>> actually makes money from Spam or SPIT, it will be necessary to have an
>> operator independent solution for fighting Spam and SPIT.
>>
>> On the other hand, it is probably the operators that are currently
>> preventing large scale SPIT by performing ingress address filtering and
>> enforcing rate caps on SIP signalling. Also, in a traditional telephony
>> environment, it would be the operator that strips off the origin address
>> for anonymous calls, so the operator has more power in filtering SPIT
>> than the end user / end device would have.
>
> I am not sure that the operator is willing to filter SPIT. This is
> open to discussion.
>
> By the way, I note here that in your operator-based filtering approach, the
> operator should forward the messages marked as SPIT to the target cell phone
> anyways. This is because the false positive probability is never zero.
> The target user should make the decision whether or not a message is SPIT
> before deleting a message from inbox.
>
> As a consequence, this makes be believe that operator-based filtering is not
> really necessary. Just forward all messages to the target cell phone, the
> target cell phone can filter them and store the ones marked as SPIT for
> eventual user inspection.
>
> I missed something?
>
> Thanks
>
> pars
>
>
>
>
>>
>> Therefore I think we need two solutions that help both parties - the
>> operator and the end user - to fight SPIT independently. They may even
>> cooperate, but they cannot completely substitute one another.
>>
>>> What is the situation in other countries?
>>
>> I am living in germany, and I used to get a lot of cold calls, most of
>> them machine assisted but actually connecting to a personal agent. Only
>> a few calls were completely automated. My cold calls frequency has dropped
>> drastically since I started asking the callers for permission to record
>> the calls for usage in court. They seem to have deleted my number from
>> their address lists.
>> If operators didn't interfer (see the above mentioned rate caps and
>> address filters), we would probably get a lot more calls, as there are
>> a lot of VoIP contracts around where you can reach most of the fixed
>> phone network within a flat rate.
>>
>> Best regards
>>
>>        Joachim.
>>
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Pars Mutaf
>> Sent: Wednesday, July 08, 2009 5:34 PM
>> To: Rucus BoF
>> Subject: [Rucus] SPIT from operator
>>
>> Hello,
>>
>> I my country, subscribers receive a lot of SPIT from their operators.
>> In my cell phone experience, the operator itself is the most serious
>> SPIT problem.
>>
>> This makes me think that SPIT solutions must be operator independent.
>>
>> Would you have any comments on that? What is the situation in other
>> countries? Which solutions can be applied?
>>
>> Thanks
>>
>> pars
>> _______________________________________________
>> Rucus mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rucus
>>
>> ----------------------------------------------------------
>> Joachim Charzinski
>>
>> Nokia Siemens Networks
>> Research, Technology and Platforms
>> Research & Technology / Network Evolution
>>
>> St.-Martin-Str. 53
>> Post box: D-80240 Muenchen
>> D-81541 Muenchen
>> Germany
>> Tel: +49 89 636 79902
>>
>> [email-masked]
>> http://www.nokiasiemensnetworks.com/global/
>>
>> Think before you print
>>
>> Nokia Siemens Networks GmbH & Co. KG
>> Sitz der Gesellschaft: München / Registered office: Munich
>> Registergericht: München / Commercial registry: Munich, HRA 88537
>> WEEE-Reg.-Nr.: DE 52984304
>>
>> Persönlich haftende Gesellschafterin / General Partner: Nokia Siemens Networks Management GmbH
>> Geschäftsleitung / Board of Directors: Lydia Sommer, Olaf Horsthemke
>> Vorsitzender des Aufsichtsrats / Chairman of supervisory board: Lauri Kivinen
>> Sitz der Gesellschaft: München / Registered office: Munich
>> Registergericht: München / Commercial registry: Munich, HRB 163416
>>
> _______________________________________________
> Rucus mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rucus
>

---

From: Pars Mutaf <[email-masked]>
Date: Thu, 9 Jul 2009 14:49:31 +0300

Hello,

On Thu, Jul 9, 2009 at 2:00 PM, Avasarala
Ranjit-A20990<[email-masked]> wrote:
> Hi
>
> Actually operator can come up with a service of helping the teminating users (called users) to identify the unwanted callers and help them register the unwanted caller identity with the network. Once registered, the calls from the particular caller who was registered as "unwanted" would be prevented from calling. This could be one way of reducing SPIT.
>
> The draft: http://tools.ietf.org/html/draft-avasarala-sipping-reason-header-dynamic-icb-00 proposes a solution of appending a SIP Reason header with new protocol value "block" to indicate to network to block the calling user from future calling.
>
> We are in the process of updating this document and hence comments are welcome.

I am not sure to understand why the target cell phone doesn't drop the
unwanted call itself.

Thanks,

pars

> Regards
> Ranjit
> From: [email-masked] [mailto:[email-masked]] On Behalf Of David Schwartz
> Sent: Thursday, July 09, 2009 4:22 PM
> To: Pars Mutaf; Charzinski, Joachim (NSN - DE/Munich)
> Cc: Rucus BoF
> It's a shame Dan Wings proposal (http://tools.ietf.org/html/draft-wing-sipping-spam-score-02) never went anywhere. Basically, it argues that the operator simply "marks" or "scores" a call and passes it on to the recipient for him/her to make the actual accept/reject decision.
>
> D.
>
> To clarify, I don't receive calls but messages from the operator about new services, new songs available as ring tone, and various non-sense stuff. I would like to filter these messages on my cell phone. As far as I know, there this no easy way to inform the operator that I'm not interested in these messages.
>
> On Thu, Jul 9, 2009 at 10:01 AM, Charzinski, Joachim (NSN - DE/Munich)<[email-masked]> wrote:
>> Hi Pars,
>>
>> Spam distribution services we find with the postal service
>> ("distribute this to every household with a street address") -
>> wherever the operator actually makes money from Spam or SPIT, it will
>> be necessary to have an operator independent solution for fighting Spam and SPIT.
>>
>> preventing large scale SPIT by performing ingress address filtering
>> and enforcing rate caps on SIP signalling. Also, in a traditional
>> telephony environment, it would be the operator that strips off the
>> origin address for anonymous calls, so the operator has more power in
>> filtering SPIT than the end user / end device would have.
>
> I am not sure that the operator is willing to filter SPIT. This is open to discussion.
>
> By the way, I note here that in your operator-based filtering approach, the operator should forward the messages marked as SPIT to the target cell phone anyways. This is because the false positive probability is never zero.
> The target user should make the decision whether or not a message is SPIT before deleting a message from inbox.
>
> As a consequence, this makes be believe that operator-based filtering is not really necessary. Just forward all messages to the target cell phone, the target cell phone can filter them and store the ones marked as SPIT for eventual user inspection.
>
> I missed something?
>
> Thanks
>
> pars
>
>
>
>
>>
>> them machine assisted but actually connecting to a personal agent.
>> Only a few calls were completely automated. My cold calls frequency
>> has dropped drastically since I started asking the callers for
>> permission to record the calls for usage in court. They seem to have
>> deleted my number from their address lists.
>> Persönlich haftende Gesellschafterin / General Partner: Nokia Siemens
>> Networks Management GmbH Geschäftsleitung / Board of Directors: Lydia
>> Sommer, Olaf Horsthemke Vorsitzender des Aufsichtsrats / Chairman of
>> supervisory board: Lauri Kivinen Sitz der Gesellschaft: München /
>> Registered office: Munich

---

From: David Schwartz <[email-masked]>
Date: Thu, 9 Jul 2009 14:49:53 +0300

Hi

> and storing marked as SPIT?

The operator has much more information to base a decision on (including input he gets from the endpoint) than the endpoint has. The operator can "share" information better with other users (including ones who did not actually mark the particular caller) as well. Email systems have been doing this for years where a spam indication by one of its members is propagated to others.

> that). This could be clarified?

My point is, that regardless of the actual SPAM indication harvesting technique (e.g. the receiving user "blocked" the call), without the ability to warn others as well the information is of limited value - hence my reference to the Wing draft.

> Or it is an energy conservation issue?

:)

Thanks,

pars

---

From: Pars Mutaf <[email-masked]>
Date: Thu, 9 Jul 2009 15:00:35 +0300

Hello,

On Thu, Jul 9, 2009 at 2:49 PM, David Schwartz<[email-masked]> wrote:
> The operator has much more information to base a decision on (including input he gets from the endpoint) than the endpoint has.
> The operator can "share" information better with other users (including ones who did not actually mark the particular caller) as well. > Email systems have been doing this for years where a spam indication by one of its members is propagated to others.

Is there any reference for this? (if not too difficult to find any).
In my view, there may exist messages marked as spam by one user, that
may not be considered as spam by other users.
I mean, users may have different spam criteria.

In any case I would suggest that these points be clarified. They don't
seem obvious to me.

Thanks,

pars

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Thu, 9 Jul 2009 20:00:55 +0800

Hi

Comments inline <Ranjit> 

Regards
Ranjit

-----Original Message-----
From: Pars Mutaf [mailto:[email-masked]] 
Sent: Thursday, July 09, 2009 5:20 PM
To: Avasarala Ranjit-A20990
Cc: David Schwartz; Charzinski, Joachim (NSN - DE/Munich); Rucus BoF; Victor Pascual Avila
Subject: Operator-assisted SPIT filtering (was Re: [Rucus] SPIT from operator)

Hello,

> We are in the process of updating this document and hence comments are welcome.

I am not sure to understand why the target cell phone doesn't drop the unwanted call itself.
<Ranjit> The target call phone understands that the caller is unwanted (E.g. telemarketer) only after speaking. So after speaking the target call phone decides to block the caller from further calling.  The target call phone can also block the caller even without speaking (i.e. dropping the call) and blocking the caller.

Thanks,

pars

>> operator and the end user - to fight SPIT independently. They may 
>> even cooperate, but they cannot completely substitute one another.
>>
>> I am living in germany, and I used to get a lot of cold calls, most 
>> of them machine assisted but actually connecting to a personal agent.
>> address filters), we would probably get a lot more calls, as there 
>> are a lot of VoIP contracts around where you can reach most of the 
>> fixed phone network within a flat rate.
>>
>> Best regards
>>
>>        Joachim.
>>
>>

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Thu, 9 Jul 2009 20:03:43 +0800

True. That is the reason why an Operator cannot mark any caller or call
as spam. Only the target users can mark a particular caller or a call as
unwanted or malicious and may want to block the caller from further
calling. 

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Pars Mutaf
Sent: Thursday, July 09, 2009 5:31 PM
To: David Schwartz
Cc: Rucus BoF
Subject: Re: [Rucus] Operator-assisted SPIT filtering (was Re: SPIT
fromoperator)

Hello,

>> over the cell phone marking the message and storing marked as SPIT?
>
> The operator has much more information to base a decision on
(including input he gets from the endpoint) than the endpoint has.
> The operator can "share" information better with other users
(including ones who did not actually mark the particular caller) as
well. > Email systems have been doing this for years where a spam
indication by one of its members is propagated to others.

Thanks,

pars

>
>> Perhaps the operator would have more information about SPITers and 
>> can perform better filtering on behalf of users? (I'm not sure about 
> My point is, that regardless of the actual SPAM indication harvesting
technique (e.g. the receiving user "blocked" the call), without the
ability to warn others as well the information is of limited value -
hence my reference to the Wing draft.

---

From: <[email-masked]>
Date: Thu, 9 Jul 2009 16:11:41 +0200

When I hear that spit solutions must be "operator independent", I feel that some basic facts from an email perspective need to be recalled, because the points that are being discussed in this thread are only relevant to a nice world with what is still very small amounts of spit.

We would simply not be conversing by email right now if ISPs were not filtering 80% to 99% of abusive emails (notice I did not say "spam" on purpose) and preventing them from reaching your computer. Perhaps we would still be using faxes (?) if the email filtering had been left as an exclusive responsiblity of the end-user. Email would be dead, in short.

Of course the called party must have some control over the filtering, based on his own criteria, which are not those of the operator. Therefore a caller blacklist, managed by the end-user and hosted in the terminal or by the operator, can be an interesting functionality, but its usefulness will depend on how easy it is for the caller to adopt a new identity. A mechanism for reporting spit to the operator or to a third party (like law enforcement for instance) might perhaps be more useful, but only if it can be established that the reported spit is illegal. Legislation on spit is far from being clearly established yet, anywhere in the world, and will probably be late by a couple of battles.

The filtering criteria of the operator are different from the end-user's. The goal of the operator is to protect the service from being submerged by spit, thus destroying its business model (no business model, no service, I'm sorry). Competing email operators do exchange information on abusive email traffic (with FBLs - feedback loops), because what is hurting one is hurting all email providers, small or large. They also use real time blocklists (RBL) which they manage themselves if they have the resources, or which are provided by third parties.

What is interesting is that even though legislation on spam is more mature, email providers strictly speaking do not "block spam" at network level, they block what they consider as "abusive email". That's for 2 reasons: first, in most jurisdictions, fortunately, operators do not have the right to filter content. The second reason is simply the huge scale of the spam phenomenon. However, email is still a comunication tool of acceptable quality and great usefulness to all, citizens and the global economy alike. With most email providers, the amount of false positives or false negatives is exceedingly small in relation to the quantity of trash they have to process every second. And because they know this, authorities tolerate the filtering applied by email providers on their own criteria.

I am sorry if all of the above is obvious, but my number one fear is to see the mistakes of the smtp world be repeated in the sip world. With voip calls gradually becoming so cheap as to become almost as free as email, we must be extra careful, and we must not adopt exclusionary stances before the problem is solved. I sincerely hope that spit will never reach email spam levels and that more control on spit filtering can be handed over to the user, but keeping the operator out would be a mistake.

Regards,
Luc
(true, I work for an operator; true, I am involved in www.maawg.org)

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> De la part de Avasarala Ranjit-A20990
> Envoyé : jeudi 9 juillet 2009 14:04
> À : Pars Mutaf; David Schwartz
> Cc : Rucus BoF
> Objet : Re: [Rucus] Operator-assisted SPIT filtering (was Re: 
> SPITfromoperator)
> 
> True. That is the reason why an Operator cannot mark any 
> caller or call as spam. Only the target users can mark a 
> particular caller or a call as unwanted or malicious and may 
> want to block the caller from further calling. 
> 
> Regards
> Ranjit
> 
> (including ones who did not actually mark the particular 
> caller) as well. > Email systems have been doing this for 
> years where a spam indication by one of its members is 
> propagated to others.
> 
> In my view, there may exist messages marked as spam by one 
> user, that may not be considered as spam by other users.
> In any case I would suggest that these points be clarified. 
> They don't seem obvious to me.
> 
> Thanks,
> 
> pars
> 
> >
> technique (e.g. the receiving user "blocked" the call), 
> without the ability to warn others as well the information is 
> of limited value - hence my reference to the Wing draft.
> >

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Fri, 10 Jul 2009 00:49:50 +0800

Hi Luc

Actually operator is in the loop in the sense that by offering the Communication Barring service. This is the enhancement to Incoming Communication Barring service as defined in 3GPP TS 22.173.  Here the operator offers the enhanced ICB service and the terminating users indicate to the network (operator) that a particular caller / call is unwanted in nature and wish to block the caller from further calling. Once the operator receives this request from the user, the operator would create a black list (could be an additional one to if there is already one existing) and add the caller details to the list.

Next time when a call from the same caller arrives, the black list for the called user is checked and if there is an entry for the calling user, his or her call is rejected. 

In SIP based networks, this mechanism can be achieved by proposing a new protocol value "block" for the SIP Reason header which can be appended to SIP BYE message or SIP 4xx message to block the caller either during call termination or call alerting stages.  The sip server at the operator looks for the Reason header in the incoming BYE or 4xx message and if the protocol value is "block" retrieves the block details and updates the black list for the called user.

More details on this mechanism are defined in  http://tools.ietf.org/html/draft-avasarala-sipping-reason-header-dynamic-icb-00.

Comments welcome

Thanks
 
Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 09, 2009 7:42 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Rucus] Operator-assisted SPIT filtering (was Re:SPITfromoperator)

Regards,
Luc

> De : [email-masked] [mailto:[email-masked]] De la part 
> de Avasarala Ranjit-A20990 Envoyé : jeudi 9 juillet 2009 14:04 À : 
> Pars Mutaf; David Schwartz Cc : Rucus BoF Objet : Re: [Rucus] 
> Operator-assisted SPIT filtering (was Re:
> SPITfromoperator)
> 
> True. That is the reason why an Operator cannot mark any caller or 
> call as spam. Only the target users can mark a particular caller or a 
> call as unwanted or malicious and may want to block the caller from 
> further calling.
> 
> Regards
> Ranjit
> 
> caller) as well. > Email systems have been doing this for years where 
> a spam indication by one of its members is propagated to others.
>