Subject: Re: [saag] SHA-1 to SHA-n transition

From: Peter Gutmann <[email-masked]>
Date: Wed, 04 Mar 2009 19:41:08 +1300

Jeffrey Hutzelman <jhutz at cmu.edu> writes:

>You seem to imply that only weird technical people have or use more than one
>computer. This is certainly not true; many people have a computer at home and
>one at work, and many of those are quite non-technical. Computers have become
>commonplace desktop items both in the home and in the office.

Thanks, you just won me $20.

(The wager was that, no matter how many disclaimers and explanatory comments I 
add (e.g. "not perfect but works for most of the people most of the time and 
it's a damn sight better than what we have now"), someone will always, always 
pipe up with some variation of "I own eight computers and this would never 
work for me and therefore it won't work for anyone else either".  As long as 
there are at least 2-3 geeks in the audience and they're not HCI people, this 
one never fails).

>Also, telling people "if the disk on your home PC dies, your life is over" is
>a good way to get them _not_ to use a scheme like this.

How is this different from the fact that if the never-backed-up 250GB disk
full of financial records, family photos, personal letters, and business data
on their PC dies their life is over anyway, whether there's crypto info on
there or not?  If you think that having to do a password reset for the few
critical accounts that actually matter and re-enrolling for
www.knittingpatterns.com is in the same league as losing your business account
records and the last photos taken of your parents before they passed away then
you seem to have a somewhat odd interpretation of "a life" :-).

Peter.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 4 Mar 2009 05:34:43 -0800

We are now into the identity issue which has precisley nothing to do with algorithm transitions. Even if a 'real' PKI was deployed it would still suffer from deployment deadlock issues.

We do in fact have an example of a fairly widely deployed system that works in precisely the way Peter suggests, Windows CardSpace. It is a way for a machine to give a solid non-portable authentication credential tied to an account.

I think that it is perfectly reasonable to divide the problem into two - solid machine based credentials and portable credentials.

And I do note that whenever we have any debate that there is always someone who leaps in with a requirement that is purportedly blocking and tells us that it proves that the idea is utterly impossible, can't be solved, not ever no way no how. 

And often it is for a group of users that the speaker has no direct connection with. Whenever we suggest dropping support for something genuinely obsolete there will be someone who claims that it is still in use 'in Africa', as if there is a third world time warp that forces them to use obsolete software as well as obsolete hardware...

The machine portability issue is real, it can even be solved inexpensively using cell phones and PDAs that have the ability to run a downloaded OTP application.

-----Original Message-----
From: [email-masked] on behalf of Peter Gutmann
Sent: Wed 3/4/2009 1:41 AM
To: [email-masked]; [email-masked]
Subject: Re: [saag] SHA-1 to SHA-n transition

Peter.
_______________________________________________
saag mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/saag

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Wed, 04 Mar 2009 11:21:39 -0500

--On Wednesday, March 04, 2009 07:41:08 PM +1300 Peter Gutmann 
<[email-masked]> wrote:

> (The wager was that, no matter how many disclaimers and explanatory
> comments I  add (e.g. "not perfect but works for most of the people most
> of the time and  it's a damn sight better than what we have now"),
> someone will always, always  pipe up with some variation of "I own eight
> computers and this would never  work for me and therefore it won't work
> for anyone else either".  As long as  there are at least 2-3 geeks in the
> audience and they're not HCI people, this  one never fails).

I don't think you won your wager.  I said nothing of the sort.
What I said was that _most_ people use more than one computer.
Not own, just use.  Not eight, just "more than one".

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Wed, 04 Mar 2009 11:32:04 -0500

--On Wednesday, March 04, 2009 05:34:43 AM -0800 "Hallam-Baker, Phillip" 
<[email-masked]> wrote:

> We are now into the identity issue which has precisley nothing to do with
> algorithm transitions.

Thanks for bringing us back around to the original point.  I'm not sure how 
we got into talking about identity and user credentials, but I seem to 
recall this thread started with a discussion of hash algorithm transition, 
and rather quickly moved away from that topic without any real resolution. 
Can we perhaps get back to discussing a technical problem we can solve, 
instead of one that is outside our expertise?

-- Jeff

---

From: Theodore Tso <[email-masked]>
Date: Wed, 4 Mar 2009 13:16:35 -0500

> Not own, just use.  Not eight, just "more than one".

How many people have a laptop plus an iPhone, for example?   :-)

Maybe even a non-techie's Macbook?

    	 	       	      	      	      - Ted

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 4 Mar 2009 10:34:57 -0800

Thanks Jeff.

At this point I think that it is clear that we can solve this problem, albeit with solutions that are somewhat 'yukky'. The most important questions in my mind are:

* Is the deployment deadlock problem real?
* Is the problem significant enough to add a barnacle to SSL or PKIX?

The problem with barnacles is not the individual barnacle, its the fact that they accumulate and eventually slow the ship down. I don't see the 'yuk' factor as being trivial. On the other hand a deployment deadlock on SHA-n makes me nervous.

-----Original Message-----
From: Jeffrey Hutzelman [mailto:[email-masked]]
Sent: Wed 3/4/2009 11:32 AM
To: Hallam-Baker, Phillip; Peter Gutmann; [email-masked]
Cc: [email-masked]
Subject: RE: [saag] SHA-1 to SHA-n transition

-- Jeff

---

From: Bill Sommerfeld <[email-masked]>
Date: Wed, 04 Mar 2009 10:43:42 -0800

> Maybe even a non-techie's Macbook?

or a gaming console with a network connection and a web browser?

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 4 Mar 2009 10:48:15 -0800

There are nine machines that have a keyboard and display in the house, but I only use three of them on a regular basis.

I think that is the point. Even if I end up having to register or pair each machine, that is three registrations, and once that is done I should have seamless access across all three machines.

Basically any scheme that is robust enough to cope with the fact that desktops have a five year max lifespan and laptops typically two is going to be able to cope with the degree of portability that most users require.

Having spent a whole night last week trying to install ubuntu, only to discover that the official 'CD-ROM' distribution is too large to fit on a CD-ROM, I am somewhat skeptical as to the claims made by techies as to usability. Incidentally, that is also the reason that hardware has a more limited effective life than folk imagine.

-----Original Message-----
From: [email-masked] on behalf of Theodore Tso
Sent: Wed 3/4/2009 1:16 PM
To: Jeffrey Hutzelman
Cc: [email-masked]
Subject: Re: [saag] SHA-1 to SHA-n transition

    	 	       	      	      	      - Ted