Subject: [saag] FW: New Version Notification for draft-moriarty-pkcs12v1-1-00.txt

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 14 Jan 2013 07:44:59 -0500

FYI - RSA has submitted PKCS 12 v1.1 as an individual draft.  Please review and provide comments.

Thanks,
Kathleen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, January 14, 2013 7:09 AM
To: Moriarty, Kathleen
Cc: [email-masked]; Parkinson, Sean; Rusch, Andreas; Scott, Michael2
Subject: New Version Notification for draft-moriarty-pkcs12v1-1-00.txt

A new version of I-D, draft-moriarty-pkcs12v1-1-00.txt
has been successfully submitted by Kathleen M. Moriarty and posted to the
IETF repository.

Filename:	 draft-moriarty-pkcs12v1-1
Revision:	 00
Title:		 PKCS 12 v1.1: Personal Information Exchange Syntax
Creation date:	 2013-01-14
WG ID:		 Individual Submission
Number of pages: 27
URL:             http://www.ietf.org/internet-drafts/draft-moriarty-pkcs12v1-1-00.txt
Status:          http://datatracker.ietf.org/doc/draft-moriarty-pkcs12v1-1
Htmlized:        http://tools.ietf.org/html/draft-moriarty-pkcs12v1-1-00

Abstract:
   This standard describes a transfer syntax for personal identity
   information, including private keys, certificates, miscellaneous
   secrets, and extensions.  Machines, applications, browsers, Internet
   kiosks, and so on, that support this standard will allow a user to
   import, export, and exercise a single set of personal identity
   information.  This standard supports direct transfer of personal
   information under several privacy and integrity modes.

The IETF Secretariat

---

From: Yoav Nir <[email-masked]>
Date: Mon, 14 Jan 2013 13:23:50 +0000

Hi Kathleen

Quickly browsing the draft, I am missing something. 

PKCS12 is very widely implemented (OpenSSL, Windows, Mac OS Keychain, iOS, various vendor products). Is this draft a v1.1 to the v1 that's out there, or are all of these already v1.1 and this is documenting or codifying existing practice. 

Would a file conforming to this syntax be usable by any or all of these implementations (modulu bugs)?

I think this draft would be an excellent candidate for an "Implementation Status" section[1].

Yoav

[1] http://tools.ietf.org/html/draft/sheffer-running-code-01

On Jan 14, 2013, at 2:44 PM, "Moriarty, Kathleen" <[email-masked]>
 wrote:

> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
> 
> Email secured by Check Point

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 14 Jan 2013 08:56:41 -0500

Hello Yoav,

RSA published version 1.1 and this matches the updated version and us s contribution to move the standard into the IETF.

I'll see if we can pull together an implementation status section on this revision.

Best regards,
Kathleen

Sent from my iPhone

---

From: Yoav Nir <[email-masked]>
Date: Mon, 14 Jan 2013 13:58:56 +0000

Yes, that's reference [18].

What are the differences between what's out there (v1?)

Yoav

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 14 Jan 2013 09:16:22 -0500

Both versions are available on the RSA website.  I am limited to an iPhone at the moment, if needed, I could provide the differences to the SAAG list.  You should be able to see both versions at the following link.

Http://rsa.com/rsalabs/node.asp?id=2138

Best regards,
Kathleen

Sent from my iPhone

---

From: Steven Bellovin <[email-masked]>
Date: Mon, 14 Jan 2013 12:13:41 -0500

> RSA published version 1.1 and this matches the updated version and us s contribution to move the standard into the IETF.
And to hand change control over to the IETF?  That's a requirement for 
IETF-published standards-track documents.

		--Steve Bellovin, https://www.cs.columbia.edu/~smb

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 14 Jan 2013 12:17:19 -0500

Yes!

Sent from my iPhone

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 14 Jan 2013 10:21:50 -0800

> Both versions are available on the RSA website.  I am limited to an iPhone at the moment, if needed, I could provide the differences to the SAAG list.  You should be able to see both versions at th…

A list of differences *in the draft* would be most useful.

--Paul Hoffman

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Wed, 16 Jan 2013 16:19:14 -0500

Here are a list of the differences from Version 1 to 1.1:

- Addition of hash algorithms.
- Incorporation of Technical Corrigendum #1, which makes some minor corrections
        to the ASN.1 syntax.
- Removal of 1024 bits as an example for the iteration count out of the ASN.1 syntax.
- Addition of a recommendation that the technique in Appendix B no longer be used
        for a specific mode (password privacy mode) and that techniques from
        PKCS#5 v2.1 be used instead.
- Addition of comments and minor corrections to the ASN.1 module in Appendix C.
- Removal of the export regulations discussion in the former Appendix D.
- Replacement of RSA with EMC in the “Intellectual property considerations”.
- Many changes and additions to the references.
- A reference was added to SP 800-132 for its recommendations on selection of a
        the iteration count value for password integrity (part of dictionary
        attack resistance).

I can put the diff in the appendix of the draft, just didn't think it would be a common thing to do given version 1.1 is the first IETF draft.

Best regards,
Kathleen
________________________________________
From: Paul Hoffman [[email-masked]]
Sent: Monday, January 14, 2013 1:21 PM
To: Moriarty, Kathleen
Cc: [email-masked]
Subject: Re: [saag] New Version Notification for        draft-moriarty-pkcs12v1-1-00.txt

--Paul Hoffman

---

From: Simon Josefsson <[email-masked]>
Date: Sun, 27 Jan 2013 15:01:58 +0100

Hi,

I'm happy to see this move to the IETF.  However there are several
things in PKCS#12 that are showing signs of age.  Therefor, I believe it
would make some sense to split this effort into two parts:

1) Publish a document that describes what is deployed out there.  This
could be version 1.0 of PKCS#12 with additional notes needed for
interoperability and completeness.

2) Publish a document that describes what can be recommended to solve
the same problem.  It would use modern password derivation methods,
encryption algorithms and modes.

Specific comments:

* Document status.  The draft says "Standards Track" but all other PKCS
  documents have been published as Informational.

* Appendix A is not referenced from anywhere in the body of the
  document.  What is it's role?

* The password derivation algorithm in Appendix B seems old, and indeed
  PKCS#5 PBKDF2 should be used instead -- however it says the described
  method is still used in some situations.  I think a new version of a
  spec in this area should use PKCS#5 PBKDF2 instead.  Or does it talk
  about implementations?  The wording is not clear.

* Appendix B uses PBES1 which is not recommended.

* Appendix B describe some OIDs for PKCS#5 PBES1, but does not mention
  any modern ciphers like AES.

* Appendix D contains copyright, patent and trademark information.
  Normally that doesn't belong in IETF documents.

* It would be nice to expand or discuss the background of the acronym
  "PFX".

/Simon

"Moriarty, Kathleen" <[email-masked]> writes:

> URL:
> http://www.ietf.org/internet-drafts/draft-moriarty-pkcs12v1-1-00.txt

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Sun, 27 Jan 2013 20:50:00 -0500

Hi Simon,

Thank you for the review!  I will try to update the draft later in the week and post it as soon as possible.  

I meant to make the draft informational since it is submitted as an individual draft, so I will be sure to correct that.  

I'll concentrate on this draft for now.  Might it be good to have this version published similar to the PKCS #12 v1.1 and a -bis or new document update from there with your #2 suggestion? 

Thank you,
Kathleen 
________________________________________
From: Simon Josefsson [[email-masked]]
Sent: Sunday, January 27, 2013 9:01 AM
To: Moriarty, Kathleen
Cc: [email-masked]
Subject: Re: FW: New Version Notification for draft-moriarty-pkcs12v1-1-00.txt

Hi,

Specific comments:

/Simon

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 27 Jan 2013 18:42:22 -0800

> I meant to make the draft informational since it is submitted as an individual draft, so I will be sure to correct that.  

Errr, that's a non sequitur. Drafts written by individuals can be on Standards Track. 

> encryption algorithms and modes.

I think that his suggestion is a good one. Have two drafts going at once: an Informational RFC describing PKCS #12 1.0 (including things that have been found in current practice), and a Standards Track RFC defining PKCS#12 1.1 that fixes the issues with 1.0.

--Paul Hoffman

---

From: Simon Josefsson <[email-masked]>
Date: Mon, 28 Jan 2013 22:54:47 +0100

"Moriarty, Kathleen" <[email-masked]> writes:

> I meant to make the draft informational since it is submitted as an
> individual draft, so I will be sure to correct that.

Thank you.

> I'll concentrate on this draft for now.  Might it be good to have this
> version published similar to the PKCS #12 v1.1 and a -bis or new
> document update from there with your #2 suggestion?

The PKCS#12 v1.1 draft is valuable to the IETF community, but it
currently doesn't appear to solve either of these problems:

1) Having PKCS#12 version 1.0 under IETF's control.  It is widely
implemented and deployed by many Internet applications.

2) Describing something that is secure that solves the same problem.

Still, with your publication, I have become more optimistic that we will
see either or both of these problems addressed in the future.  I was
expressing a hope that you might address them while you were doing the
PKCS#12 v1.1 work.

Btw, if permission can be negotiated with the copyright holder to submit
PKCS#12 version 1.0 (and its technical corrigendum) to the IETF, I'd be
happy to do the work to put that in IETF draft form.  With proper
security considerations, and hopefully interop considerations (but
better to publish without it than to not publish), that document could
be published as INFORMATIONAL.

/Simon