Subject: [saag] Please review draft-iab-crypto-alg-agility-00.txt

From: Russ Housley <[email-masked]>
Date: Thu, 6 Mar 2014 08:59:11 -0500

I gave a presentation in the SAAG session today.  Once we get the content right, the Security ADs have agreed to sponsor it for BCP.  So, please review and comment so that we can get the content right soon.

Thanks,
  Russ

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 06 Mar 2014 15:46:57 +0000

On 03/06/2014 01:59 PM, Russ Housley wrote:
> I gave a presentation in the SAAG session today.  Once we get the
> content right, the Security ADs have agreed to sponsor it for BCP.
> So, please review and comment so that we can get the content right
> soon.

And its short!

S

> 
> Thanks, Russ
> 
> _______________________________________________ saag mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/saag
> 
>

---

From: "Black, David" <[email-masked]>
Date: Mon, 10 Mar 2014 21:40:10 -0400

The draft generally looks quite good - here are 3 quick comments:

-1- Section 2.2:

   Some cryptographic algorithms are inherently tied to a specific key
   size, but others allows many different key sizes.  When more than one
   key size is available, the algorithm specification MUST identify the
   specific sizes that are to be supported.

AES CCM and GCM also have multiple sizes of ICVs (Integrity Check Values)
for which an analogous MUST should be included, perhaps in the form of a
general statement about other aspects of the algorithm, with ICV size as
an example. 

-2- Section 2.3 could be blunter - if the weak algorithm does not provide
acceptable security, the protocol needs to be configurable and configured
to neither offer, accept nor use that algorithm.

-3- Section 3.2

   When a protocol specifies a single mandatory-to-implement algorithm
   for integrity and authentication,

What about encryption?  The rest of the paragraph appears to be applicable to
encryption algorithms, although the second and final paragraph in that
section is specific to integrity. 

Thanks,
--David

> -----Original Message-----
> From: saag [mailto:[email-masked]] On Behalf Of Russ Housley
> Sent: Thursday, March 06, 2014 8:59 AM
> To: IETF SAAG
> Subject: [saag] Please review draft-iab-crypto-alg-agility-00.txt
> 
> I gave a presentation in the SAAG session today.  Once we get the content
> right, the Security ADs have agreed to sponsor it for BCP.  So, please review
> and comment so that we can get the content right soon.
> 
> Thanks,
>   Russ
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag