Subject: [saag] FW: New Version Notification for draft-farrelll-mpls-opportunistic-encrypt-03.txt

From: Stephen Farrell <[email-masked]>
Date: Tue, 28 Oct 2014 00:10:09 +0000

Hiya,

The Farrelll twins have been playing with the concept of opportunistic
encryption for MPLS. This is very much positioned as an experiment.

We'd like to hear from people who are interested in this as an idea we
should look into further.

And, of course, we'd love to discuss the ideas in the draft.

Adrian and Stephen

PS: A similar message has been sent to the mpls wg list. Feel free to
discuss using whichever venue is best, but please try cc the draft
alias above as we're not both subscribed to both lists;-)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 26 October 2014 23:16
> To: Adrian Farrel; Stephen Farrell; Adrian Farrel; Stephen Farrell
> Subject: New Version Notification for draft-farrelll-mpls-opportunistic-encrypt-
> 03.txt
> 
> 
> A new version of I-D, draft-farrelll-mpls-opportunistic-encrypt-03.txt
> has been successfully submitted by Adrian Farrel and posted to the
> IETF repository.
> 
> Name:		draft-farrelll-mpls-opportunistic-encrypt
> Revision:	03
> Title:		Opportunistic Security in MPLS Networks
> Document date:	2014-10-26
> Group:		Individual Submission
> Pages:		30
> URL:            http://www.ietf.org/internet-drafts/draft-farrelll-mpls-opportunistic-
> encrypt-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-farrelll-mpls-opportunistic-
> encrypt/
> Htmlized:       http://tools.ietf.org/html/draft-farrelll-mpls-opportunistic-encrypt-
> 03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-farrelll-mpls-opportunistic-
> encrypt-03
> 
> Abstract:
>    This document describes a way to apply opportunistic security
>    between adjacent nodes on an MPLS Label Switched Path (LSP) or
>    between end points of an LSP.  It explains how keys may be agreed
>    to enable encryption, and how key identifiers are exchanged in
>    encrypted MPLS packets.  Finally, this document describes the
>    applicability of this approach to opportunistic security in MPLS
>    networks with an indication of the level of improved security as
>    well as the continued vulnerabilities.
> 
>    This document does not describe security for MPLS control plane
>    protocols.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Randy Bush <[email-masked]>
Date: Tue, 28 Oct 2014 11:44:40 +0900

trying to put a P in mpls-based VNs, eh?  a bit of porcine maquillage.
shame lsps are only protected against wiretap on the hop.  but better
then running nekkid, i guess.  go for it.

randy