Subject: [saag] PKCS #9 LDAP Registrations New Version Notification for draft-seantek-ldap-pkcs9-01.txt

From: Sean Leonard <[email-masked]>
Date: Sat, 08 Nov 2014 07:23:56 -0800

Hello pkix/saag:

In September I published an initial Internet-Draft on registering PKCS 
#9 values (such as dateOfBirth and userPKCS12) in the IANA LDAP 
Parameters registry.

I got a few comments from the ldap list, so I revised it to -01 last 
month. Since IETF 91 is coming up, I thought I would at least inform 
these lists of the work. A lot of security software (such as OpenSSL) 
uses LDAP Parameters with varying degrees of (in)formality, so the 
purpose of this short 7-page draft is just to finish off what PKCS #9 
started.

Comments welcome. Thanks,

Sean

Begin forwarded message:

> *From: [email-masked] <mailto:[email-masked]>
> *Subject: **New Version Notification for draft-seantek-ldap-pkcs9-01.txt*
> *Date: *October 26, 2014 at 3:56:06 PM PDT
> *To: *Sean Leonard <[email-masked] 
> <mailto:[email-masked]>>, "Sean Leonard" <[email-masked] 
> <mailto:[email-masked]>>
>
>
> A new version of I-D, draft-seantek-ldap-pkcs9-01.txt
> has been successfully submitted by Sean Leonard and posted to the
> IETF repository.
>
> Name:draft-seantek-ldap-pkcs9
> Revision:01
> Title:Lightweight Directory Access Protocol (LDAP) Registrations for 
> PKCS #9
> Document date:2014-10-26
> Group:Individual Submission
> Pages:7
> URL: http://www.ietf.org/internet-drafts/draft-seantek-ldap-pkcs9-01.txt
> Status: https://datatracker.ietf.org/doc/draft-seantek-ldap-pkcs9/
> Htmlized: http://tools.ietf.org/html/draft-seantek-ldap-pkcs9-01
> Diff: http://www.ietf.org/rfcdiff?url2=draft-seantek-ldap-pkcs9-01
>
> Abstract:
>   PKCS #9 includes several useful definitions that are not yet
>   reflected in the LDAP IANA registry. This document adds those
>   definitions to the IANA registry.
>
> The IETF Secretariat
>

---

From: Sean Turner <[email-masked]>
Date: Mon, 10 Nov 2014 13:06:04 -1000

RFC 4510 is kind of a lame LDAP security reference because it just says this:

  LDAP security considerations are discussed in each document
  comprising the technical specification.

Maybe 4512 is better because it at least mentions privacy.  Because I’m sure you’re going to get hit with a “where’s your privacy considerations” maybe you should have a look at the SCIM draft:

http://datatracker.ietf.org/doc/draft-ietf-scim-core-schema/?include_text=1

At a minimum you’re going to note which of these elements are privacy sensitive.  You may end up saying those identified elements must be returned over a protected channel.

spt

On Nov 08, 2014, at 05:23, Sean Leonard <[email-masked]> wrote:

> Hello pkix/saag:
> 
> In September I published an initial Internet-Draft on registering PKCS #9 values (such as dateOfBirth and userPKCS12) in the IANA LDAP Parameters registry.
> 
> I got a few comments from the ldap list, so I revised it to -01 last month. Since IETF 91 is coming up, I thought I would at least inform these lists of the work. A lot of security software (such as OpenSSL) uses LDAP Parameters with varying degrees of (in)formality, so the purpose of this short 7-page draft is just to finish off what PKCS #9 started.
> 
>> From: [email-masked]
>> Subject: New Version Notification for draft-seantek-ldap-pkcs9-01.txt
>> Date: October 26, 2014 at 3:56:06 PM PDT
>> To: Sean Leonard <[email-masked]>, "Sean Leonard" <[email-masked]>
>> 
>> 
>> Name:  draft-seantek-ldap-pkcs9
>> Revision: 01
>> Title:
>> 
>>             
>> 
>>             
>> Lightweight Directory Access Protocol (LDAP) Registrations for PKCS #9
>> Document date: 2014-10-26
>> Group:
>> 
>>             
>> 
>>             
>> Individual Submission
>> Pages:
>> 
>>             
>> 
>>             
>> 7
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag