Subject: [saag] Effects of Ubiquitous Encryption Draft: Caching in Mobile Networks

From: Natasha Rooney <[email-masked]>
Date: Thu, 11 Jun 2015 02:58:43 +0000

Hi all!

First time post to this mailing list for me to please excuse any process mistakes! I have collected some information on caching in mobile networks (and on mobile) for the Ubiquitous Encryption draft. A lot of this information comes from academic studies and information that some mobile operators are willing to share. This is not my area of expertise so I am happy to hear any suggestion for changes. Also I would like to say that I support this draft not as a way to mitigate these issues but as one place which shows the effects of ubiquitous encryption for the IETF and the wider community. Many thanks and let me know if you have any questions!

Natasha

New suggested content below:

2.1.X.  Caching in Mobile Networks

Mobile networks operate a centralised architecture; traffic traverses through a small number of packet-gateways within the Core Network before reaching the internet[1]. These centralised architectures have lead mobile network operators to cache content. Forward caching is used in most cases [4].

Caching tends to occur in the Core Network. In LTE networks caching happens in the Packet Gateway (PGW) in the Evolved Packet Core (the evolution of the Core Network) [1]. Within 3G networks caching can again happen at the PGW and sometimes more specifically at the GI Interface which connects the GGSN (Gateway GPRS support node) and the PGW. Web caching can reduce download bandwidth consumption to around 25% [1] and have a cache hit ratio around 33%. Cache hit ratios naturally grow as the population increases.

Caching can happen at the Radio Access Network but is much less common; caching at this level is harder due to managing handover of users between base stations, although this technique may be suitable for some video use cases.

Caching in the mobile network both delivers content faster to users and create savings for mobile operators [5]. Caching at the RAN or on the handset would be preferred for latency saving [4], but cost savings and ease of deployment, use, and development of Core Network caches have lead to caching within the core network being more widely used.

2.1.X.1 Caching in Future Evolved Networks

Within the next few years a shift away from caching towards CDNs, interconnected CDNs and software defined networking is expected. This may offer further methods for moving content closer to the customer and over those bottlenecks in the network. In this case we may find the effects listed here to be less drastic and reliance on caching to decrease.

2.1.X.2 Caching Video

Video transcoding can often occur at the same time as content caching within the operator network. Some caching systems will request a video asset, discover the format and transcode this to a suitable mobile format and cache before delivering the content to the user [2]. Encrypting video content means both this caching and transcoding are no longer possible.

2.1.X.3 On-Device Caching

Transparent on-device caching caches data from browsers and apps on the device. This caching method can be configured to cache data specifically to a particular user, making content retrieval extremely fast by not needing to traverse any network [6]. Encrypted content cannot be cached by on-device cache solutions.

[1] http://www.cs.princeton.edu/~sihm/papers/monbot-mobisys13.pdf
[2] http://www.rcrwireless.com/20140522/wireless/video-optimization-cache-king-fixed-networks-mobile
[3] http://www-personal.umich.edu/~hjx/file/mobisys12_caching.pdf
[4] J. Erman, A. Gerber, M. Hajiaghayi, D. Pei, S. Sen, and O. Spatscheck. To Cache or not to Cache: The 3G case. IEEE Internet Computing, 2011., http://www-math.mit.edu/~hajiagha/InternetComputing.pdf
[5] http://pennysleuth.com/invest-in-cell-phone-infrastructure-for-growth-in-2010/
[6] http://www.mobolize.com/wp/wp-content/uploads/2015/01/Mobile-Endpoint-Optimization-Technical-WP.pdf

Thanks again!

Natasha

Natasha Rooney | Web Technologist | GSMA | [email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]
Tokyo, Japan

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Göran Eriksson AP <[email-masked]>
Date: Thu, 11 Jun 2015 04:59:00 +0000

Hi,

Perhaps obvious for many but what is the definition of a cache and a CDN or even more to the point- what is the difference? They both cache...

I am sure You have such a text as well, explaining this. Might be good adding it.

Best regards
Göran Eriksson

> 11 jun 2015 kl. 05:00 skrev Natasha Rooney <[email-masked]>:
> 
> Hi all!
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: "John Levine" <[email-masked]>
Date: 11 Jun 2015 09:43:10 -0000

In article <[email-masked]> you write:
>Hi,
>
>Perhaps obvious for many but what is the definition of a cache and a CDN or even
>more to the point- what is the difference? They both cache...

Seems to me the useful difference is that a CDN is under the control
of the entity providing the material, while caches are under control
of the end user or an intermediary.

CDNs and end user caches seem benign, intermediary caches less so.

R's,
John

---

From: Natasha Rooney <[email-masked]>
Date: Thu, 11 Jun 2015 10:18:28 +0000

Thanks for this Göran!

The difference is CDNs tend to have permission from the content provider, usually its a service the content provider has purchased from the CDN provider. Operator caches tend to be transparent, they do it if you like it or not! So maybe…

"Caching in this case refers to transparent caching where content providers have no control on whether or for what duration something is being cached".

I wonder, however, whether these caches do obey cache headers, which is something I don’t know. Can anyone on the list confirm if these caches obey caching headers (one hopes they do!).

Thanks!

Natasha

> On Jun 11, 2015, at 1:59 PM, Göran Eriksson AP <[email-masked]> wrote:
>
> Hi,
>

---

From: Natasha Rooney <[email-masked]>
Date: Thu, 11 Jun 2015 10:19:23 +0000

On Jun 11, 2015, at 6:43 PM, John Levine <[email-masked]<mailto:[email-masked]>> wrote:

Oh I like this sentence better than mine!

---

From: Göran Eriksson AP <[email-masked]>
Date: Thu, 11 Jun 2015 10:30:34 +0000

>
>
>
>On Jun 11, 2015, at 6:43 PM, John Levine <[email-masked]> wrote:
>
>Seems
> to me the useful difference is that a CDN is under the control
>of
> the entity providing the material, while caches are under control
>of

“Control” is kind of vague. In Natasha’s response, the word “purchased”
was used. That points at there being a business agreement including a
contract. The contract is important I think since that contract can also
cover what the CDN may do with knowledge about the end-user (individual or
enterprise user) it acquires by operating the CDN, as well as actions
required to safeguard that data.

This is too many words of course but I think control is not precise enough.

>
>This
> email and its attachments are intended for the above named only and may
>be confidential. If they have come to you in error you must take no
>action based on them, nor must you copy or show them to anyone; please
>reply to this email or call +44 207 356 0600
> and highlight the error.