Subject: Re: [saag] Ubiquitous Encryption: content filtering

From: Natasha Rooney <[email-masked]>
Date: Mon, 6 Jul 2015 10:20:56 +0000

Apologies for the late response, I was away for a week. I have an amendment to the Content Filtering suggestion:

I had a comment to remove the "mobile" from "mobile networks" in the submission; which I am fine to do but am not sure if content filtering is done in the same way on all networks. If so, then the mobile can be removed! I just ran through the other emails and I don’t think anyone else asked a question, if this is incorrect please let me know!

Natasha

Natasha Rooney | Web Technologist | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>
Tokyo, Japan

On Jun 24, 2015, at 4:32 AM, Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>> wrote:

Responding to various parts of the thread:

Q: What is the difference between filtering and censorship?
A: The person who decides to impose it.

Filtering is actually an essential tool for use of the modern Internet. Without filtering there is no mechanism to control abuse.

Today I received five junk calls. The time is rapidly approaching when I get rid of the telephone line completely. There is simply too much spam.

The fact that the Russian Business Network has put a machine on the net does not mean that any machine I own need be able to connect to it. I don't want their IP address to be reachable, I don't want their DNS names to resolve.

So the ability to perform filtering is an essential part of every end-to-end encryption mechanism. But giving control over that filtering to the government is not. When I was at university there was a club for thugs who went round smashing up restaurants for fun. One of the members of that club is now the UK Prime Minister. I am damned if I am going to let the likes of him decide what anyone can access.

The question is who has control and who is empowered.

I am firmly of the opinion that ubiquitous end-to-end encryption is only viable if it is accompanied by a robust and easy to use mechanism that allows for a gap in the stack. If I publish a key for [email-masked]<mailto:[email-masked]> it will be the key of a service in the cloud that performs anti-malware filtering. Use of the end-to-end key will be reserved to people who are expressly authorized to use it.

_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/saag

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 6 Jul 2015 12:02:03 -0400

On Mon, Jul 6, 2015 at 6:20 AM, Natasha Rooney <[email-masked]> wrote:

>  Apologies for the late response, I was away for a week. I have an
> amendment to the Content Filtering suggestion:
>
>  I had a comment to remove the "mobile" from "mobile networks" in the
> submission; which I am fine to do but am not sure if content filtering is
> done in the same way on all networks. If so, then the mobile can be
> removed! I just ran through the other emails and I don’t think anyone else
> asked a question, if this is incorrect please let me know!
>

Thanks for the revised text.  Al and I chatted and we'll add this into
section 2.1.5.  As Yoav and I discussed at some point in the thread,
content filtering also occurs on enterprise networks.  We are adding this
to the middlebox monitoring section of the draft.  If this applies to other
network types besides mobile (not at an edge), then we can adjust the
text.  The revised text is better and gets further away from the concerns
of whether or not it's appropriate for the IETF.  This draft is just
documenting current practices that will change with encryption, for some of
the documented items, new ways to achieve the same goal will be developed,
for others, they will not be developed.

Al and I will wait to add text on the SPAM discussion until that evolves a
little further.

We'll have the next version posted before EOD.

Thank you,
Kathleen

>
> Natasha
>
>
> Natasha Rooney | Web Technologist | GSMA | [email-masked] | +44
> (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]
> Tokyo, Japan
>
>
>  On Jun 24, 2015, at 4:32 AM, Phillip Hallam-Baker <[email-masked]>
> wrote:
>
>  Filtering is actually an essential tool for use of the modern Internet.
> Without filtering there is no mechanism to control abuse.
>
>  Today I received five junk calls. The time is rapidly approaching when I
> get rid of the telephone line completely. There is simply too much spam.
>
>  The fact that the Russian Business Network has put a machine on the net
> does not mean that any machine I own need be able to connect to it. I don't
> want their IP address to be reachable, I don't want their DNS names to
> resolve.
>
>  So the ability to perform filtering is an essential part of every
> end-to-end encryption mechanism. But giving control over that filtering to
> the government is not. When I was at university there was a club for thugs
> who went round smashing up restaurants for fun. One of the members of that
> club is now the UK Prime Minister. I am damned if I am going to let the
> likes of him decide what anyone can access.
>
>  I am firmly of the opinion that ubiquitous end-to-end encryption is only
> viable if it is accompanied by a robust and easy to use mechanism that
> allows for a gap in the stack. If I publish a key for
> [email-masked] it will be the key of a service in the cloud that
> performs anti-malware filtering. Use of the end-to-end key will be reserved
> to people who are expressly authorized to use it.
>
>
> [email-masked]
> This email and its attachments are intended for the above named only and
> may be confidential. If they have come to you in error you must take no
> action based on them, nor must you copy or show them to anyone; please
> reply to this email or call +44 207 356 0600 and highlight the error.
>
> [email-masked]

-- 

Best regards,
Kathleen