Subject: [saag] Comment on open source Re: keys under doormats: is our doormat ok?

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 16 Jul 2015 10:16:35 -0400

On Mon, Jul 13, 2015 at 4:11 PM, Stephen Farrell <[email-masked]>
wrote:

>
> Tend to agree. It's also addressing export of course but were any
> of the recently mooted government silliness to become real, it'd
> also have to involve controls on export/import as well as on usage
> so that part of the analysis is actually still relevant I figure.
> (There'd be an even bigger and even sillier impact on open source
> the importance of which is nowadays probably better appreciated.)
>

I don't think it is the importance of open source in general that has
changed. The difference is that the portion of the stack where the crypto
usually lives is no longer the portion that is proprietary and competitive.
Even the commercial applications are based on code which is open source.
Microsoft just put the whole of the .NET framework up on github under an
MIT license.

Managing a computer in a way that provides sufficient security to protect
my stuff is fairly straightforward. Managing a computer in a way that
provides sufficient security for other people's stuff is very hard. There
is liability to be considered. There have to be audits.

The best way to design a system therefore is to avoid becoming a trusted
service if at all possible and limit the degree of trust other parties have
to put on your system.

The fatal flaw with mandated lawful access is that the only way I can
design a system that allows me to guarantee access for Mr Plod or Mr Spook
is by designing the system in a way that allows my own employees to perform
similar abuse.

---

From: "Henry B (Hank) Hotz, CISSP" <[email-masked]>
Date: Sun, 19 Jul 2015 19:55:14 -0700

My $.02 is that this all sounds like a rerun of the clipper chip debates. The only problem is that the proposal is (so far) so abstract that it can’t end as quickly.

For those who don’t remember, it was a chip to encrypt digital cell phone conversations so only the two parties and the NSA could decrypt them. It all came to an abrupt halt when a Japanese mathematician cracked and published how to access the back door. Thankfully, that was before any mandate had been imposed.

I can’t believe that even the NSA can design a system where that won’t eventually happen for anything we put out there. I can’t believe that even the NSA can design a good enough doormat.

Why are we debating this all over again?

Sorry, I realize I should send this email to my congress-critters, and not here.

---

From: Yoav Nir <[email-masked]>
Date: Mon, 20 Jul 2015 07:33:39 +0200

> On Jul 20, 2015, at 4:55 AM, Henry B (Hank) Hotz, CISSP <[email-masked]> wrote:
> 

One big difference is that if I want to encrypt my email or web traffic there is no “chip”, unless a general-purpose CPU counts as a “chip”. They’d have to ban software encryption to make this work, and I can’t see how that would happen. All operating system distributions today come with TLS, IPsec and S/Mime. Are they going to ban Windows (up to version 10), Mac OS (up to 10.11) and all current Linux distros?

> I can’t believe that even the NSA can design a system where that won’t eventually happen for anything we put out there. I can’t believe that even the NSA can design a good enough doormat.

I don’t believe they can either, but even if they can, the way to access the back-door is going to get leaked. It doesn’t matter if they do it because they think it’s right or for money. 

> Why are we debating this all over again?

Because some governments are proposing it?

Yoav