Subject: Re: [saag] SEC-DIR QA review of draft-ietf-trill-channel-tunnel-07.txt

From: "Susan Hares" <[email-masked]>
Date: Tue, 18 Aug 2015 21:03:18 -0400

Saag: 

Would you review following four drafts from TRILL which create a new
directory service mechanism for IP/MAC address mappings?   In you QA review,
would  determine if the security mechanisms in this IP address/MAC Address
have: good security mechanisms and meet the privacy concerns? 

These 4 drafts are in the process of Routing QA reviews and IANA Reviews
(where appropriate).   

1)       TRILL: Edge Directory Assist Mechanisms: This draft provides the
overview of the TRILL directory mechanisms.  These mechanisms aim at
reducing multi-destination traffic, particularly ARP/ND and unknown unicast
flooding. It can also be used to detect traffic with forged source
addresses.

Routing QA review on draft-trill-directory-assist-mechanisms-03.txt
https://mailarchive.ietf.org/arch/msg/trill/9QMAY54iiheEzFOKPLdv59QdA7M

Note:  Draft has not been revised to handle these comments. 

2)       draft-ietf-trill-arp-optimization - This draft describes how reduce
ARP/ND traffic within a TRILL Campus by the following mechanisms: a)
learning MAC/IP addresses maping via ISIS application sub-TLVor b) getting
IP/MAC addresses from directory services (push/pull).  This draft gives step
by step instructions on the mechanisms. 

Routing QA review:
http://www.ietf.org/mail-archive/web/rtg-dir/current/msg02606.html

Note: Draft has not been revised to handle these comments. 

3)        draft-ietf-trill-channel-tunnel-07.txt on your QA review: The
TRILL directory mechanisms have push/pull mechanisms.  The
draft-ietf-trill-channel-tunnel draft is needed to provide a mechanism to
secure pull directory messages.  Push directory messages are IS-IS PDUs so
these drafts can use IS-IS authentication.

4)      draft-ietf-trill-ia-appsubtlv-05:  This draft reports of addresses
for TRILL interfaces in ISIS application sub-TLV (reduces/replaces need for
ARP/ND )

Note: No Routing QA Review yet (awaiting review) 

Thank you, 

Sue Hares 

TRILL-co-chair and document shepherd for this group.

---

From: [email-masked]
Date: Wed, 19 Aug 2015 01:17:30 +0000

Sue,

How many more are on the way? I fear too many asks might cause fewer responses.

Ta,
S.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 18 Aug 2015 21:34:34 -0400

Stephen: 

I'm a WG chair for 3 WGs, and I'm pushing WG groups of WG drafts toward the IESG publishing so it may seem like a large group: 

Let me prioritize the drafts by WG: 

1) I2RS - is a must have: 

 I2RS is in the midst of a disagreement over the security requirements.  Without Russ Housley's help to review it, we are stuck for this work. Top priority 

2)  TRILL - is a "Nice to have" as we are using Crypto-suites in tunneling protocol. 

This is a QA review for the next group of TRILL - which is providing a whole group of directory service.   If you do not do this now, then it will progress to IESG submission in September.   Donald Eastlake worked on these drafts so it is ok

3) BGP - "Nothing more/less than usual" status - for all drafts.   

Sue 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2015 9:18 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: RE: SEC-DIR QA review of draft-ietf-trill-channel-tunnel-07.txt

Sue,

Ta,
S.

On Wed Aug 19 02:03:18 2015 GMT+0100, Susan Hares wrote:
> reducing multi-destination traffic, particularly ARP/ND and unknown 
> unicast flooding. It can also be used to detect traffic with forged 
> source addresses.
> 
>  
> 
> learning MAC/IP addresses maping via ISIS application sub-TLVor b) 
> getting IP/MAC addresses from directory services (push/pull).  This 
> draft gives step by step instructions on the mechanisms.
> 
>  
> 
> Routing QA review:
> draft-ietf-trill-channel-tunnel draft is needed to provide a mechanism 
> to secure pull directory messages.  Push directory messages are IS-IS 
> PDUs so these drafts can use IS-IS authentication.
> 
>  
> 
> for TRILL interfaces in ISIS application sub-TLV (reduces/replaces 
> need for ARP/ND )
> 
>  
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 18 Aug 2015 22:01:50 -0400

As I understand it, Russ has agreed to cover #1, so we just need help in the other 2 with #2 having priority.

We could just request early reviews and have them put into the rotation if no one volunteers.

Thanks,
Kathleen 

Sent from my iPhone

> On Aug 18, 2015, at 9:34 PM, Susan Hares <[email-masked]> wrote:
> 
> Stephen: 
>