Subject: [saag] NIST requests comments on using ISO/IEC 19790:2012 as the U.S. Federal Standard for cryptographic modules

From: Stephen Farrell <[email-masked]>
Date: Fri, 14 Aug 2015 22:14:40 +0100

Hiya,

As an FYI, those of you who are interested in cryptographic
module APIs would probably be interested in this. [1] (partly
copied below.)

I'm told the ISO spec is behind a paywall, but haven't gone
to look and see if there's a version freely available, so
it's hard to know what kind of change this might represent.
If someone has more info on that it might be useful to
share that here.

Cheers,
S.

[]1 http://csrc.nist.gov/news_events/#aug12

-----------

NIST requests comments on using ISO/IEC 19790:2012 as the U.S. Federal
Standard for cryptographic modules

NIST is seeking public comments on using International Organization for
Standardization/International Electrotechnical Commission (ISO/IEC)
standards for cryptographic algorithm and cryptographic module testing,
conformance, and validation activities, currently specified by Federal
Information Processing Standard (FIPS) 140-2. The National Technology
Transfer and Advancement Act (NTTAA), Public Law 104-113, directs
federal agencies to adopt voluntary consensus standards wherever
possible. The responses to this request for information (RFI) will be
used to plan possible changes to the FIPS or in a decision to use all or
part of ISO/IEC 19790:2012, Security Requirements for Cryptographic
Modules, for testing, conformance and validation of cryptographic
algorithms and modules.

The **RFI posted in today’s Federal Register provides additional
background information, including seven questions that NIST is
especially interested in having addressed, as well as NIST’s intentions.

 Send public comments to: [email-masked] (also see the address for
sending written comments)

Comment period closes: September 28, 2015

---

From: Phil Lello <[email-masked]>
Date: Sat, 15 Aug 2015 09:23:06 +0100

I'm not in the US or trading with US companies, so presumably not affected,
but the paywall alone sounds like a reasonable grounds to object to me - it
prevents reasonable review by people with no reason to buy the standard,
and presumably also creates a smaller pool of suppliers (since it will
eliminate those who don't buy the spec).

On Fri, Aug 14, 2015 at 10:14 PM, Stephen Farrell <[email-masked]
> wrote:

> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>

---

From: David Lloyd-Jones <[email-masked]>
Date: Sat, 15 Aug 2015 07:24:15 -0400

Stephen,

None of
http://csrc.nist.gov/news_events/#aug12
http://csrc.nist.gov/publications/PubsFIPS.html#140-2
http://www.iso.org/iso/home/store/catalogue_tc/catalogue_detail.htm?csnumber=52906
http://www.iso.org/iso/catalogue_detail.htm?csnumber=52906

is behind a paywall.

What is it you have "heard," Stephen, that has given Phil this avalanche of
"reason to object"?

I wouldn't be surprised if some of the documentation within those
catalogues costs money.  There was a time in the early days of Oracle when
the docs for their basic database software cost US$6,000.  I paid US$92 for
my IBM equivalent a few years ago, but these are not paywalls.  They are
costs of operating docs.

(I suspect that that $6,000 was because Larry knew he was working the
American taxpayer over just one time, and in 1983 that was still real money
to him: gas for the motorbike, not the jet.)

Is it a question of that sort of thing?

Parenthetically, I notice that the correspondence thread "Information
Security" over on Google+ has recently fractured in two, I would guess
because the main feed is full of juvenile ranting.

-dlj.

On 15 August 2015 at 04:23, Phil Lello <[email-masked]> wrote:

> I'm not in the US or trading with US companies, so presumably not
> affected, but the paywall alone sounds like a reasonable grounds to object
> to me - it prevents reasonable review by people with no reason to buy the
> standard, and presumably also creates a smaller pool of suppliers (since it
> will eliminate those who don't buy the spec). {snipped}
>

---

From: "Paterson, Kenny" <[email-masked]>
Date: Sat, 15 Aug 2015 11:31:08 +0000

Err, no. ISO documents are notorious for not being free. In this case, the asking price is 178 Swiss Francs. Not exorbitant but not free either. (Yeah, it's free to read the abstract.)

Kenny

On 15 Aug 2015, at 12:24, David Lloyd-Jones <[email-masked]<mailto:[email-masked]>> wrote:

Stephen,

None of

is behind a paywall.

What is it you have "heard," Stephen, that has given Phil this avalanche of "reason to object"?

I wouldn't be surprised if some of the documentation within those catalogues costs money.  There was a time in the early days of Oracle when the docs for their basic database software cost US$6,000.  I paid US$92 for my IBM equivalent a few years ago, but these are not paywalls.  They are costs of operating docs.

(I suspect that that $6,000 was because Larry knew he was working the American taxpayer over just one time, and in 1983 that was still real money to him: gas for the motorbike, not the jet.)

Parenthetically, I notice that the correspondence thread "Information Security" over on Google+ has recently fractured in two, I would guess because the main feed is full of juvenile ranting.

-dlj.

On 15 August 2015 at 04:23, Phil Lello <[email-masked]<mailto:[email-masked]>> wrote:
I'm not in the US or trading with US companies, so presumably not affected, but the paywall alone sounds like a reasonable grounds to object to me - it prevents reasonable review by people with no reason to buy the standard, and presumably also creates a smaller pool of suppliers (since it will eliminate those who don't buy the spec). {snipped}
_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/saag

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 15 Aug 2015 13:50:58 +0100

> What is it you have "heard," Stephen, that has given Phil this avalanche of

I already said that I have been told that the ISO spec is behind
a paywall, that is all. And now I've said it twice:-)

Whether or not that's a deal for folks who've previously been
willing to subject themselves to FIPS140 fun is a reasonable
question. But it's also reasonable to point out that that is
a barrier to broad, open review.

And of course, if you care about any of this, then telling
NIST what you think is the correct action.

S.

---

From: William Whyte <[email-masked]>
Date: Mon, 17 Aug 2015 12:21:39 -0400

In fairness, NIST explicitly call this out themselves at
https://www.federalregister.gov/articles/2015/08/12/2015-19743/government-use-of-standards-for-security-and-conformance-requirements-for-cryptographic-algorithm
:

 NIST is also interested in feedback on the impacts of a potential U.S.
Government requirement for use and conformance using a standard with a
fee-based model where organizations must purchase copies of the ISO/IEC
19790:2014.

William

---

From: Michael Richardson <[email-masked]>
Date: Mon, 17 Aug 2015 14:39:12 -0400

William Whyte <[email-masked]> wrote:
    > fee-based model where organizations must purchase copies of the
    > ISO/IEC 19790:2014.

I won't read/review a document behind a paywall for free.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Russ Housley <[email-masked]>
Date: Mon, 17 Aug 2015 14:48:08 -0400

It is not clear to me that the use of ISO/IEC 19790 offers any improvement for the people that make crypto modules or the people that purchase crypto modules.  The specification being behind a paywall means that fewer people will know what it says.  Since the existing FIPS documents are freely available online, this seems to me to be a move in the wrong direction.

Russ

On Aug 17, 2015, at 12:21 PM, William Whyte wrote:

> In fairness, NIST explicitly call this out themselves at https://www.federalregister.gov/articles/2015/08/12/2015-19743/government-use-of-standards-for-security-and-conformance-requirements-for-cryptographic-algorithm: 
> 
>  NIST is also interested in feedback on the impacts of a potential U.S. Government requirement for use and conformance using a standard with a fee-based model where organizations must purchase copies of the ISO/IEC 19790:2014.
> 
> William
> 
> On Sat, Aug 15, 2015 at 8:50 AM, Stephen Farrell <[email-masked]> wrote:
> 
>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 17 Aug 2015 16:33:26 -0400

On Mon, Aug 17, 2015 at 2:48 PM, Russ Housley <[email-masked]> wrote:
> It is not clear to me that the use of ISO/IEC 19790 offers any improvement
> for the people that make crypto modules or the people that purchase crypto
> modules.  The specification being behind a paywall means that fewer people
> will know what it says.  Since the existing FIPS documents are freely
> available online, this seems to me to be a move in the wrong direction.

+1, but presumably these comments should be going to some NIST channel?

> https://www.federalregister.gov/articles/2015/08/12/2015-19743/government-use-of-standards-for-security-and-conformance-requirements-for-cryptographic-algorithm:
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 17 Aug 2015 18:31:27 -0400

I think it would be stronger if these comments went to NIST from the IETF Security Area Directors or the IESG.

Russ

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 17 Aug 2015 23:43:17 +0100

Hiya,

On 17/08/15 23:31, Russ Housley wrote:
> I think it would be stronger if these comments went to NIST from the
> IETF Security Area Directors or the IESG.

Fair enough, I'm happy to chat with Kathleen and see how
best to process a statement if you or someone has time to
draft a bit of text. Or if nobody does I'll try get to it
next week if Kathleen doesn't beat me to it. (I at least
may need reminding - so please bug me if nothing appears
to happen a lot;-)

I don't think it'd be right for the IESG to send but I'm
happy to chat with the IESG and IAB to find a way to get
the message sent. (*)

Regardless of whose name is on the "From" line of the
message, I'd be happy if the text had been seen and not
found objectionable on this list. (If objections are
raised here we can figure out what to do about 'em.)
And of course, after some text has been crafted here it
might get tweaked by e.g. the IAB or someone but I'd
make sure they know that this list was involved in the
generation of the text and ask that they check any such
edits.

S.

(*) For the sensible amongst you who don't get involved in
IETF process stuff, the IAB are (amongst other things) the
foreign-office and might rightly be a bit irked if the IESG
(amongst other things, the home-office) started stepping on
that toe. Apologies for the .gov.uk terminology but I figure
the Irish analogues wouldn't be as well known:-)

>>> It is not clear to me that the use of ISO/IEC 19790 offers any
>>> improvement for the people that make crypto modules or the people
>>> that purchase crypto modules.  The specification being behind a
>>> paywall means that fewer people will know what it says.  Since
>>> the existing FIPS documents are freely available online, this
>>> seems to me to be a move in the wrong direction.
>> 
>>> Government requirement for use and conformance using a standard
>>> with a fee-based model where organizations must purchase copies
>>> of the ISO/IEC 19790:2014.
>>> 
>>> William
>>> 
>>>> I already said that I have been told that the ISO spec is
>>>> behind a paywall, that is all. And now I've said it twice:-)
>>>> 
>>>> question. But it's also reasonable to point out that that is a
>>>> barrier to broad, open review.
>>>> 
>>>> And of course, if you care about any of this, then telling NIST
>>>> what you think is the correct action.
>>>> 
>>>> S.
>>> 
>>> 
>>> 
>>> _______________________________________________ saag mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/saag
>>> 
> 
> _______________________________________________ saag mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/saag
> 
>

---

From: "Mark D. Baushke" <[email-masked]>
Date: Mon, 17 Aug 2015 17:37:02 -0700

It may be worth noting that NIST actually put the wrong edition of the
ISO/IEC standard in the Federal Register article... They intended to put
19790:2012 instead.

See also

  http://csrc.nist.gov/groups/STM/cmvp/notices.html

	   -- Mark

---

From: Phil Lello <[email-masked]>
Date: Tue, 18 Aug 2015 10:33:47 +0100

I'd just like to clarify that my objection to the paywall isn't about
paying for the standard per-se, as it would be reasonable to pay a fee as
an implementor (much like paying to access C++ standards to write a
compiler). The objection is specifically about needing to pay to access the
standard as part of a review process, as the fee is a barrier to broad
evaluation.

Phil

---

From: Richard Barnes <[email-masked]>
Date: Tue, 18 Aug 2015 09:47:32 -0400

On Tue, Aug 18, 2015 at 5:33 AM, Phil Lello <[email-masked]> wrote:
> I'd just like to clarify that my objection to the paywall isn't about paying
> for the standard per-se, as it would be reasonable to pay a fee as an
> implementor (much like paying to access C++ standards to write a compiler).
> The objection is specifically about needing to pay to access the standard as
> part of a review process, as the fee is a barrier to broad evaluation.

Well, then let me explicitly disagree with this position.  The
standards that run the Internet need to be widely implemented, and
that means the specs need to be widely available.  As Russ observed,
the current FIPS standards are freely available, so moving to a
paywalled standard would be a major step backwards.  And a step
backwards for, AFAICT, no benefit.

I would also observe that "free for review, pay for implementation" is
not really a realistic position.  If anyone can download the spec for
review, then it will be out there on the Internet after it's
finalized.  Much like the C++ spec, in fact (see the links in
https://en.wikipedia.org/wiki/C%2B%2B).  And in practice that just
means that everyone will use the free "almost final" version, not the
paywalled "final" version.

--Richard

---

From: Michael Richardson <[email-masked]>
Date: Tue, 18 Aug 2015 10:12:25 -0400

> IETF Security Area Directors or the IESG.

+1

---

From: Michael Richardson <[email-masked]>
Date: Tue, 18 Aug 2015 10:13:08 -0400

> happy to chat with the IESG and IAB to find a way to get

I think it's directly related to OpenStand.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Aug 2015 15:28:19 +0100

> I think it's directly related to OpenStand.

Fair point.

S.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Aug 2015 15:31:14 +0100

> backwards for, AFAICT, no benefit.

One of the reasons I asked if someone was willing to take a
1st cut at drafting some text is that, since I am not going
to be reading the document behind the paywall, I have no clue
if Richard is correct when he says "for, AFAICT, no benefit."
(Since I've not read the thing;-)

If an IETF/IAB/IESG/whatever response really ought also say
something about the technical content, as well as the open-ness
aspect of the process, then I at least will be depending on
folks who have peeked behind that particular curtain to see
what the wizard looks like. Or if none of us do, then I guess
we could say that:-)

Cheers,
S.