Subject: [saag] CNN Says: Encryption a growing threat to security

From: Yoav Nir <[email-masked]>
Date: Tue, 4 Aug 2015 09:41:33 +0300

http://edition.cnn.com/2015/08/01/opinions/rogers-encryption-security-risk/index.html <http://edition.cnn.com/2015/08/01/opinions/rogers-encryption-security-risk/index.html>

If encryption is so dangerous to security, why does the US government use it so much?

Both the article and the video contain a bunch of nonsense, but I worry a lot about this kind of message being sent to the public by a trusted source such as CNN.

I think the worst of this is presenting the issue as if this “master key” scheme is in the interest of the public, whereas the only downside is the bottom-line of corporations. So all those tech companies resisting such mandates are just heartlessly putting profits before the safety of the people. It’s a powerful message, and I’m afraid a lot of people, even well-educated ones, are buying it.

IMO key escrow with a private corporation is marginally worse than key escrow with the government, but both mean that we can’t trust the encryption. In the old Perry Mason novels, private detective Paul Drake would go to his friend at the phone company, slip him some money and get the phone records for whoever Perry Mason suspected. I guess in this brave new world that Mike Rogers is advocating the new Paul Drake would go to his friend at Google and get their TLS keys. In such a world, I don’t know if it’s prudent for my doctor to send me the result of my blood test over HTTPS, or for companies to move personnel records from one data center to another over the Internet. Back to a guy with a briefcase handcuffed to his wrist?

Yoav

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 4 Aug 2015 00:56:50 -0700

It is important to read between the lines of these statements, which concern data at rest, not in transit. Encryption of data at rest is simultaneously not widely deployed enough and at the same time, difficult to overcome for law enforcement agencies lacking the funding and sophistication of military and surveillance agencies.

Those agencies, who understand the technology and trade offs much better, have either been silent on the subject, or have alumni who now openly oppose the proposals from
Law enforcement. 

We have seen this movie before. It matters little if CNN pretends it is a new release rather than a remake.

On Aug 3, 2015, at 11:41 PM, Yoav Nir <[email-masked]> wrote:
> 
> http://edition.cnn.com/2015/08/01/opinions/rogers-encryption-security-risk/index.html
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
_______________________________________________
saag mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/saag

---

From: Yoav Nir <[email-masked]>
Date: Tue, 4 Aug 2015 11:54:17 +0300

> On Aug 4, 2015, at 10:56 AM, Bernard Aboba <[email-masked]> wrote:
> 

The movie is not new but the text is. It specifically talks about communications, giving email and messaging apps as examples. While the encryption of messages in transit is not widely deployed on the Internet, setting up even S/MIME or PGP among a small group is fairly easy and overcoming it is hard.

Who are the agencies who are silent or opposed? I haven’t heard many in either the US or the UK.

Yoav

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 4 Aug 2015 07:17:24 -0700

Here is an article on alumni who are opposed:
http://www.itnews.com.au/News/407105,top-former-us-security-officials-oppose-encryption-backdoors.aspx

Here is the article on the new mandates:
http://www.itnews.com.au/News/405036,white-house-mandates-https-only-govt-websites.aspx

---

From: Nico Williams <[email-masked]>
Date: Tue, 4 Aug 2015 10:06:15 -0500

On Tue, Aug 04, 2015 at 11:54:17AM +0300, Yoav Nir wrote:
> The movie is not new but the text is. It specifically talks about
> communications, giving email and messaging apps as examples. While the
> encryption of messages in transit is not widely deployed on the
> Internet, setting up even S/MIME or PGP among a small group is fairly
> easy and overcoming it is hard.

Small groups of people using S/MIME or PGP (encryption) is just a source
of even more interesting metadata.  80% of e-mail traffic using S/MIME
or PGP (encryption) would notionally reduce the ability of intel
agencies to collect message plaintexts, but the metadata would still be
plenty, and anyways, any e-mail infrastruction and MUA enhancements that
could get us to such pervasive encryption would likely provide many MITM
opportunities and other means of gathering data (think of CALEA, at
least for sites like gmail and hosted domains -- no crypto backdoors,
just forced access for LEAs).

To me it seems like the impact of civilian crypto on intel agencies is
mostly this: curtailing the amount of plaintext and metadata that can be
massively gathered on web browsing.  The web is perhaps the use case
with the most pervasive civilian end-to-end crypto.  Metadata is really
where the game is at, and TLS + CDNs -> some opacity as to that,
especially if we did something strong enough as to DNS privacy (though I
suspect we won't).  E-mail is store-and-forward, high-latency as a
social medium, but the web is real-time.  Applying CALEA-style
legislation to web sites seems difficult.  The encrypted web's higher
opacity and technical difficulty of legal surveilance compared to
e-mail's strikes me as the probable motivation for intel and LEA
opposition to civilian crypto.  Besides, CALEA doesn't help intel
agencies much.  This is all just speculation, mind you.

Nico
--