Subject: Re: [saag] sha1 - have we more work to do?

From: Sarat G <[email-masked]>
Date: Thu, 5 Nov 2015 09:55:46 +0530

Hi Stephen,
Recently I worked on SNMPv3. The SNMP auth protocol still uses HMAC SHA 96
and HMAC MD5 96[RFC 2574].

Thank You.
Regards,
Sarat G

On Thu, Oct 15, 2015 at 11:03 PM, Rick Andrews <[email-masked]>
wrote:

> Stephen, OCSP (RFC 6960) mandates SHA-1 for KeyHash, though the risk of
> using it here is probably very low.
>
> ---------------
>
> Message: 2
> Date: Fri, 9 Oct 2015 14:25:40 +0100
> From: Stephen Farrell <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [saag] sha1 - have we more work to do?
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=utf-8
>
> Hiya,
>
> While it may be still under submission, and not yet peer reviewed, I was
> just looking at [1,2] and wondered if we've still work to do to deprecate
> sha1 anywhere that we've not yet done. I know a lot of this was done
> already
> but just wanted to check that we're good.
>
> Anyone know places where sha1 is still a should or must or where it's still
> in widespread use despite no longer being a should or must?
> (No need to mention root stores in browser for that last though, as that's
> a
> known issue and is I think already being tackled by browser
> makers.)
>
> I guess we can make a list and then figure out what to do if the list is
> non-empty.
>
> Cheers,
> S.
>
> [1] https://sites.google.com/site/itstheshappening/
> [2] https://sites.google.com/site/itstheshappening/shappening_article.pdf
>
> ------------------------------
>
>
>
>
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 6 Nov 2015 10:55:56 +0900

This is pretty new, but might a step in the right direction http://datatracker.ietf.org/doc/rfc7630/.

spt

> On Nov 05, 2015, at 13:25, Sarat G <[email-masked]> wrote:
> 
> Hi Stephen,
> Recently I worked on SNMPv3. The SNMP auth protocol still uses HMAC SHA 96 and HMAC MD5 96[RFC 2574].
> 
> Thank You.
> Regards,
> Sarat G
> 
> 
> 
> On Thu, Oct 15, 2015 at 11:03 PM, Rick Andrews <[email-masked]> wrote:
> sha1 anywhere that we've not yet done. I know a lot of this was done already
> (No need to mention root stores in browser for that last though, as that's a

---

From: Sarat G <[email-masked]>
Date: Sun, 8 Nov 2015 18:23:55 +0530

Thank you Sean.

Regards,
Sarat G

On Fri, Nov 6, 2015 at 7:25 AM, Sean Turner <[email-masked]> wrote:

> This is pretty new, but might a step in the right direction
> http://datatracker.ietf.org/doc/rfc7630/.
>
> spt
>
> > [2]
> https://sites.google.com/site/itstheshappening/shappening_article.pdf
> >