Subject: [saag] NSA re-org and its impact

From: "Salz, Rich" <[email-masked]>
Date: Tue, 2 Feb 2016 20:14:18 +0000

I try to stay out of national crypto politics here, but I think many on these lists (both big, please be careful about replying) will care.

The NSA is re-organizing to merge its signals intelligence (attack) and information assurance (protect) into one unit.  The NSA is, by US Law, the official advisor to NIST on cryptography. NIST has a pretty admirable track record of crypto (exceptions being mostly when they were misled by their official expert). Things may change now.  Or not.  YMMV.

https://www.washingtonpost.com/world/national-security/national-security-agency-plans-major-reorganization/2016/02/02/2a66555e-c960-11e5-a7b2-5a2f824b02c9_story.html<https://www.washingtonpost.com/world/national-security/national-security-agency-plans-major-reorganization/2016/02/02/2a66555e-c960-11e5-a7b2-5a2f824b02c9_story.html?hpid=hp_local-news_no-name%3Ahomepage%2Fstory>

--
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

---

From: Yoav Nir <[email-masked]>
Date: Tue, 2 Feb 2016 22:48:27 +0200

> On 2 Feb 2016, at 10:14 PM, Salz, Rich <[email-masked]> wrote:
> 
> https://www.washingtonpost.com/world/national-security/national-security-agency-plans-major-reorganization/2016/02/02/2a66555e-c960-11e5-a7b2-5a2f824b02c9_story.html <https://www.washingtonpost.com/world/national-security/national-security-agency-plans-major-reorganization/2016/02/02/2a66555e-c960-11e5-a7b2-5a2f824b02c9_story.html?hpid=hp_local-news_no-name%3Ahomepage%2Fstory>
>  

IDK. People were complaining before about the attack mission overshadowing and in fact hurting the protect mission. I don’t see how this makes it better. Perhaps worse.

> “When it comes to cyber in particular, the line between collection capabilities 
> and our own vulnerabilities — between the acquisition of signals intelligence 
> and the assurance of our own information — is virtually nonexistent,” said 
> Rep. Adam B. Schiff (Calif.), the ranking Democrat on the House Intelligence 
> Committee. “What is a vulnerability to be patched at home is often a potential 
> collection opportunity abroad and vice versa.”

This sounds so... misguided.

Yoav

---

From: "David S. Misell" <[email-masked]>
Date: Tue, 02 Feb 2016 22:49:48 +0000

Surely the argument from David Alexander from RSA conference 2015 still holds, you need the best people in Offence to advise behind the scenes moving into talk freely to those in defence. In the U.K. We have never had the money or resources for both, ( according to Tony Sale before he died, when everything was one big melting pot in ww2 )
After all what has changed since Turing did the assurance analysis of the U.K./USA telephone link which remained in use, even if his Delilah replacement weighed 59 tons less and was portable!
Best Regards,

Dave

'Certain things are done first, then said'

> On 2 Feb 2016, at 20:48, Yoav Nir <[email-masked]> wrote:
> 
> 
>> https://www.washingtonpost.com/world/national-security/national-security-agency-plans-major-reorganization/2016/02/02/2a66555e-c960-11e5-a7b2-5a2f824b02c9_story.html
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Michael Richardson <[email-masked]>
Date: Tue, 02 Feb 2016 19:45:50 -0500

David S. Misell <[email-masked]> wrote:
    > Surely the argument from David Alexander from RSA conference 2015 still
    > holds, you need the best people in Offence to advise behind the scenes moving
    > into talk freely to those in defence. In the U.K. We have never had the

A systematic series of secondments, liasons and exchanges would accomplish
this goal without compromising the priorities of the defense organization.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Watson Ladd <[email-masked]>
Date: Tue, 2 Feb 2016 20:21:53 -0800

On Tue, Feb 2, 2016 at 7:54 PM, Tony Arcieri <[email-masked]> wrote:
> On Tue, Feb 2, 2016 at 12:14 PM, Salz, Rich <[email-masked]> wrote:
>>
>> The NSA is re-organizing to merge its signals intelligence (attack) and
>> information assurance (protect) into one unit. The NSA is, by US Law, the
>> official advisor to NIST on cryptography. NIST has a pretty admirable
track
>> record of crypto (exceptions being mostly when they were misled by their
>> official expert). Things may change now. Or not. YMMV.
>
>
> At a time when NIST needs to restore trust, it would seem rather unwise
for
> them to accept any unjustified parameters from the NSA like they did with
> Dual_EC_DRBG (and hopefully they prefer well-scrutinized, widely trusted
> standards such as the CFRG curves)
>
> Dual_EC_DRBG was a debacle, but short of the NSA making massive advances
> over the public sector in cryptography and therefore being able to hide a
> backdoor in plain sight it seems like the sort of trick they can only pull
> once...

Like putting MD5 into widespread deployment after Dobbartin's 1996 paper?
Or Dual EC post 2007? Or continuing to widely use TLS 1.0 post Bard's 2004
attack, and Bodo Mueller's cbc-attacks.txt? Or making IKEv2 and IKEv1
sufficiently baroque that the only widely deployable mode was easily
decryptable, then ensuring that VPN makers would tell their clients to
enable it. We've know about every public NSA attack on crypto years before
it happened.

The basic fact is people know things about crypto, and will tell you what
to do. And you do them, or you suffer the consequences. And to the extent
the IETF can't adapt to that, we need to take the letter E out and replace
it with B.

>
> This is clearly a bad development, but hopefully NIST learned its lesson
the
> last time around.
> Tony Arcieri
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: Tony Arcieri <[email-masked]>
Date: Tue, 2 Feb 2016 19:54:56 -0800

On Tue, Feb 2, 2016 at 12:14 PM, Salz, Rich <[email-masked]> wrote:

> official advisor to NIST on cryptography. NIST has a pretty admirable track

At a time when NIST needs to restore trust, it would seem rather unwise for
them to accept any unjustified parameters from the NSA like they did with
Dual_EC_DRBG (and hopefully they prefer well-scrutinized, widely trusted
standards such as the CFRG curves)

the last time around.

-- 
Tony Arcieri