Subject: [saag] RFC 6979, Deterministic Signatures for DSA/ECDSA using SHA3?

From: Jeffrey Walton <[email-masked]>
Date: Tue, 1 Mar 2016 19:11:49 -0500

Hi Everyone,

How does one use SHA-3 with a deterministic DSA/ECDSA signature under RFC 6979?

Has anyone defined what HMAC/SHA-3 means?

Jeff

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Thu, 3 Mar 2016 11:34:07 +0000

Hi Jeff,

One can use SHA3-224, SHA3-256, SHA3-384 and SHA3-512 as drop-in replacements for SHA2s in the HMAC construction.  

In addition, we are specifying two more efficient MAC constructions from Keccak.

The first one is a single-pass MAC which does not use the HMAC construction to produce Mac tags. 

The second one is to use the SHAKE128 and SHAKE256 in the HMAC construction.  We are working on a formal specification of the SHAKEs being used as fixed output-length hash functions. Fixed output-length hash functions can be used in the HMAC construction. 

The first one (single-pass MAC) is the most efficient option.

Quynh. 

________________________________________
From: saag <[email-masked]> on behalf of Jeffrey Walton <[email-masked]>
Sent: Tuesday, March 1, 2016 7:11 PM
To: [email-masked]
Subject: [saag] RFC 6979, Deterministic Signatures for DSA/ECDSA using SHA3?

Hi Everyone,

Jeff

_______________________________________________
saag mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/saag