Subject: [saag] metadata insertion draft question

From: Stephen Farrell <[email-masked]>
Date: Fri, 14 Oct 2016 16:59:19 +0100

Hiya,

Ted has written a draft [1] on this topic.

Earlier, we wondered whether it'd be good to include
the meat of this into the work on 3552bis. [2]

Ted's now at the point of thinking his draft is near
done so would like to know the plan.

If we seem to have consensus to include this in 3552bis
then that's straightforward.

If we think that's not the best plan, then I'd likely
look at AD sponsoring this separately to see if it has
IETF consensus.

So, what do you think, should we:

a) incorporate the meat of [1] into [2]
b) look at AD sponsoring [1] separately
c) something else...

Thanks,
S.

PS: Note that your answer to the above does not have
to mean you think the text in [1] is perfect. An IETF
last call will be needed for either (a) or (b) when
any changes needed can be identified.

[1] https://tools.ietf.org/html/draft-hardie-privsec-metadata-insertion-03
[2] https://tools.ietf.org/html/draft-nir-saag-rfc3552bis-00

---

From: Randy Bush <[email-masked]>
Date: Sat, 15 Oct 2016 16:40:22 +0900

it would be good if ted's draft included example suggestions to
ameliorate the the two "Examples of this design pattern include
[RFC7239] and [I-D.ietf-dnsop-edns-client-subnet]"

randy

---

From: Yoav Nir <[email-masked]>
Date: Sat, 15 Oct 2016 10:50:47 +0300

> On 14 Oct 2016, at 18:59, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> c) something else…

Plan (a) is tempting. However, since we published version -00 of 3552bis there have been zero comments on the list. We are going to try to revive the discussion, but there’s a real risk that 3552bis will either expire and go away or take a long, long time to reach publication.  I hope this isn’t the case, but it’s a real possibility.

The content in draft-hardie is worth publishing, so I don’t think it’s a good idea to tie it to 3552bis.  Of course we would link to it from 3552bis if it gets published on its own.

But if people prefer (a), just post a PR on [3] and I can merge it into a -01 version before Seoul.

Yoav

[3] https://github.com/IETF-SAAG/RFC3552bis <https://github.com/IETF-SAAG/RFC3552bis>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 15 Oct 2016 13:28:24 +0100

On 15/10/16 08:50, Yoav Nir wrote:
> since we published version -00 of 3552bis there have been zero
> comments on the list. We are going to try to revive the discussion,

Yeah, hopefully that's just an over-the-summer thing. I'll start
a thread on that in a bit if other folks don't. (So please do
all feel free to suggest changes to [1] to modernise 3552)

S.

[1] https://tools.ietf.org/html/draft-nir-saag-rfc3552bis-00

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 19 Oct 2016 15:19:48 +0000

Both docs are short enough that I would prefer to see them merged.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 19 Oct 2016 18:22:55 +0300

Does 44 pages (3552bis) count as short?

> On 19 Oct 2016, at 18:19, Salz, Rich <[email-masked]> wrote:
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 30 Oct 2016 21:43:20 +0000

Wrapping up on this thread - I don't see discussion of
3552bis taking off yet (sadly) so as of now I plan to
AD sponsor this draft separately. Once Ted tells me he
thinks this is baked, I'll do my AD review and all going
well, after that's sorted start an IETF LC.

If, at any point in the processing of this draft, there
emerges a consensus to incorporate this into 3552bis, I'll
be fine with that, but for now it looks like 3552bis may
take a while.

Cheers,
S.

PS: Ted - Randy's comment up thread was a substantive
comment on the content, please take a look at that if
you've not already.

---

From: Ted Hardie <[email-masked]>
Date: Mon, 31 Oct 2016 11:17:20 -0700

On Sun, Oct 30, 2016 at 2:43 PM, Stephen Farrell <[email-masked]>
wrote:

> Okay,  I will see about including example ameliorations, but I likely
won't have that in the drafts directory before the deadline today.  I hope
to have it ready for when the window opens.

regards,

Ted