Subject: Re: [saag] software update for teeny-weeny devices

From: Watson Ladd <[email-masked]>
Date: Thu, 10 Nov 2016 07:26:00 -0800

On Oct 18, 2016 12:52 PM, "Mohit Sethi" <[email-masked]> wrote:
>
> Thanks for the pointer. This was indeed hilarious and sad to follow on
Twitter. I think it highlights another important problem of
bootstrapping/configuring IoT devices. At some point Mark has to run a port
scanner to find out what IP address was assigned to his WiFi Kettle.
>
> But for his light bulb not working during dinner time, at least in this
case I think he manually confirmed the firmware update. Perhaps the user
can be better informed in future that the installing firmware updates may
make the light bulb unusable for x amount of time.

We've had light bulbs with the IQ of acephelic nematodes that when current
goes in, go on and give light reliably. I expect that whatever intelligence
is added to them, this will remain the case.

>
> Thanks
> /--Mohit
>
>
>
> On 10/17/2016 08:07 PM, Peter Gutmann wrote:
>>
>> Mohit Sethi <[email-masked]> writes:
>>
>>>
>>> For me scheduling of updates is important: I don't want my connected
light
>>> bulb to update at night when I am using it.
>>
>> So not this then:
>>
>> https://twitter.com/markrittman/status/785905327967498240/photo/1
>>
>> (that was part of an 11-hour battle to get a WiFi kettle working).
>>
>> Peter.
>
>
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Yoav Nir <[email-masked]>
Date: Thu, 10 Nov 2016 18:48:14 +0200

> On 10 Nov 2016, at 17:26, Watson Ladd <[email-masked]> wrote:
> 
> 
> On Oct 18, 2016 12:52 PM, "Mohit Sethi" <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Thanks for the pointer. This was indeed hilarious and sad to follow on Twitter. I think it highlights another important problem of bootstrapping/configuring IoT devices. At some point Mark has to run a port scanner to find out what IP address was assigned to his WiFi Kettle.
> >
> > But for his light bulb not working during dinner time, at least in this case I think he manually confirmed the firmware update. Perhaps the user can be better informed in future that the installing firmware updates may make the light bulb unusable for x amount of time.
> 
> We've had light bulbs with the IQ of acephelic nematodes that when current goes in, go on and give light reliably. I expect that whatever intelligence is added to them, this will remain the case.
> 

Certainly not. A lightbulb contacts either a server in your home or a cloud service to ask whether it should let the current in or not.  That way you can tell it to turn on or off from half-way around the world. 

And if you dare buy a competitor’s server to install in your home, a software update will make sure that the bulb refuses to talk to this server.

Yoav