Subject: [saag] SECDISPATCH WG Summary from IETF 104

From: Roman Danyliw <[email-masked]>
Date: Mon, 25 Mar 2019 19:13:58 +0000

The SECDISPATCH WG met on Tuesday afternoon.  The agenda items were dispatched as follows:

(1) draft-mccain-keylist -- continue discussion on IETF OpenPGP mailing list ([email-masked]) to grow interest

(2) draft-rundgren-json-canonicalization-scheme -- not security area work; bring to ART

(3) draft-schinazi-masque -- needs more discussion; non-WG IETF mailing list will be created    

(4) draft-gont-predictable-numeric-ids -- ADs will follow-up work to define right venue 

(5) draft-birkholz-core-coid -- BOF recommended
     
(6) draft-raza-ace-cbor-certificates -- BOF recommended

---

From: "Dr. Pala" <[email-masked]>
Date: Tue, 26 Mar 2019 09:22:32 +0100

Dear Saag,

I noticed at the last dispatch that there has been no humming to get the 
feeling of the room - all recommendation were given by the chairs as 
there was no "voting" (humming) for the different options for the future 
of the (at lest for the {3-6}) proposals. Since this seemed a bit 
strange to me, I wanted to ask if this is representative of how 
SecDispatch will operate from now on.

Do not get me wrong, I think this might be a better approach other than 
asking the room about what to do since most of the times people would 
not read the drafts and still vote to adopt it or not (which I find 
quite disrespectful for the work the people put in - at least that 
happened in the past).

Please let me know if this represents a change in the way secdispatch is 
handled or ... ? And if this is the case, wouldn't it be more efficient 
to do this via e-mail if there is no feedback that is taken in 
consideration during the session ?

Thanks,
Max

On 3/25/19 8:13 PM, Roman Danyliw wrote:
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 26 Mar 2019 08:35:54 +0000

>    I noticed at the last dispatch that there has been no humming to get the 
    feeling of the room

Good point, thanks for raising the issue. We also missed "to be confirmed on the list."  Whatever the rules are going to be, they should be explicit.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Mar 2019 10:58:30 +0100

> Good point, thanks for raising the issue. We also missed "to be
    > confirmed on the list."  Whatever the rules are going to be, they
    > should be explicit.

Which list? :-)
no, seriously.  I think that each propsal needs some CCs to other lists.

Also, I would have thought that the virtual interim meeting results would
have been included in that summary email as well.

I'd like to see a paragraph for each proposal explaining why other options
(including "not relevant to IETF", or also, "conflicts with existing work")
are less relevant.  As such each really needs it's own thread.
Yes, that is more work... "many hands" comes to mind.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 26 Mar 2019 16:34:42 +0000

> -----Original Message-----
> From: Secdispatch [mailto:[email-masked]] On Behalf Of
> Michael Richardson
> Sent: Tuesday, March 26, 2019 5:59 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [Secdispatch] [saag] SECDISPATCH WG Summary from IETF 104
> 
> 

I strongly concur that we need to be consistent and explicit about the process.  

Across the meetings, we have been inconsistent on when hums are taken vs. summarizing feedback from the mic line -- it has been a judgement call on assessing consensus from the front table.

Where the process has been consistent across meetings is in NOT taking any confirmations to the list.  Dispatch decisions have been a point in time activity during a meeting based on the participants in the room or virtually participating.  The motivation for this approach was to convene a discrete event that provides immediate feedback on next steps to the draft authors.  The charter does allow for the WG "... com[ing] to a prompt resolution of the appropriate disposition of each proposal ... on the mailing list".

> no, seriously.  I think that each propsal needs some CCs to other lists.

I'm not sure what hard rule to apply on a per draft basis for post-dispatch notifications.  However, pre-dispatch, continued coordination with ART dispatch process (and other areas) remains top of mind too.

> have been included in that summary email as well.

(for SAAG) A pointer to the summary of the virtual interim meeting on 03/05/2019: 
https://mailarchive.ietf.org/arch/msg/secdispatch/9AfqrecZfFMlMGxSXOo4ENZtrVk

> (including "not relevant to IETF", or also, "conflicts with existing work") are
> less relevant.  As such each really needs it's own thread.

The summaries are intentionally terse as they are trying to share the results of the dispatch as soon as possible.  More details will ultimately be published in the minutes and ground truth remains in the recording.  I worry on how to deliberate after the dispatch meeting but provide prompt resolution.

Roman