Subject: [saag] SUIT WG Summary

From: Russ Housley <[email-masked]>
Date: Wed, 27 Mar 2019 05:23:09 -0400

ITU-T SG17 Question 6/17 has produced a document that defines a terminology and architecture for IoT Software Update.  It points to the IETF SUIT work.  The editor of the document is watching the SUIT mail list and attended the Hackathon, so a discussion on our mail list will influence the document.

At the Hackathon, the team worked on manifest generators, manifest parsers, and demonstrated end-to-end workflow on two micro controllers and a simulated micro controller.

The architecture document includes some linkage to the TEEP WG.  The terminology is aligned with the ITU-T SG17 Question 6/17.  WG Last Call began during the meeting.

The information model has been updated to address comments from recent reviews and add additional use cases. It needs a minor revision, and then it will be ready for an extended WG Last Call.  It will last 4 weeks to ensure that people in the TEEP WG have time to check alignment with that work.

The manifest document had a major revision, adopting a very different design based on WG feedback.  A WG Call for Adoption will begin shortly.

The Information Model for Behavioral Description document describes an approach to formally defining the behavior of a system under firmware update and secure boot conditions.  This was discussed to ensure there is a common understanding.  This document will not become an RFC.

Russ & Dave & Dave

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 30 Mar 2019 11:31:56 -0500

> The Information Model for Behavioral Description document describes an approach to formally defining the behavior of a system under firmware update and secure boot conditions.  This was discussed t…

Thank you for considering this path and making the intent explicit; I'm
sure the IESG will appreciate not having to review the document.

-Ben