Subject: Re: [saag] SECDISPATCH WG Summary from IETF 106

From: Brian Campbell <[email-masked]>
Date: Fri, 17 Jan 2020 13:42:55 -0700

Apologies folks, I'm responsible for the rushed and awkward presentation
about reverse proxies and TLS client certificates at the very end of the
SECDISPATCH session in Singapore, which is mentioned below with "no draft
yet--> needs draft". It took me a little while to get through the work but
I'm happy to share that there is now an actual draft available. Here it is
in the fancy new HTML format:
https://www.ietf.org/id/draft-bdc-something-something-certificate-01.html
as well as the good ol status page:
https://datatracker.ietf.org/doc/draft-bdc-something-something-certificate/

On Tue, Nov 19, 2019 at 9:34 PM Francesca Palombini <francesca.palombini=
[email-masked]> wrote:

> The SECDISPATCH WG met on Tuesday November 19.  The agenda items were
> dispatched as follows:
>
>
>
> (1) Problem statement for post-quantum multi-algorithm PKI (Max Pala)
>
> drafts:  https://datatracker.ietf.org/doc/draft-pq-pkix-problem-statement/
>
>
> https://datatracker.ietf.org/doc/draft-ounsworth-pq-composite-sigs/
>
> --> dispatch to LAMPS WG (confirm on mailing list)
>
>
>
> (2) OCSPv2 - Improving OCSP Responses (Max Pala)
>
> LAMPS & PKIX discussions:
>
> Draft:  https://tools.ietf.org/html/draft-pala-ocspv2-00
>
> --> create a BoF for small focused WG
>
>
>
> (3) Privacy Pass Protocol (Nick Sullivan)
>
> drafts: https://datatracker.ietf.org/doc/draft-privacy-pass/
>
> --> work on charter text then BoF for small focused WG
>
>
>
> (4) HTTP Request signing (Justin Richer)
>
> draft: https://tools.ietf.org/html/draft-cavage-http-signatures
>
> --> dispatched to HTTPBIS WG
>
>
>
> (5) Communication Network Perspective on Malware Lifecycle (Joachim Fabini)
>
> draft:
> https://datatracker.ietf.org/doc/draft-fabini-smart-malware-lifecycle/
>
> --> check the IAB project (talk to Ted)
>
>
>
> (6) Securing protocols between proxies and backend (HTTP?) servers (Brian
> Campbell)
>
> draft: Looking for support/contributors, no draft yet
>
> --> needs draft
>
>
>
> Detailed minutes will be coming in the next couple of weeks.
>
>
>
> Thanks,
> Francesca
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Mike Ounsworth <[email-masked]>
Date: Tue, 21 Jan 2020 18:18:23 +0000

I support this effort!

The lack of such a header has been a pain point for migrating applications with client-cert driven auth mechanisms into the cloud.

---
Mike Ounsworth
Software Security Architect, Entrust Datacard

From: Secdispatch <[email-masked]> On Behalf Of Brian Campbell
Sent: January 17, 2020 2:43 PM
To: Francesca Palombini <francesca.palombini=[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXTERNAL]Re: [Secdispatch] SECDISPATCH WG Summary from IETF 106

WARNING: This email originated outside of Entrust Datacard.
DO NOT CLICK links or attachments unless you trust the sender and know the content is safe.
________________________________
Apologies folks, I'm responsible for the rushed and awkward presentation about reverse proxies and TLS client certificates at the very end of the SECDISPATCH session in Singapore, which is mentioned below with "no draft yet--> needs draft". It took me a little while to get through the work but I'm happy to share that there is now an actual draft available. Here it is in the fancy new HTML format: https://www.ietf.org/id/draft-bdc-something-something-certificate-01.html as well as the good ol status page: https://datatracker.ietf.org/doc/draft-bdc-something-something-certificate/

On Tue, Nov 19, 2019 at 9:34 PM Francesca Palombini <francesca.palombini=[email-masked]<mailto:[email-masked]>> wrote:
The SECDISPATCH WG met on Tuesday November 19.  The agenda items were dispatched as follows:

(5) Communication Network Perspective on Malware Lifecycle (Joachim Fabini)
draft: https://datatracker.ietf.org/doc/draft-fabini-smart-malware-lifecycle/
--> check the IAB project (talk to Ted)

(6) Securing protocols between proxies and backend (HTTP?) servers (Brian Campbell)
draft: Looking for support/contributors, no draft yet
--> needs draft

Thanks,
Francesca

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.