
From nobody Mon Dec 11 15:44:00 2017
Return-Path: <aweits@rit.edu>
X-Original-To: savi@ietfa.amsl.com
Delivered-To: savi@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E02951242EA for <savi@ietfa.amsl.com>; Mon, 11 Dec 2017 15:43:55 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.901
X-Spam-Level: 
X-Spam-Status: No, score=-1.901 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id o1s8R6HX7mdh for <savi@ietfa.amsl.com>; Mon, 11 Dec 2017 15:43:53 -0800 (PST)
Received: from discipline.rit.edu (discipline.rit.edu [129.21.6.207]) by ietfa.amsl.com (Postfix) with SMTP id 48216128B91 for <savi@ietf.org>; Mon, 11 Dec 2017 15:43:53 -0800 (PST)
Received: (qmail 787 invoked by uid 501); 11 Dec 2017 23:43:52 -0000
From: Andrew W Elble <aweits@rit.edu>
To: dhcwg@ietf.org
Cc: savi@ietf.org
Date: Mon, 11 Dec 2017 18:43:52 -0500
Message-ID: <m2wp1sakzr.fsf@discipline.rit.edu>
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (berkeley-unix)
MIME-Version: 1.0
Content-Type: text/plain
Archived-At: <https://mailarchive.ietf.org/arch/msg/savi/pFZfKUhYs9CQoVaOKKRWfqtht6I>
Subject: [savi] Question on RFC2131 / RFC1541
X-BeenThere: savi@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Mailing list for the SAVI working group at IETF <savi.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/savi>, <mailto:savi-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/savi/>
List-Post: <mailto:savi@ietf.org>
List-Help: <mailto:savi-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/savi>, <mailto:savi-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 11 Dec 2017 23:43:56 -0000

I'm wondering about the re-use of XID at time T1. RFC1541 had a clear
explanation as to what was expected of XID at renewal. RFC2131 is
lacking that language.

RFC7513 seems to contain a reference to the use of a new TID/XID at
renewal time.

Should clients be re-using the same XID that was used in the initial
DHCPDISCOVER at renewal?

RFC7513 6.4.3.5:
 Event: EVE_DHCP_RENEW - A DHCPv4 Renew or a DHCPv6 Renew
        message is received
   "In such case, a new TID will be used by the client.  The TID field of
   the corresponding entries MUST be set to the new TID.  Note that TID
   check will not be performed on such messages."

RFC2131 4.1:
 Constructing and sending DHCP messages
   "The 'xid' field is used by the client to match incoming DHCP messages
   with pending requests.  A DHCP client MUST choose 'xid's in such a
   way as to minimize the chance of using an 'xid' identical to one used
   by another client. For example, a client may choose a different,
   random initial 'xid' each time the client is rebooted, and
   subsequently use sequential 'xid's until the next reboot.  Selecting
   a new 'xid' for each retransmission is an implementation decision.  A
   client may choose to reuse the same 'xid' or select a new 'xid' for
   each retransmitted message"

RFC1531/RFC1541 4.4.4:
 Reacquisition and expiration
   "At time T1 after the client accepts the lease on its network address,
   the client moves to RENEWING state and sends (via unicast) a
   DHCPREQUEST message to the server to extend its lease.  The client
   generates a random transaction identifier and inserts that identifier
   into the 'xid' field in the DHCPREQUEST. The client records the local
   time at which the DHCPREQUEST message is sent for computation of the
   lease expiration time.  The client MUST NOT include a 'server
   identifier' in the DHCPREQUEST message."

Thanks,

Andy

-- 
Andrew W. Elble
aweits@discipline.rit.edu
Infrastructure Engineer, Communications Technical Lead
Rochester Institute of Technology
PGP: BFAD 8461 4CCF DC95 DA2C B0EB 965B 082E 863E C912


From nobody Mon Dec 11 16:51:08 2017
Return-Path: <mellon@fugue.com>
X-Original-To: savi@ietfa.amsl.com
Delivered-To: savi@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 1C611128D3E for <savi@ietfa.amsl.com>; Mon, 11 Dec 2017 16:51:07 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=fugue-com.20150623.gappssmtp.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id JbqZ62RcrG8u for <savi@ietfa.amsl.com>; Mon, 11 Dec 2017 16:51:04 -0800 (PST)
Received: from mail-qt0-x22e.google.com (mail-qt0-x22e.google.com [IPv6:2607:f8b0:400d:c0d::22e]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 99FE5128D16 for <savi@ietf.org>; Mon, 11 Dec 2017 16:51:04 -0800 (PST)
Received: by mail-qt0-x22e.google.com with SMTP id u10so43477670qtg.2 for <savi@ietf.org>; Mon, 11 Dec 2017 16:51:04 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=fugue-com.20150623.gappssmtp.com; s=20150623; h=from:message-id:mime-version:subject:date:in-reply-to:cc:to :references; bh=juj+ziY7zq9h7O0V39ogrhBV6ooEakkCPqHQr1vTSZ8=; b=cA/OlQxJosCgpgvp/S6pNGVoinloYJBYXNlggtF0yGX+Q8lI3YCPRejJzJJB1+7owa hLOVshNFGOvV/cf8l47XSAyv+BfLs5JdsXGaxBZMtOUonjukqGdN4FORhfK4TDABqsty mRJbzpVNMn7ZjtoLZohhZ8S6cCEiEhEvm66ZoyoONy17YvuWs36GUq6cU1PItKWz9HRH iQoxldW2TgZuPwh5AHoH/9K7vXh+Kr6qKETXOyaezow7kGwSxQMiNL3EBpSqhkNb1wW5 ueokFEAziojq6voWRPoRkHb8WgeHk+ThoVtGyaZeobw4SC9KLr6ATK4eguGFl7QLsLdK s81Q==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:message-id:mime-version:subject:date :in-reply-to:cc:to:references; bh=juj+ziY7zq9h7O0V39ogrhBV6ooEakkCPqHQr1vTSZ8=; b=k1WJDbmQTb2tNsR7gNd+sf0/+iYo0eOE+AmzI80wBv07FJecPBHTpX+KRppmEHwVcZ oah3DTBgsA22+3PPuyCfaAoKuw1y2sw/fsW9oLp0JpTfP/4AD5rvFXJsL7KAif7bxvt7 Wy9SB2pmdlrntigDmWzuEb6Q9rzIL8MdK4CwdyJ219ERFCFWT+E1euGWjmawuycEYDXS 7w4JgR+vIj/qBRlJdB03g73N4I/GC6h27XQA7bQrnrgpsxyhSm8qE3SaGIJ8Xjly4tyS HrygP4L+Ao4qPFajIpSnoxH9K7+9EfY1OlV8G5ek84WkRYwcwQXCX8ezh2ZR9w0DxEDp WI+Q==
X-Gm-Message-State: AKGB3mJrccxv2UFRvHwXoeiC/xP/SPn+GI+qNHLTUofp2pf+YkjLNETn ThQqOCDVgtSNJK7Yhnk14Uk+iw5EQWw=
X-Google-Smtp-Source: ACJfBosu6uPnYs3aDZjzxBDoLvP572qmSG31t2Ly+54P0z450i5fd/udu6wLvFaJHPbVcKfOwc2ReQ==
X-Received: by 10.55.124.198 with SMTP id x189mr3152194qkc.332.1513039863763;  Mon, 11 Dec 2017 16:51:03 -0800 (PST)
Received: from [10.0.30.153] (c-24-60-163-103.hsd1.ma.comcast.net. [24.60.163.103]) by smtp.gmail.com with ESMTPSA id v17sm4922695qkl.36.2017.12.11.16.51.02 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Mon, 11 Dec 2017 16:51:03 -0800 (PST)
From: Ted Lemon <mellon@fugue.com>
Message-Id: <92E00282-063B-416E-B7C9-E4502F6DFCBA@fugue.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_22F3B010-2F05-4E2C-8C8A-4842C2B59A1C"
Mime-Version: 1.0 (Mac OS X Mail 11.2 \(3445.5.20\))
Date: Mon, 11 Dec 2017 19:51:02 -0500
In-Reply-To: <m2wp1sakzr.fsf@discipline.rit.edu>
Cc: dhcwg@ietf.org, savi@ietf.org
To: Andrew W Elble <aweits@rit.edu>
References: <m2wp1sakzr.fsf@discipline.rit.edu>
X-Mailer: Apple Mail (2.3445.5.20)
Archived-At: <https://mailarchive.ietf.org/arch/msg/savi/Aph1Ien_BXEYpY7e-04Out6J9xc>
Subject: Re: [savi] [dhcwg] Question on RFC2131 / RFC1541
X-BeenThere: savi@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Mailing list for the SAVI working group at IETF <savi.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/savi>, <mailto:savi-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/savi/>
List-Post: <mailto:savi@ietf.org>
List-Help: <mailto:savi-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/savi>, <mailto:savi-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 12 Dec 2017 00:51:07 -0000

--Apple-Mail=_22F3B010-2F05-4E2C-8C8A-4842C2B59A1C
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	charset=us-ascii

On Dec 11, 2017, at 6:43 PM, Andrew W Elble <aweits@rit.edu> wrote:
> Should clients be re-using the same XID that was used in the initial
> DHCPDISCOVER at renewal?

No.


--Apple-Mail=_22F3B010-2F05-4E2C-8C8A-4842C2B59A1C
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=us-ascii

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html; =
charset=3Dus-ascii"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; line-break: after-white-space;" class=3D"">On =
Dec 11, 2017, at 6:43 PM, Andrew W Elble &lt;<a =
href=3D"mailto:aweits@rit.edu" class=3D"">aweits@rit.edu</a>&gt; =
wrote:<div><blockquote type=3D"cite" class=3D""><div class=3D""><span =
style=3D"font-family: Menlo-Regular; font-size: 18px; font-style: =
normal; font-variant-caps: normal; font-weight: normal; letter-spacing: =
normal; text-align: start; text-indent: 0px; text-transform: none; =
white-space: normal; word-spacing: 0px; -webkit-text-stroke-width: 0px; =
float: none; display: inline !important;" class=3D"">Should clients be =
re-using the same XID that was used in the initial</span><br =
style=3D"font-family: Menlo-Regular; font-size: 18px; font-style: =
normal; font-variant-caps: normal; font-weight: normal; letter-spacing: =
normal; text-align: start; text-indent: 0px; text-transform: none; =
white-space: normal; word-spacing: 0px; -webkit-text-stroke-width: 0px;" =
class=3D""><span style=3D"font-family: Menlo-Regular; font-size: 18px; =
font-style: normal; font-variant-caps: normal; font-weight: normal; =
letter-spacing: normal; text-align: start; text-indent: 0px; =
text-transform: none; white-space: normal; word-spacing: 0px; =
-webkit-text-stroke-width: 0px; float: none; display: inline =
!important;" class=3D"">DHCPDISCOVER at renewal?</span><br =
style=3D"font-family: Menlo-Regular; font-size: 18px; font-style: =
normal; font-variant-caps: normal; font-weight: normal; letter-spacing: =
normal; text-align: start; text-indent: 0px; text-transform: none; =
white-space: normal; word-spacing: 0px; -webkit-text-stroke-width: 0px;" =
class=3D""></div></blockquote></div><br class=3D""><div =
class=3D"">No.</div><div class=3D""><br class=3D""></div></body></html>=

--Apple-Mail=_22F3B010-2F05-4E2C-8C8A-4842C2B59A1C--

