Subject: [scale] Third (and final?) call to discuss scaling VPNs

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 Jan 2014 10:46:03 -0000

My previous two emails may have been lost in the vacations.

It is now a working week for most people, so let's have one more attempt to see
whether there is interest in this topic.

Thanks,
Adrian

> -----Original Message-----
> From: scale [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: 03 January 2014 22:21
> To: [email-masked]
> Subject: [scale] Scaling VPNs in the New Year
> 
> Sending this again in the hope of catching some people at their desks at the
> start of January.
> 
> Adrian
> 
> > -----Original Message-----
> > From: scale [mailto:[email-masked]] On Behalf Of Adrian Farrel
> > Sent: 25 December 2013 21:42
> > To: [email-masked]
> > Subject: [scale] Scaling VPNs at Christmas
> >
> > Hello Scale Mailing List,
> >
> > I'm a bit puzzled by the lack of activity on this list. If there is genuine
> > support for the idea of a BoF to discuss scaling VPNs (issues, requirements,
> > moving towards solutions) I would have expected to see more traffic.
> Certainly,
> > if there is no more evidence of enthusiasm to discuss this then I don't
think
> we
> > will go ahead with a face-to-face meeting (i.e. a BoF) at the London IETF.
> >
> > I had expected to hear a chorus of complaints from operators about how they
> > struggle with their deployments today, and how they want to grow them soon.
> I
> > thought I was going to hear from a number of operators about the VPN
> > requirements of data centers. And I had expected a number of vendors to be
> > wanting to talk about how they address these problems. My expectation had
> > been
> > that we would talk about different scaling challenges across the VPN space
and
> > learn what techniques could be common.
> >
> > But it is OK!
> > If no-one has scaling concerns or if no-one wants to talk about them right
> now,
> > we can move on.
> >
> > Cheers,
> > Adrian
> 
> 
> _______________________________________________
> scale mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scale

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 7 Jan 2014 10:14:01 -0500

Hi Adrian -

Silence is deafening, possibly holidays and diversion to next glittering (SDN) object.. :-)

I am interested in scaling and performance requirements of VPNs in data centers as well as carrier networks.
>From vendors (mine) perspective, we need to understand what the realistic expectations are.

Like you, I wish as well, that some of the operators participate in this discussion so that f2f meeting in London could be more productive.

Thanks,
himanshu

-----Original Message-----
From: scale [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, January 07, 2014 5:46 AM
To: [email-masked]
Subject: [scale] Third (and final?) call to discuss scaling VPNs

It is now a working week for most people, so let's have one more attempt to see whether there is interest in this topic.

Thanks,
Adrian

> Sending this again in the hope of catching some people at their desks 
> at the start of January.
> 
> Adrian
> 
> > I'm a bit puzzled by the lack of activity on this list. If there is 
> > genuine support for the idea of a BoF to discuss scaling VPNs 
> > (issues, requirements, moving towards solutions) I would have expected to see more traffic.
> Certainly,
think
> > I had expected to hear a chorus of complaints from operators about 
> > how they struggle with their deployments today, and how they want to grow them soon.
> I
> > requirements of data centers. And I had expected a number of vendors 
> > to be wanting to talk about how they address these problems. My 
> > expectation had been that we would talk about different scaling 
> > challenges across the VPN space
and

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 7 Jan 2014 10:17:28 -0500

Just thinking - it might be possible that not enough people have signed in to this mailing list.
Would it be worth sending your email to other mailing lists such as - mpls, PWE3, L2VPN and L3VPN,
before considering to turn the lights off?

Thanks,
Himanshu

-----Original Message-----
From: scale [mailto:[email-masked]] On Behalf Of Shah, Himanshu
Sent: Tuesday, January 07, 2014 10:14 AM
To: [email-masked]; [email-masked]
Subject: Re: [scale] Third (and final?) call to discuss scaling VPNs

Hi Adrian -

Thanks,
himanshu

-----Original Message-----
From: scale [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, January 07, 2014 5:46 AM
To: [email-masked]
Subject: [scale] Third (and final?) call to discuss scaling VPNs

Thanks,
Adrian

think
and

---

From: ramki Krishnan <[email-masked]>
Date: Tue, 7 Jan 2014 07:28:14 -0800

Hi Adrian,

I and other folks from Brocade are very interested in the VPN requirements for data centers. We are connecting to operators to see their interest in this topic.

Thanks,
Ramki

-----Original Message-----
From: scale [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, January 07, 2014 2:46 AM
To: [email-masked]
Subject: [scale] Third (and final?) call to discuss scaling VPNs

Thanks,
Adrian

think
and

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 Jan 2014 16:34:34 -0000

Hi Himanshu,

You may be right. The list shows "only" 75 subscribers, but I figure that the
list was advertised well enough when created so that those who are concerned did
sign up (you found it :-).

I think as you and Ramki indicated, a number of us would be interested in
hearing what operators would like to achieve as raw numbers in DC VPNs, but to
date not only do we not have those numbers, we don't have an idea whether they
would create any issues. Perhaps these are conversations that operators prefer
to have with their vendors and the scaling issues are more related to
implementations than to protocols.

My conclusion (at the moment) is that the I-Ds that currently hint at scaling
issues for VPNs are providing solutions for speculative problems, or (worse)
trying to find justifications for protocol extensions without real cause.

We'll keep stirring, but I am not holding my breath!

Adrian

> From: Shah, Himanshu [mailto:[email-masked]]
> Sent: 07 January 2014 15:17
> Subject: RE: [scale] Third (and final?) call to discuss scaling VPNs
> 
> Just thinking - it might be possible that not enough people have signed in to
this
> mailing list.
> Would it be worth sending your email to other mailing lists such as - mpls,
PWE3,
> L2VPN and L3VPN,
> I am interested in scaling and performance requirements of VPNs in data
centers
> as well as carrier networks.
> Like you, I wish as well, that some of the operators participate in this
discussion
> so that f2f meeting in London could be more productive.
> 
> Thanks,
> himanshu
> 
>

---

From: Rob Shakir <[email-masked]>
Date: Tue, 7 Jan 2014 17:01:05 +0000

Adrian,

As someone who has worked for a few operators, I’ll raise my head above the parapet.

Wes George and I worked on a draft that characterises some of the problems that we have seen in various operational L3VPN deployments. It really speaks to the specific case of control-plane scaling issues on L3VPN PEs. I do not think that this draft intends to speculate on any new work that the IETF should necessarily commence - although there may be various solutions that could be proposed to helping handle some of the scaling behaviours that we discussed.

As such - I think any BoF that is going to be held on this topic really need to consider what causes scaling issues. For me, there are three different areas: 

 1. An individual operator’s policy on how it implements its networks, products, and the features and capabilities that it supports.
 2. Each equipment vendor’s implementation of these features, and their underlying software architecture.
 3. The features and procedures of the underlying protocols running on each device.

Essentially, even though all of these are going to impact the overall scaling of PEs in L3VPN environments, but it is my feeling that both 1. and 2. are somewhat more of a problem than 3. For instance, both 1 and 2 require understanding of how different devices, or features that could be deployed together interact with one another, and the particulars of how that may be handled in the implementation in question - which are clearly going to be discussions which fall outside of the IETF’s scope. IMHO, often the understanding that operators are trying to get to here is not even trying to drive the highest scale per device, but also about determining the level to which a particular deployment will scale given the various different variables (size of RIBs, frequency of RIB updates, type of services provisioned, OAM features deployed…).

My intention in working on the draft-gs-vpn-scaling doc was to try to highlight what some of the scaling pitfalls can be, and provide some motivation (based on experiences) for such multi-dimensional scaling to be something that is actually examined by equipment implementors (typically, the head-line numbers on the spec. sheet are very nice in isolation, but not very good together). On this note, I am looking to update the doc based on some discussions Wes and I had in Berlin — but I have unfortunately not managed to carve out the cycles to do so just yet.

On the lack of response — I would suggest that collecting operator opinions only through the IETF is likely to be something that yields datasets from relatively few parties inherently, perhaps it is worth posing the question to one or more of the operator group lists.

Kind regards,
r.

---

From: Rob Shakir <[email-masked]>
Date: Tue, 7 Jan 2014 17:08:45 +0000

> My intention in working on the draft-gs-vpn-scaling doc was to try to highlight what some of the scaling pitfalls can be, and provide some motivation (based on experiences) for such multi-dimension…

Although my cycles are limited, they’re not *that* limited — actually I’m updating post-Vancouver!

r.