Subject: [scim] Meeting notes - interest group meetup April 7 2021

From: Pamela Dingle <[email-masked]>
Date: Wed, 7 Apr 2021 18:16:59 +0000

Calendar ICS for this SCIM Interest Group is here: https://outlook.live.com/owa/calendar/00000000-0000-0000-0000-000000000000/25ef962b-555f-4781-b533-bfe7be451be8/cid-95C8043F862EFECA/calendar.ics. Next meeting is April 21, 2021.

Meeting Notes - 7 April 2021
 Comment

Github link for these notes: meetings/2021-04-07.md at main · SCIM-Interest-Group/meetings (github.com)<https://github.com/SCIM-Interest-Group/meetings/blob/main/2021/2021-04-07.md>

<https://hackmd.io/7slTTtbGQvyXx5GR5A3JKg#Attendees>
Agenda

  *   Paul/Matt P go through SCIM-PAM draft
  *   Matt D to go through the actions from previous group surveys (a spreadsheet we are calling the SCIM IG Interest List)

<https://hackmd.io/7slTTtbGQvyXx5GR5A3JKg#SCIM-PAM-ietf-draft-Summary>SCIM PAM ietf draft Summary

  *   Paul/Matt note that they are not original authors and hope they do justice to the original draft spec, with apologies and thanks to Kelly Grizzle, et al

     *   Spec link: https://tools.ietf.org/html/draft-grizzle-scim-pam-ext-01
     *   Spec Github page: https://github.com/kelly-grizzle-sp/scim-pam
     *   Presentation link: https://docs.google.com/presentation/d/1qd6pewmf_DXVydtg9siHeQvC5xhnJ4OmqEQcJzoyf9E/edit#slide=id.gc83ee66d31_0_265
  *   Usage: SCIM PAM is in active use in the SCIM PAM Sailpoint connector

     *   Lots of SailPoint customers are using it already
  *   Purpose: The draft helps IGA+PAM solutions to do two things together:

     *   use SCIM to read Privileged Data
     *   Use SCIM to read and modify the access rights to Privileged Data (ACLs)
  *   Paper Cuts

     *   The draft needs a statement of purpose. The draft does 2 things but nobody ever summarizes those things
     *   Reading/writing ACLs is done in a very specific way - opportunity for us as a group is to make this a more generalized standardized SCIM-esque standard
        *   Because there is no authorization in SCIM the draft had to build that functionality
           *   We have the opportunity to build that into SCIM core which would make this draft much more concise
     *   There is no SCIM concept of linking objects.
        *   We have the opportunity to make that pattern more standardized
        *   Linked objects is a generically useful concept that we could make easy
        *   A way to canonically address the authority
           *   Need some kind of way to designate who the canonical authority is for an attribute
     *   Difficult to determine when something has changed in SCIM
        *   Notifications are a problem
           *   Matt D would love to see a webhook-style change mechanism

<https://hackmd.io/7slTTtbGQvyXx5GR5A3JKg#SCIM-2021-Interest-List>SCIM 2021 Interest List

  *   Matt overviewed the items in the list - a combination of existing drafts (including the SCIM-PAM draft we just reviewed today) and also additional ideas
     *   The tentative plan is
        *   Matt to get the list into a format that we can collectively iterate on
        *   We will make topics out of all the items in this meeting

<https://hackmd.io/7slTTtbGQvyXx5GR5A3JKg#Persistent-Questions-for-Future-Meetings-or-to-go-to-the-group>Persistent Questions for Future Meetings (or to go to the group)

* Is multi-value pagination a special case for groups only or a more generic concern?
* Do we need to address only object pagination or is cursor pagination as important?

<https://hackmd.io/7slTTtbGQvyXx5GR5A3JKg#Next-Meeting>Next Meeting:

  *   April 21, 3pm PT
     *   Pam to ask Mark Wahl if he will summarize his draft
     *   More work on the Interest List
     *   Pam to get the plan for sorting videos figured out

---

From: Matt Domsch <[email-masked]>
Date: Mon, 12 Apr 2021 19:35:42 +0000

I've consolidated/edited the Interest List sent around by Darran Rolls last summer.  You can find it here:

GitHub: https://github.com/SCIM-Interest-Group/wiki/blob/main/SCIM%202021%20Interest%20List.md (read-only)
HackMD: https://hackmd.io/@SCIM-Interest-Group/r1Tmu8iBd  (edit to add yourself to any topic list, or add topics)

I've also posted the Papercuts document that Darin McAdams (AWS) provided, adding SailPoint's own items to consider.

GitHub: https://github.com/SCIM-Interest-Group/wiki/blob/main/Papercuts.md (read-only)
HackMD: https://hackmd.io/@SCIM-Interest-Group/HkjNNGYVO (edit to add your own challenges interpreting the spec  or that your engineering teams have run into).

Thanks,
Matt

Matt Domsch
VP, Engineering Fellow
[email-masked]<mailto:[email-masked]>
www.sailpoint.com<http://www.sailpoint.com/>