Subject: Re: [scim] Registering SCIM Schema Extension

From: Kelly Grizzle <[email-masked]>
Date: Fri, 25 Mar 2022 18:42:52 +0000

If you intend it to be a schema that is standardized and shared beyond your organization, then you can register it.  Otherwise, it is not a requirement.

From: scim <[email-masked]> on behalf of "KATAOKA TOSHIYUKI(片岡　俊幸)" <[email-masked]>
Date: Thursday, March 24, 2022 at 9:47 AM
To: "[email-masked]" <[email-masked]>
Subject: [scim] Registering SCIM Schema Extension

Hello, We are implementing SCIM protocol in one of our services, and in order to add some new attributes we need a new schema such as: “urn:ietf:params:scim:schemas:extension:nec:ope:2.0:User”. According to RFC7643 10.3. and scim mailing list ZjQcmQRYFpfptBannerStart
This Message Is From an External Sender
This message came from outside your organization.
ZjQcmQRYFpfptBannerEnd

Hello,

   We are implementing SCIM protocol in one of our services, and in order to add some new attributes we need a new schema such as:

      “urn:ietf:params:scim:schemas:extension:nec:ope:2.0:User”.

   According to RFC7643 10.3. and scim mailing list archives, I think we need to register a new schema such as above.  Is it correct that we need to send a SCIM schema registration template to this mailing list (scim(at)ietf.org) to register the new schema?

Regards,

Toshiyuki Kataoka

_______________________________________________

scim mailing list

[email-masked]

https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/scim__;!!MsNKLpFGsw!fTbna2L1T2uOxL2iNP12YIvtQbJVf03pZvq768wTTnv9pXl9orLo_7FZR7-_0aefOkHnTuU$

---

From: Phillip Hunt <[email-masked]>
Date: Fri, 25 Mar 2022 12:05:50 -0700

Yes. At the end of the current rfc7643 there is an IANA registration process described. IANA submitted specs are sent to subject matter experts to review for conflicts etc.  When complete, your schema uri is registered with IANA for anyone to look up. 

As Kelly mentions if you don’t intend wide use, you strictly don’t need to register. 

It is a good idea to bring directly to scim wg if there is substantial overlap and/or widely used claims. For example i think the group will be discussing new authenticator extensions and device/iot schemas going forwards based on discussions at this week’s WG meeting. 

Phil

> On Mar 25, 2022, at 11:43 AM, Kelly Grizzle <kelly.grizzle=[email-masked]> wrote:
> 
> 
> ZjQcmQRYFpfptBannerStart
> https://www.ietf.org/mailman/listinfo/scim