Subject: Q. on draft-ietf-tsvwg-sctpsocket-04.txt

From: Marco Molteni <[email-masked]>
Date: Fri, 20 Sep 2002 16:51:35 +0200

Hi Randall :-)

section 5.3 of draft-ietf-tsvwg-sctpsocket-04.txt says:

  1209      Multiple notifications may be returned to a single recvmsg()
  1210      call.  

and then:

  1216      A recvmsg() call will return only one notification at a time.  Just

which is correct ?

thanks
Marco

  1192  5.3 SCTP Events and Notifications
  1193  
  1194      An SCTP application may need to understand and process events and
  1195      errors that happen on the SCTP stack. These events include network
  1196      status changes, association startups, remote operational errors and
  1197      undeliverable messages.  All of these can be essential for the
  1198      application.
  1199  
  1200      When an SCTP application layer does a recvmsg() the message read is
  1201      normally a data message from a peer endpoint.  If the application
  1202      wishes to have the SCTP stack deliver notifications of non-data
  1203      events, it sets the appropriate socket option for the notifications
  1204      it wants.  See section 7.3 for these socket options.  When a
  1205      notification arrives, recvmsg() returns the notification in the
  1206      application-supplied data buffer via msg_iov, and sets
  1207      MSG_NOTIFICATION in msg_flags.
  1208  
  1209      Multiple notifications may be returned to a single recvmsg()
  1210      call.  
  1211  
  1212      This section details the notification structures.  Every
  1213      notification structure carries some common fields which provides
  1214      general information.
  1215  
  1216      A recvmsg() call will return only one notification at a time.  Just
  1217      as when reading normal data, it may return part of a notification if
  1218      the msg_iov buffer is not large enough.  If a single read is not
  1219      sufficient, msg_flags will have MSG_EOR clear.  The user MUST finish
  1220      reading the notification before subsequent data can arrive.

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Fri, 20 Sep 2002 10:56:24 -0500

Well.. this is a good one for La Monte because
I think it was his idea to change it to multiple notifications
coming up in one read... but I can't remember which the authors
agreed to... in any event one of the lines is wrong :>

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: "K. Poon" <[email-masked]>
Date: Mon, 23 Sep 2002 12:43:31 -0700 (PDT)

> agreed to... in any event one of the lines is wrong :>

Was this discussed?  I didn't remember it...

=====
K. Poon.				[email-masked]

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com