Subject: peeloff tester

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 08 Oct 2002 15:07:24 -0500

Hi all:

I have just placed a new "peeloff" testing utility up on
http://www.sctp.org

This utililty is started on the server

peel_server -m port-num-of-server

On the client do

peel_client -h host-of-server -p port-of-server

The client will make two associations to the server and write 4 4k records.

The server will read N bytes of the first record, peeloff the 
association and
then read the 4k-N bytes followed by the other 3 4k records.

After validating the resulting reads are correct it then closes the 
peeled off association.. This
is the key for the client to reconnect the dead assocaition..

This will continue starting where N is 1 up to about 4095...

At the last pass the server will look for one more.. but blow up.. since 
the client as dropped off :>

So you should get nearly 4k passes with all data correct...

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: Nivedita Singhvi <[email-masked]>
Date: Tue, 08 Oct 2002 13:39:50 -0700

> R

Thanks, I just pulled it down. Very handy. This may be 
obvious, but what should sctp_peeloff() return if its
a SOCK_STREAM socket? EOPNOTSUPP? This should be obvious
but I'm not sure..Ditto for a few other cases: what if
the socket isnt even bound yet? 

thanks,
Nivedita

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 08 Oct 2002 16:56:36 -0500

>the socket isnt even bound yet? 
Yeah

EOPNOTSUPP would generally be what one would expect if the peeloff() was
not supported... I know if you don't compile TCP style into the kame kernel
you will get this back..

R

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 08 Oct 2002 18:10:02 -0500

Tcp-style or SOCK_DGRAM = 1 to 1 socket to association
Udp-style or SEQ_PACKET = 1 to many socket to association

R

Nivedita Singhvi wrote:

>Thanks for the response..Just to clarify, are you implying
>that should you have TCP style socket support, then sctp_peeloff()
>could be supported? Hmmm, from my reading of the API draft, I had
>assumed (but I'm fairly new to SCTP and havent done any implementing
>yet) that there was no applicable equivalent for a SOCK_STREAM socket.
>i.e. It isnt supported for tcp-style sockets..If thats not the case,
>then what exactly should happen for a tcp socket? 
>
>I appreciate the help! :)
>
>thanks,
>Nivedita
>
>  
>

---

From: Nivedita Singhvi <[email-masked]>
Date: Tue, 08 Oct 2002 15:15:13 -0700

thanks,
Nivedita