Subject: reliable messages in PRSCTP

From: 王宏涛 <[email-masked]>
Date: Tue, 29 Oct 2002 15:30:28 +0800

I am working on the prsctp module for ns-2. 
I have a question.

when the receiver prcessing a FORWARD TSN, "receiver must use the stream sequence information to examine all of the listed stream reordering queues, and immediately
make available for delivery stream sequence number earlier or equal to the stream sequence number listed in the FORWARD TSN." as mentioned in prsctp draft.

I want to know that if receiver should delivery the reliable messages whose SSN are earlier ot equal to the stream sequence number listed in the FORWARD TSN.

--------------------------------------------------
Hongtao WANG
National Key Lab.
Beijing University of Posts and Telecommunications
Beijing ,100876,P.R.China
Tel:(8610)-62283757
Email:[email-masked]
--------------------------------------------------

---

From: <[email-masked]>
Date: Tue, 29 Oct 2002 13:36:04 +0200

> hello all!

	Hi Wang!

> I have a confusion on the section 3.6 of prsctp draft. as 
> following....
> 
>    "during processing of a FORWARD TSN, the receiver MUST
>    use the stream sequence information to examine all of the listed
>    stream reordering queues, and immediately make available 
> for delivery
>    stream sequence numbers earlier than or equal to the 
> stream sequence
>    number listed inside the FORWARD TSN.
> 
>    After receiving and processing a FORWARD TSN, ... The receiver MUST
>    remove any partially reassembled message which is still missing one
>    or more TSNs earlier than or equal to the new cumulative 
> TSN point."
> 
> 	Should the receiver delivery the full reliable messages 
> which are not expired and t their SSN are earlier than or 
> equal to the stream sequence number listed inside the FORWARD 
> TSN, but they are still missing some chunks (their TSN is 
> earlier than or equal to the new cumulative TSN point).

	Nope... Just take into account that the receiver doesn't know which SSNs are reliable are which are not...

	If an SSN is reliable, simply the data sender will never send you a FORWARD TSN chunk with a TSN newer than the oldest TSN of a reliable SSN pending receipt... If you receive a FORWARD TSN with let's say TSN 100, and TSN 95 was still missing, it means that TSN 95 was part of an unreliable SSN...

	So don't worry, you won't ever be in this situation :-)

>     If the receiver do so, the lifetime of full reliable 
> messages are not usful.in fact the reliable messages are not 
> reliable because they are delivered partially before the 
> their lifetime expire.

	See above... (note also that the lifetime of a reliable message is "forever").

	BR Iván Arias Rodríguez