Subject: FTP over SCTP

From: "Abha Singh Bais" <[email-masked]>
Date: 13 Nov 2002 19:47:39 -0000

hi
During our simulations for ftp over sctp in ns.
We tried using "ftp produce n" but it was not working whereas 
normal case of "ftp start" was working well. Can anyone tell us 
how to control the no of packets being sent and set the packet 
size for the above application.

Thanks
Abha and Nitin

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Fri, 15 Nov 2002 18:00:07 -0500 (EST)

Abha,

You are posting to the wrong list for ns-2 questions. We have a separate
mailing list that you can subscribe to for such questions. If you aren't
on the list already, I can add you (just let me know).

To answer your question:

1. You can send a file with x number of bytes with "ftp send x".

2. You can set the packet size with sctp's mtu_ variable. If you have an
sctp agent called sctp0, you can do "$sctp0 set mtu_ y", where y is the
packet size you want. By default, the mtu is 1500 bytes.

~armando

0--                                                --0
| Armando L. Caro Jr.     |       [email-masked] |
| University of Delaware  |  www.cis.udel.edu/~acaro |
0--                                                --0