Subject: Re: Preprocessor constants indicated SCTP is available?

From: "La Monte Henry Piggy Yarroll" <[email-masked]>
Date: Fri, 01 Nov 2002 06:40:05 -0600

On Thu, 31 Oct 2002 10:07:53 -0600, "Randall Stewart (cisco)" <[email-masked]> w
rote:
> 
> Craig:
> 
> Why don't we just use
> 
> _HAVE_SCTP_xxxxxx
> 
> and then define these all in the next pass of the sockets draft..
> if posix standardizes it then you can do a
> 
> define _POSIX_SCTP_xxxx        _HAVE_SCTP_xxxx

Renaming is hard.  The draft API will be done LONG before POSIX
actually standardizes it.  Is there a serious problem with using the
_POSIX_SCTP_ prefix?  Can we get Open Group to allocate it to us for
preliminary work?

> R
> 
> Craig Rodrigues wrote:
> 
> >On Thu, Oct 31, 2002 at 08:25:37AM -0600, La Monte Henry Piggy Yarroll wrote:
> >  
> >
> >>May I suggest the somewhat presumptuous _POSIX_SCTP?  We should also
> >>define _POSIX_SCTP_PRSCTP, _POSIX_SCTP_ADDIP, and similar symbols for
> >>any optional features in the RFC. 
> >>
> >>A quick scan of the MAY clauses shows mostly minor behavioral and
> >>implementation options.  The only ones I can IMAGINE being useful to
> >>an application writer are:
> >>
> >>_POSIX_SCTP_BUNDLING		- supports outbound bundling,
> >>_POSIX_SCTP_FRAGMENTATION	- supports outbound fragmentation,
> >>_POSIX_SCTP_ESP			- supports IP Encapsulating Security Payload,
> >>_POSIX_SCTP_ECN			- supports Explicit Congestion Notification,
> >>    
> >>
> >
> >Lamonte,
> >
> >You're on the right track for what I'm looking for.  
> >I think it is great, and will make writing portable code a lot easier!!
> >If all the SCTP implementations could agree on something, that would be super.
> > 
> >The only thing is, I caution you about using _POSIX_ as the prefix, since none
> >of these constants have gone through the standards process yet,
> >so they are not "officially"  approved by POSIX.
> >
> >It might be OK, but I would consult with a standards guru before proceeding.
> >
> >  
> >
> 
> 
> -- 
> Randall R. Stewart
> ITD
> Cisco Systems Inc.
> [email-masked] 815-342-5222(cell) or 815-477-2127(office)
> 
> 
>

---

From: Craig Rodrigues <[email-masked]>
Date: Fri, 1 Nov 2002 12:11:04 -0500

> _POSIX_SCTP_ prefix?  Can we get Open Group to allocate it to us for

Let me try contacting someone at the Opengroup.
POSIX comes under IEEE, so IEEE may feel that they own the
_POSIX_* namespace.  That's the only reason
why I suggested holding off on using it.  But give me a few
days to find the right contact in Opengroup.  Opengroup did some
work recently in taking some of the IETF work with the
IPv6 socket API and added that to the Single Unix Specification, v3,
so there is a precedent for adding new networking API's to the standards.

-- 
Craig Rodrigues        Distributed Systems and Logistics, Office 6/325A
[email-masked]       BBN Technologies, a Verizon company
(617) 873-4725         Cambridge, MA