Subject: Implementor's Guide, section 2.27.2

From: David Lehmann <[email-masked]>
Date: Thu, 14 Nov 2002 15:01:51 -0500

In Implementor's Guide, section 2.27.2, it states:
       If the receiver of an INIT chunk detects unrecognized parameters
       and has to report them according to section 3.2.1 it MUST put
       the 'Unrecognized Parameter' parameter(s) in the INIT-ACK chunk
       sent in response to the INIT-chunk.

However, if the parameter type begins with '01', no INIT-ACK will be
sent back to the peer.  In this case, should we sent an ERROR chunk?
If so, the text should be made clearer.

-- 

David Lehmann                          Ulticom, Inc.
AOL/Yahoo IM: davidULCM                1020 Briggs Road
1-856-787-2729                         Mt. Laurel, NJ 08054   USA

---

From: <[email-masked]>
Date: Fri, 15 Nov 2002 00:46:48 +0200

Hi David!

> -----Original Message-----
> From: ext David Lehmann [mailto:[email-masked]]
> Sent: 14 November, 2002 22:02
> To: sctp-impl
> Subject: Implementor's Guide, section 2.27.2
> 
> 

	Yeah, I think you are right. If the peer has to discard the INIT but still report the error, it should send an ERROR chunk back...

	The problem is that some implementations where sending always the ERROR chunk, in a separate chunk (and the INIT ACK didn't carry the 'Unrecognized Parameter' parameter). This way there is a possibility that the ERROR chunk gets first to the destination and then, and there is no association yet, the ERROR receiver should send back and ABORT that would abort the association... Later on the INIT ACK would be received and accepted, but probably the INIT sender won't accept the COOKIE ECHO because it will have already aborted the association...

	I thinks this should be made more clear.

	BR Iván Arias Rodríguez