Subject: another question about implementing add ip

From: <[email-masked]>
Date: Fri, 22 Nov 2002 17:00:36 +0800

hi,

Here is another question about implementing add ip.

If the sender requests to set primary path to an address not in its address list by mistake, what shall the receiver do?
Which error cause should be used?

Thanks!

Dajiang Zhang

---

From: "Manish Rajpal" <[email-masked]>
Date: Fri, 22 Nov 2002 17:40:12 +0530

hi

As told in the draft, its an option that receiver SHOULD perform. If the
request can not be honored for whatsoever reasons, it can be ignored. And no
response will be taken as success by the peer.
newayz, any message from the peer with such an address that does not exist
will be responded back by an abort.

regards
manish
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, November 22, 2002 2:30 PM
Subject: another question about implementing add ip

hi,

If the sender requests to set primary path to an address not in its address
list by mistake, what shall the receiver do?
Which error cause should be used?

Thanks!

Dajiang Zhang

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Fri, 22 Nov 2002 10:00:32 -0600

>response will be taken as success by the peer.

Yes.. I agree with the above.. you ignore the set-primary that sets to
an address that does
not exist.

>will be responded back by an abort.

Hmm.. what does "newayz" mean? You never would send an abort to a peer
that said
set-primary(x) when (x) is not in the association.

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: "Manish Rajpal" <[email-masked]>
Date: Mon, 25 Nov 2002 19:23:01 +0530

well, what I meant to say was if the peer considers x to be a part of
associations and uses this address as source address in any further messages
, it will be responded back with an abort.