Subject: Error Cause TLV in ASCONF-ACK

From: [email-masked]
Date: Mon, 30 Dec 2002 14:24:23 +0530

Hi

The addip draft says:
"The  entire TLV that is refused is copied from the ASCONF into the  error
cause.",

but in the example TLV shown below (as in the draft)

        +--------------------------------+
        | Type = 0xC003  | Length = 24   |
        +--------------------------------+
        |       C-ID = 0x01023474        |
        +--------------------------------+
        |  Cause=0x000C  | Length = 16   |
        +----------------+---------------+
        |  Type=0xC001   | Length = 12   |
        +--------------------------------+
        |  Type=0x0005   | Length = 8    |
        +----------------+---------------+
        |       Value=0x0A010101         |

The Request being refused to ADD an address does not have the correlation ID,
which is not the case when TLV is copied from the chunk.
Please clarify the right behavior.
Should 1) the ASCONF ACK contained TLV copied from the asconf chunk (as written
in text)?, or
2) The sender of ACK must build the parameter without the correlation id (as
shown in all examples)

regards
manish
www.hssworld.com

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Mon, 30 Dec 2002 07:03:58 -0600

>but in the example TLV shown below (as in the draft)

This is an error in the draft and I will fix it in the next pass :-0

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)