Subject: RE: Multihoming with NAT

From: [email-masked]
Date: Mon, 2 Dec 2002 11:18:16 +0530

hi,

see my comments [MR],

regards
manish
www.hssworld.com

[email-masked] on 11/28/2002 07:40:42 PM

To:   Manish Rajpal/HSS@HSS
cc:   [email-masked], [email-masked]

Subject:  RE: Multihoming with NAT

     Hi!

> hi
>
> No! you don't need a SCTP aware NAT, lets suppose NAT has two
> addresses, then
> both these addresses can be used for the  association. The
> packets sent by the
> peer to any of these addresses will be routed to the sctp
> host which has got a
> single address. So u have a multihomed association without
> the host having more
> than one address.

     I must confess that I really never completely understood how NATs and DNS
are compatible... NATs allocate address for the use of a host during a certain
time... so, are NATs changing DNS entries every time they assign different
addresses to different hosts? And they have to do this so everybody can know...
I don't really know how this can work... :-/ Unless DNS entries are only given
to "static" hosts that have regular access to the "outside world" and that
always use the same addresses...

[MR] its just that when the internal hosts do a lookup, these names will be
resolved to internal addresses. But if the hostname is resolved outside the
current realm, the addresses obtained must a be subset of the external addresses
that NAT has. The host name resolution will be based on the address realm.

> about the misbehaving routers, i'ld like say that its the
> multihoming that comes
> to rescue when you have diffrent addresses belonging to
> different networks, So
> while one network is not in good health the packets can take
> diffrent route to
> reach destination.

     But at the end, all the packets have to go to the same destination: the
NAT. Well, the NAT can be connected easily to different networks... yes you are
right...

[MR]I haven't come across many NAT boxess, I am not sure if its that really
easy.

> Its just that the INIT/INIT ACK chunks that communicate the
> addresses to the
> peer and if we can send a hostname, we can create the
> multi-homed association.

     Could you please quickly explain me how DNS and NATs are compatible? I just
don't know and feel lazy to check RFCs... :-)
[MR] only RFC 2694 would help

> Only restrition I see is dynamically adding or delteting IP
> addresses from such
> an association.

     Yes, that's right... Unless you change the DNS entry and then you send in
the ASCONF not the IP address but the host name... I don't think anybody would
support this... and I don't think it is feasible either...

[MR] The draft does not allow you to send hostname in ASCONF chunk.

> And if NAT is sctp aware, which is least likely, you don't
> even need the
> hostname as the NAT can itself  translate the addresses in
> INIT/INIT-ACK.
> So  we don't require anything new from existing NAT box, all
> that is required is
> to send a hostname in the INIT/ INIT ACK that will be resolved to the
> address(es) of NAT. So probably a new interface that allows a
> user to specify a
> hostname for a socket to bind to. If the NAT io

     Seems that the message was truncated...

     BR Iv

án Arias Rodríguez

> regards
> manish
> www.hssworld.com
>
>
>
>
>
> [email-masked] on 11/28/2002 06:03:35 PM
>
> To:   Manish Rajpal/HSS@HSS, [email-masked]
> cc:   [email-masked]
>
> Subject:  RE: Multihoming with NAT
>
>
>
>
>      Hi!
>
> > hi,
> >
> > I don't think so, multihoming can work very well behind a NAT
> > too. if NAT can
> > translate one address, it can translate n addresses. I don't
>
>      I think this is precisely the problem... NATs don't know
> anything about
> SCTP, so at most they can translate the source address of the
> IP packet. All the
> deployed NATs are not ready to recognize Protocol Number 132
> and then look
> inside every of such packets and recognize an INIT/INT ACK
> chunk, so it can dig
> inside the packet and recognize de address parameters...
>
>      Of course, if you re-code a NAT to do such thing, I
> think it would work...
> :-/ But, who is the one that is going to re-code all the
> existing NATs...?
>
>      Besides, I don't really think that having multihoming
> while being behind a
> NAT is really anything useful... I'm not an expert, but I
> would say that you
> normally have only one NAT that is "covering" a stub domain.
> It means that all
> the packets have to go anyway through the NAT... Well, you
> can always have
> several netwok cards, and then multihoming would prevent
> failure if one of the
> cards itself fails, but it won't prevent about misbehaving
> routers in the way...
>
> > foresee any issue.
> > In fact, with NAT, its possible that a host running sctp and
> > having single
> > address can appear as a multihomed host to the peer. Only NAT
> > box has to Map
> > both the external addresses to a single internal address.
>
>      But it has to be able to do so... which is not true so far...
>
>      BR Iv
>

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Mon, 02 Dec 2002 11:19:52 -0600

>[MR]I haven't come across many NAT boxess, I am not sure if its that really
I can sure tell that by your statements.. I have dealt with a number of 
them and they
need changes to work with hostnames or anything else having to do with
SCTP multi-homing.

>[MR] The draft does not allow you to send hostname in ASCONF chunk.

And I see NO reason to add it.. There is no value in hostname parameters for
the add-ip draft... and I do not see it being added..

R

>------------------------------------------------------------------------
>
>
>án Arias Rodríguez
>
>  
>
>>regards
>>manish
>>www.hssworld.com
>>
>>
>>
>>
>>

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)