Subject: Same transport addresses for two SCTP associations within a host

From: [email-masked]
Date: Wed, 4 Dec 2002 15:22:50 -0500

Hi List,

o  SCTP endpoint: The logical ............... A transport
      address used by an SCTP endpoint must not be used by another SCTP
      endpoint.  In other words, a transport address is unique to an
      SCTP endpoint.

Does this prevent us to use same transport address ( IP address + port
number, in case of SCTP running over IP) for two associations within a
host? I think that it is OK to have same transport addresses when their
peer's transport addresses are different.

Simon
Radisys Corp.

---

From: <[email-masked]>
Date: Thu, 5 Dec 2002 14:20:40 +0200

Hi!

	This is a classical mistake. The point is that you establish an association between two endpoints. You can see an endpoint as a kind of "multi-IP socket".

	Imagine you are just listening. Imagine that you have two endpoints that share an IP address (and of course they use the same port). In this situation, you receive an INIT, and, which endpoint gets it?

	In TCP you cannot have two sockets listening in the same address and port at the same time. This is kind of similar...

	Of course, from a single endpoint you can have several associations with some other different endpoints...

	I hope it helps!

	BR Iván Arias Rodríguez

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 04 December, 2002 22:23
> To: [email-masked]
> Subject: Same transport addresses for two SCTP associations within a
> host
> 
> 
> Hi List,
>