Subject: processing INVALID_STREAM_ID

From: Mohammed Ashraf <[email-masked]>
Date: Thu, 02 Jan 2003 13:09:51 +0530

Hi,
    I would like to know if there is any recommended action ( like : given below
)to be taken when the sctp stack receives an ERROR chunk with INVALID_STREAM_ID.

  - dropping all  the packets sent on this stream from the Tx q and notifying ULP
abt the send failure and deciding no to send any more packets on this stream )
- ABORT the connection and restart it so that stream negotioation can be done
agian.
etc ..

thanks,
ashraf

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Thu, 02 Jan 2003 12:40:33 -0600

>- ABORT the connection and restart it so that stream negotioation can be done
Mohammed:

I am not sure what the recommended action should be :>  The one big key
is you better be announcing the problem to some log ..since if you send to
a invalid stream your stack (or possibly your peers) has a software 
bug... i.e.
either you negotiated the number of streams to be X and are using X+1 or
you negotiated the number of streams to be X and your peer somehow thinks
it is less than X...

Either way a log of the error is appropriate and then the gulity party 
needs to
find and fix the bug :>

R

>  
>
>------------------------------------------------------------------------
>
>**************************Disclaimer**************************************************    
> 
> Information contained in this E-MAIL being proprietary to Wipro Limited is 'privileged' 
>and 'confidential' and intended for use only by the individual or entity to which it is 
>addressed. You are notified that any use, copying or dissemination of the information 
>contained in the E-MAIL in any manner whatsoever is strictly prohibited.
>
>****************************************************************************************
>
>
>
>  
>

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)