Subject: SCTP - Protocol Violation

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Tue, 21 Jan 2003 09:00:59 +0530 (India Standard Time)

Hi All,
    A new cause code "Protocol Violation" is added in the sctp-imp guide
version-7. 
    I want to know the any example, when this error will be send.

Regards,
Vijay

---

From: Schruefer Wolfgang <[email-masked]>
Date: Tue, 21 Jan 2003 09:39:35 +0100

Hi Vijay,

here an example when we abort with this cause:

Two data chunks of the same stream with a TSN / SSN mismatch are received, e.g.:
chunk A: TSN=1, SSN=1
chunk B: TSN=2, SSN=3

Regards
Wolfgang
 
-----Ursprüngliche Nachricht-----
Von: Vijay Kumar Choudhary [mailto:[email-masked]]
Gesendet: Dienstag, 21. Januar 2003 04:31
An: [email-masked]
Betreff: SCTP - Protocol Violation

Hi All,

Regards,
Vijay

---

From: Meyknecht Bernward <[email-masked]>
Date: Fri, 24 Jan 2003 17:18:00 +0100

Hi Vijay,

another example for sending an ABORT with 'protocol violation' is the 
receipt of an invalid INIT, maybe with length too short or with 
invalid parameters (sream number values =0 or init tag =0).
This cause code is especially helpful for debugging.

If your SCTP receiver checks that an INIT has to be the only chunk in 
an SCTP packet, you can also use this cause code with ABORT when  
you receive such a packet.

Kind regards,

Bernward

-----Ursprüngliche Nachricht-----
Von: Vijay Kumar Choudhary [mailto:[email-masked]]
Gesendet: Dienstag, 21. Januar 2003 04:31
An: [email-masked]
Betreff: SCTP - Protocol Violation

Hi All,

Regards,
Vijay