Subject: Applications using SCTP multihoming

From: "Eng Se-Hsieng" <[email-masked]>
Date: Tue, 18 Feb 2003 17:05:37 +0800

Dear all,

I'm running the 2.4.18 version of lksctp and wondering if I can make use
of the mozilla or apache available on www.sctp.org which was written for
BSD.

Would anyone know of any applications (e.g. ftp, browser) written for
lksctp which uses multihoming with failover successfully?

Thank you.

Regards,
Se-Hsieng
Singapore

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 18 Feb 2003 06:39:18 -0600

Eng Se-Hsieng wrote:

> Dear all,
>
> I'm running the 2.4.18 version of lksctp and wondering if I can make 
> use of the mozilla or apache available on _www.sctp.org_ 
> <file://www.sctp.org> which was written for BSD.
>
Se-Hsieng:

I can't say for sure if it will work, having not tested it :> It really
depends on if lksctp implemented the TCP model API. This is
required, since the mozilla on www.sctp.org just changes a few
things (aka the protocol type) in all the socket calls.

Maybe Jon can say if the TCP model is there..

Regards

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: Jon Grimm <[email-masked]>
Date: Tue, 18 Feb 2003 08:34:23 -0600

> Maybe Jon can say if the TCP model is there..

Hi Eng (& Randy)

Nope, lksctp doesn't yet have TCP-style ... however I anticipate 
starting this within the month.   BTW, the 2.4.18 lksctp is far, far out 
of date and not supported.

If you want to play with failover, you should be able to use sctp_darn 
or sctp_test which are in the sctp-tools tarball.

Best Regards,
Jon