Subject: Re: TCP/UDP style

From: "K. Poon" <[email-masked]>
Date: Sat, 1 Feb 2003 06:49:33 -0800 (PST)

--- "Randall Stewart (cisco)" <[email-masked]> wrote:
> We have worked hard to try to get options available to the TCP side
> to make
> it equate to the UDP style... but even at that there is at least one
> thing
> that the UDP style can do that the TCP style can not..
> 
> you can do a
> 
> send(data,...)
> to start an association... this gets it so that you have data bundled
> on the cookie-echo.

Depending on the implementation, an app can send data in the
cookie-echo packet by using a non-blocking connect() and then a
send().

> There were other features that were not accerssable to TCP at one
> time.. but as I said we have made ways for a tcp style to use these 
> too.. even
> though they are harder to use...
> 
> Expect to see in the next draft a
> 
> send_sctp() of some sort that hopfully makes it easier for both TCP
> and UDP
> to use the API..

What is send_sctp()?  It seems to me that it may not be a good
idea to have a send_sctp() if it is what I think.  Let's discuss
off line first...

=====
K. Poon.				[email-masked]

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Sat, 01 Feb 2003 17:52:53 -0600

>idea to have a send_sctp() if it is what I think.  Let's discuss

Yes.. I belive La Monte did mention it a while back and we just have not
gotten around to discussinng it :>

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)