Subject: RE: [Lksctp-developers] Re: Applications using SCTP multihoming

From: "Eng Se-Hsieng" <[email-masked]>
Date: Wed, 19 Feb 2003 20:13:35 +0800

> If you want to play with failover, you should be able to use sctp_darn 
or sctp_test which are in the sctp-tools tarball.

Not all my network interfaces were accessible using sctp_darn.

My Toshiba satellite 4030CDT has one wired LAN connection (eth0) and one wireless LAN (Cisco Aironet 350:eth1).

In one shell, I typed 'sctp_darn -H 0 -P 250 -l'
and in another I entered 'sctp_darn -H 0 -P 260 -h X.X.X.X -p 250 -s', replacing X.X.X.X with the IP addresses of localhost, eth0 and eth1 successively.

The listening side received messages sent to localhost and WLAN successfully and 6 SCTP frames were generated each time in ethereal. However, no message was received when the remote host was set to wired LAN but Ethereal shows an INIT from the WLAN interface to the wired LAN interface.

If I bind the multiple addresses manually with the -B option, I can only receive messages sent to the WLAN interface.

1. Was my usage of sctp_darn correct for a multihoming case?

2. For failover, I disconnected the WLAN card. The messages did not arrive on the wired LAN interface.

3. Ethereal hangs after capture or shuts itself down while testing the above.

I would be most grateful for any suggestions.

> BTW, the 2.4.18 lksctp is far, far out of date and not supported.

It is apparently not trivial to upgrade from Redhat 7.3 2.4.18 to 2.5.59. While I understand that this would allow me to keep in sync with lksctp, I apparently need to upgrade a lot of software (compilers, libs,etc.). Could someone kindly point me to an appropriate resource or offer more detailed instructions please?

Thank you.

Eng Se-Hsieng

-----Original Message-----
From:	Jon Grimm [mailto:[email-masked]]
Sent:	Tue 2/18/2003 10:34 PM
To:	Randall Stewart (cisco)
Cc:	Eng Se-Hsieng; [email-masked]; [email-masked]
Subject:	Re: [Lksctp-developers] Re: Applications using SCTP multihoming
 > Maybe Jon can say if the TCP model is there..
 >

Hi Eng (& Randy)

Nope, lksctp doesn't yet have TCP-style ... however I anticipate 
starting this within the month.   BTW, the 2.4.18 lksctp is far, far out 
of date and not supported.

If you want to play with failover, you should be able to use sctp_darn 
or sctp_test which are in the sctp-tools tarball.

Best Regards,
Jon

---

From: Jon Grimm <[email-masked]>
Date: Wed, 19 Feb 2003 08:30:19 -0600

Hi Eng,
	Lets move this discussion to lksctp-developers.

Thanks, jon