Subject: Re: Matching addresses in INIT and INIT ACK

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Wed, 12 Mar 2003 11:25:30 -0600

[email-masked] wrote:

>	... snip...
>
>  
>
>>>	But... When sending an INIT, how could you get an ABORT 
>>>      
>>>
>>back (without error causes)? We have the next possible error 
>>causes as an answer to the INIT:
>>    
>>
>>>	- Missing Mandatory Parameter
>>>	- Out of Resource
>>>	- Unresolvable Address
>>>	- Invalid Mandatory Parameter
>>>	- Unrecognized Parameters
>>>
>>>	I don't know now about any situation in which you would 
>>>      
>>>
>>send an empty ABORT as a response to an INIT. So most 
>>probably receiving a plain ABORT simply means 'Restart of an 
>>association with new addresses'... :-/
>>    
>>
>>What about when there is no one listening on that port? I suppose one
>>could send a "out of resource" in this case.. but I think I 
>>send just a
>>plain ole ABORT no error cause when this occurs :-0
>>    
>>
>
>	I might be talking nonsense, but, if you are not listening to that port, wouldn't you receive an ICMP 'port unreachable' message?
>
>	BR Iván Arias Rodríguez
>
>  
>
Well, no not really,  you would get a ICMP if there was no protocol 
registered to
handle SCTP..

But just like when you send a SYN to a TCP port that is not listening 
you get a RST
in SCTP you should get an ABORT()

I just double verifyed that my new code to handle adding new addresses 
in a INIT
scenario (which used to silently discrd the packet.. opps.. is now going 
to send
the same type of ABORT as a no listner port :>... no error cause at all).

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: <[email-masked]>
Date: Wed, 12 Mar 2003 18:58:57 +0200

... snip...

	BR Iván Arias Rodríguez