Subject: Re: Question on Multihoming

From: Dimitrios Apostolidis <[email-masked]>
Date: Fri, 25 Apr 2003 16:05:06 +0200

Hi,

thank you for your comments.
Now it makes sense :-)

Thanks again,
Dimi

[email-masked] schrieb:

>	Hi!
>
>	A comment on the original message... inline...
>
>  
>
>>Dimi:
>>
>>I would imagine during the resend of the COOKIE-ECHO all of
>>the addresses would have been tried for endpoint-2.
>>
>>After the failure the association structure in the kernel will most
>>likely be removed.. so no record of the other addresses would
>>exist... so.. if the app wanted to use a different address
>>it would have to specify so...
>>    
>>
>
>	Sure. See below...
>
>  
>
>>R
>>
>>
>>Dimitrios Apostolidis wrote:
>>
>>    
>>
>>>Hi,
>>>
>>>I have a question on how MultiHoming can be used.
>>>
>>>Following scenario:
>>>1) endpoint 1 sends an INIT to endpoint 2
>>>2) endpoint 2 answers with an  INIT ACK with several IP address 
>>>parameters
>>>3) endpoint 1 sends a COOKIE ECHO
>>>4) endpoint 2 does not send a COOKIE ACK
>>>5) after the timer expires endpoint 1 sends again the COOKIE ECHO
>>>
>>>If endpoint two is not answering again, endpoint 1 will try this 
>>>Max.Init.Retransmits.
>>>Then it reports a failure, enters the closed state and retransmitts 
>>>the INIT (see Section 5.1.6 of rfc2960)
>>>      
>>>
>
>	I think you have misunderstood the paragraph of 5.1.6. It doesn't say that *after* entering the closed state you start again retransmitting the INIT chunk. It says "when retransmitting the INIT", but this is supposed to happen before, not after closing the association. I.e., the association establishment phase is as follows...
>
>	1) You send the INIT.
>	2) If you don't receive the INIT ACK you retransmit the INIT (this is what that text at the end of the section is about).
>	3) When you receive the INIT ACK, you send the COOKIE ECHO.
>	4) If you don't receive the COOKIE ACK, you retransmit the COOKIE ECHO.
>
>	Too many retransmissions at 2) or 4) makes you fail the establishment phase, so you close the association, you report it to the upper user, *and nothing else* (unless the upper user tells you to do so).
>
>	At this point, Randall's explanation should be obvious for you: since you have erased everything, and you only send again INITs to the same endpoint *if the upper user tells you to do so* (i.e., restarting again the whole process, unrelated to the previous attempt), you can only use the address the upper user provides you.
>
>	I hope it helped!
>
>	BR Iván Arias Rodríguez
>
>  
>
>>>Now, I have the following question:
>>>Does this new INIT have to be sent to the same IP address 
>>>      
>>>
>>or can it be 
>>    
>>
>>>sent to one of the alternative IP addresses found in the INIT ACK?
>>>I didn't find anything in the standard (or did I overlook 
>>>      
>>>
>>something?)
>>    
>>
>>>
>>>Kind Regards,
>>>Dimi
>>>
>>>
>>>      
>>>
>>-- 
>>Randall R. Stewart
>>ITD
>>Cisco Systems Inc.
>>[email-masked] 815-342-5222(cell) or 815-477-2127(office)
>>
>>
>>
>>    
>>
>
>  
>

---

From: <[email-masked]>
Date: Fri, 25 Apr 2003 16:39:01 +0300

Hi!

	Sure. See below...

	1) You send the INIT.

	I hope it helped!

	BR Iván Arias Rodríguez