Subject: HEARTBEAT-DATA

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Mon, 21 Apr 2003 14:09:14 +0530 (India Standard Time)

Hi All,
    Can we send HEARTBEAT chunk if the data transfer is going on ?

Regards,
Vijay

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Mon, 21 Apr 2003 14:50:58 -0500

>    Can we send HEARTBEAT chunk if the data transfer is going on ?
Sure.. at least to idle destinations..

Whenever you HB timer goes off if a RTT measurement as not been made
within a RTO you should send a HB .

If data is actively being sent on the address the above condition will NOT
be true and you don't need to HB...

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 21 Apr 2003 15:02:03 -0500

On 4/21/03, Randall Stewart (cisco) wrote:

>Whenever you HB timer goes off if a RTT measurement as not
>been made within a RTO you should send a HB .
>
>If data is actively being sent on the address the above
>condition will NOT be true and you don't need to HB...
>
>R
>

Section 8.3 also specifies that the upper layer can
initiate a Heartbeat:

   D) Request an on-demand HEARTBEAT on a specific 
    destination transport address of a given 
    association.
        
Now it might seem nonsensical for the upper layer would
request sending both a heartbeat and data to the same
destination, but then the upper layer's motivations are by
definition out of scope.

Caitlin Bestler
http://asomi.com/CaitlinBestler/

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Mon, 21 Apr 2003 15:51:24 -0500

>destination, but then the upper layer's motivations are by
Yep.. forgot that one.. but true.. if the ULP sent data AND issued
a HB request (on demand).. one would send it out without concern
for the RTT times... etc.

R