Subject: Question on Multihoming

From: Dimitrios Apostolidis <[email-masked]>
Date: Fri, 25 Apr 2003 14:03:01 +0200

Hi,

I have a question on how MultiHoming can be used.

Following scenario:
1) endpoint 1 sends an INIT to endpoint 2
2) endpoint 2 answers with an  INIT ACK with several IP address parameters
3) endpoint 1 sends a COOKIE ECHO
4) endpoint 2 does not send a COOKIE ACK
5) after the timer expires endpoint 1 sends again the COOKIE ECHO

If endpoint two is not answering again, endpoint 1 will try this 
Max.Init.Retransmits.
Then it reports a failure, enters the closed state and retransmitts the 
INIT (see Section 5.1.6 of rfc2960)

Now, I have the following question:
Does this new INIT have to be sent to the same IP address or can it be 
sent to one of the alternative IP addresses found in the INIT ACK?
I didn't find anything in the standard (or did I overlook something?)

Kind Regards,
Dimi

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Fri, 25 Apr 2003 08:14:14 -0500

Dimi:

I would imagine during the resend of the COOKIE-ECHO all of
the addresses would have been tried for endpoint-2.

After the failure the association structure in the kernel will most
likely be removed.. so no record of the other addresses would
exist... so.. if the app wanted to use a different address
it would have to specify so...

R

Dimitrios Apostolidis wrote:

> Then it reports a failure, enters the closed state and retransmitts 
> the INIT (see Section 5.1.6 of rfc2960)
>

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)