Subject: a question of rcv-buf initializaion

From: "Lei Zhang" <[email-masked]>
Date: Tue, 29 Jul 2003 12:47:23 +0200

Hi:

During initialization of SCTP, a receive buffer should be set as 2^32 (42947295). I wonder if there is any other conditions like in TCP

[rcv_buff = (4 * snd_mss < 65536) ? 4 * snd_mss : 65536 ]  has been specified in SCTP.

Somebody could kindly tell me for sure?

Thanks a lot

Lei

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 29 Jul 2003 08:54:33 -0500

>Somebody could kindly tell me for sure?
The KAME stack sets it equal to a configured value
of 128k... a larger value by default is a good thing ... it
helps in long bandwidth/delay situations...

I don't think there is a requireiment on what you set it to... but the
larger you can make it I think the better.....

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)