Subject: Re: question: 'application adaptation for SCTP'

From: [email-masked]
Date: Mon, 1 Sep 2003 03:56:37 -0700 (PDT)

Suggest you to read the interface section of SCTP in RFC2960.
Every outgoing msg must indicate a stream number. That
is ULP's responsibility.

> Hi, friends:
>
> Here I have a question about those applications using SCTP.
>
> Like we all know, SCTP includes a key parameter that is a value of
> "Outbound Streams". basically this allocation is up to the application.
> In most cased only the application has the right knowledge about the
> nature and types of its data.
>
> The question is Application should send a packet with the stream number
> which the packet belongs to. Does that means, to implement my
> simulation, that I must modify the application layer? otherwise, how is
> the application able to send the packet, indicating the stream number..
>
> Waiting your reply...
>
> Regards
>
> Lei Zhang

---

From: "Lei Zhang" <[email-masked]>
Date: Mon, 1 Sep 2003 12:08:38 +0200

Hi, friends:

Like we all know, SCTP includes a key parameter that is a value of "Outbound Streams". basically this allocation is up to the application. In most cased only the application has the right knowledge about the nature and types of its data. 

The question is Application should send a packet with the stream number which the packet belongs to. Does that means, to implement my simulation, that I must modify the application layer? otherwise, how is the application able to send the packet, indicating the stream number..

Waiting your reply...

Regards

Lei Zhang