Subject: Re: A question about RFC2960.

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 5 Sep 2003 09:14:34 -0600

Ivan.Arias-Rodriguez,

On Fri, 05 Sep 2003, [email-masked] wrote:

> > THW interpretation, that is what it SAYS.
> 
> 	I don't know what THW means :-(

To H*ll With.

> > Just the embarrasing correction in IG 2.7.
> 
> 	No, 2.7 is not there because of that. It is there to leave clear that
> 	you can have CWnd + MTU - 1 bytes in flight.

Yes, even after T3-rtx expiry.  Embarrassing, isn't it?

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: [email-masked]
Date: Fri, 5 Sep 2003 18:09:59 +0300

> > >    Note: Any DATA chunks that were sent to the address 
> for which the
> > >    T3-rtx timer expired but did not fit in one MTU (rule 
> E3 above),
> > >    should be marked for retransmission and sent as soon 
> as cwnd allows
> > >    XXXXXX                                  
> XXXXXXXXXXXXXXXXXXXXXXXXXXX
> > >    (normally when a SACK arrives).
> > >    
> > > Because CWND allows on Destination B, they SHOULD be sent 
> immediately.
> > 
> > 	But if the meaning is "sent as much as cwnd allows" and 
> not "send only
> 

	Maybe, if I'm not the only thinking as I do, or you are not the only one thinking as you do, this section might need a clarification... :-/

> > 	a datagram now, and the rest later", the note doesn't 
> make any sense,
> > 	because you are ALWAYS able to have at least two 
> datagrams in flight
> > 	and thus you can always send at least 2*MTU bytes 
> (little bit less in
> > 	fact)...
> 

	No, 2.7 is not there because of that. It is there to leave clear that you can have CWnd + MTU - 1 bytes in flight.

	If the user messages have different sizes and they don't exactly fit the MTU (i.e., the CWnd) then you must send more than CWnd or you will never increase it.

	It is not a correction, is a clarification... And, why is it embarrassing?

> > 	By the way, the note says "that were sent to the 
> address for which the
> > 	T3-rtx timer expired". I'm not sure if this is correct, 
> since it takes
> > 	for granted that you retransmit the chunks to the same 
> address, which
> > 	is wrong if you are not single-homed...
> 
> Well, they must have been sent to the address for which 
> T3-rtx expired in the
> first place, otherwise the timer would not have tolled for them...

	Sorry. I understood "DATA chunks that were sent" as the ones included in that packet sent right after T3 expiration.

	My mistake here.

	BR Iván Arias Rodríguez