Subject: RE: question: 'application adaptation for SCTP'

From: "Caitlin Bestler" <[email-masked]>
Date: Mon, 1 Sep 2003 13:02:31 -0500

It is possible for a higher level protocol to have a concept
of "endpoints" that are connected to each other and that can
then reliably exchange messages. The underlying connection
could be a TCP connection or a pair of SCTP streams.

This is also a very useful abstraction for encouraging
migration to SCTP.

The mapping of RDMA over IP to SCTP in the rddp WG
assumes this sort of strategy.

It could apply to any upper layer protocol that reliably
exhcnages a sequence of messages. So if the exisitng TCP
adaptation has to waste time putting message delimiters
in, then the approach could easily work.

With this approach the application is not aware of the
SCTP association, just its "Connection" on a pair of
streams. It is only applicable if it makes sense to
have multiple "connections" between two hosts within
a single session.

Otherwise, you're into an application specific mapping.
If the existing TCP version of the application only
uses a single connection then it will be hard to retrofit
multiple streams into the SCTP adaptation.

-----Original Message-----
From: Lei Zhang [mailto:[email-masked]]
Sent: Monday, September 01, 2003 6:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: question: 'application adaptation for SCTP'

Hi, yuzhou;

Thanks for the reply, actually, there is a ULP process between Applicatio
and SCTP called "tpal" in my simulation (on OPNET). I don't know if I should
only operate the "tpal" layer or reckon the application layer as well.

Maybe I didn't explain my question clearly, sorry.

If anyone has a experience with OPNET for studying SCTP, could you give me
some instruction?

Best Regards

Lei

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, September 01, 2003 12:57 PM
To: Lei Zhang
Cc: [email-masked]
Subject: Re: question: 'application adaptation for SCTP'

Suggest you to read the interface section of SCTP in RFC2960.
Every outgoing msg must indicate a stream number. That
is ULP's responsibility.

> Hi, friends:
>
> Here I have a question about those applications using SCTP.
>
> Like we all know, SCTP includes a key parameter that is a value of
> "Outbound Streams". basically this allocation is up to the application.
> In most cased only the application has the right knowledge about the
> nature and types of its data.
>
> The question is Application should send a packet with the stream number
> which the packet belongs to. Does that means, to implement my
> simulation, that I must modify the application layer? otherwise, how is
> the application able to send the packet, indicating the stream number..
>
> Waiting your reply...
>
> Regards
>
> Lei Zhang

---

From: "Lei Zhang" <[email-masked]>
Date: Mon, 1 Sep 2003 13:14:35 +0200

Hi, yuzhou;

Thanks for the reply, actually, there is a ULP process between Applicatio and SCTP called "tpal" in my simulation (on OPNET). I don't know if I should only operate the "tpal" layer or reckon the application layer as well. 

If anyone has a experience with OPNET for studying SCTP, could you give me some instruction? 

Best Regards

Lei