Subject: SCTP - Timer T1, RTO Min, RTO Intial and RTO Max

From: "Subhashini" <[email-masked]>
Date: Fri, 3 Oct 2003 12:27:53 +0530

Hi,

I want to know the usage of retransmission timers RTO Inital, RTO Min and RTO Max during Init procedure. i.e after the expiry of T1-INIT timer, the timer value of T1 should be set with what value? There is one more configurable paramter "Max Init Retransmission" to tell how many times INIT should be transmitted before to decide to abort the association. Please tell me the usage of all these timers and this configurable parameter during INIT procedure.
Should the difference between the first INIT transfer and the second INIT trasnsfer be close to RTO Min? If so, what should be the diffrence between the successive INIT transmissions? Please clarify.

thanks,
Subhshini ...

---

From: [email-masked]
Date: Fri, 3 Oct 2003 16:58:56 +0300

Hi Subhshini!

	The RTO is the time you wait before you consider an unacknowledged datagram to be lost.

	The minimum and maximum values of RTO are recommended to be 1 second and 1 minute respectively. If you don't have packet losses, RTO will typically be set to RTO Min, as the RTT is normally some tens of millisecond.

	However, at the very beginning, when sending the first INIT, you set the RTO to Initial RTO, which is 3 seconds. If after 3 seconds you don't receive the INIT ACK, you retransmit the INIT and as usual, you double the value of RTO, thus becoming 6 seconds. Then after a second time out, you set RTO to 12, 24, 48 and after that it is set to 60 and doesn't change...

	And about the retransmission counters. You retransmit the INIT up to 8 times. In the way I understand this, you can send up to 9 INITs (first one and 8 retransmissions). Once you have already established the association, that maximum number is increased to 10. 

	And by the way, RTO Initial, RTO Min and RTO Max are not timers. They are the recommended values to be used with the timers, which are T1, T3...

	I hope it helped!

	BR Iván Arias Rodríguez

-----Original Message-----
From: ext Subhashini [mailto:[email-masked]]
Sent: Friday, 03 October, 2003 9:58
To: [email-masked]
Subject: SCTP - Timer T1, RTO Min, RTO Intial and RTO Max

Hi,

thanks,
Subhshini ...