Subject: RE: question about address-parameters in INIT-ACK

From: "Lei Zhang" <[email-masked]>
Date: Tue, 14 Oct 2003 12:06:15 +0200

Hi, Andreas and all:

Thanks for the reply, you make it very clear.

But I have further questions, do you know why it is defined like that(Note 3)? Why can't Host Name address stay with other IP addresses? Neither can two Host Name address?

B/R

Lei

-----Original Message-----
From: Andreas Jungmaier [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 11:51 AM
To: Lei Zhang
Subject: Re: question about address-parameters in INIT-ACK

On Tuesday 14 October 2003 10:38, you wrote:
> Hi, all sctp player:
>
> Who could kindly explain the paragraph in RFC2960, 3.3.3:
>
> Note 3: The INIT ACK chunks MUST NOT contain more than one Host Name
>    address parameter.  Moreover, the sender of the INIT ACK MUST NOT
>    combine any other address types with the Host Name address in the
>    INIT ACK.  The receiver of the INIT ACK MUST ignore any other address
>    types if the Host Name address parameter is present.
>
> what will happen if INIT ACK has Host Name address and other IPv4/6
> addresses? or two Host Name addresses?
>

I think the endpoint could either silently ignore other address 
parameters (IPv4/IPv6) if there is only one host name parameter,
or could send back an abort with an error chunk adding the parameters
in question as "unrecognized parameters".

Either way, I would not implement host name parameter support 
at all. Most implementations out there do not use it, and therefore
only list IPv4/IPv6 addresses as supported address types.
Then, you can safely abort any replies with a host name paramter.

Hope that helps,

best regards,
Andreas

- -- 
Dipl.-Ing. Andreas Jungmaier              
Computer Networking Technology Group     
University of Duisburg-Essen                       
http://www.exp-math.uni-essen.de/~ajung   
PGP Key-ID: D382 4AC0             

PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0

---

From: Andreas Jungmaier <[email-masked]>
Date: Tue, 14 Oct 2003 13:51:48 +0200

On Tuesday 14 October 2003 12:06, Lei Zhang wrote:
> But I have further questions, do you know why it is defined like that(Note
> 3)? Why can't Host Name address stay with other IP addresses? Neither can
> two Host Name address?
>

Lei:

I think the original motivation for introducing something as the hostname
parameter was to allow SCTP to work with NAT boxes. However, there may be
other ways for achieving this.

Anyway, a host name can resolve to more than one IP address, so theoretically
it should be sufficient to add one of these parameters.

But: you are right. If you allow one such parameter, there is no reason
why there could not be more (theoretically). However, the spec's do not allow 
this, and are very clear about it.

- From an architectural point of view the host name parameter is undesirable,
since SCTP will likely be implemented in most operating systems (i.e. systems
that deserve this designation :-)
In this case, the setup of an association depends on a name lookup which 
infers delay and asynchronous I/O....in the kernel.

Regards,
Andreas
- --