Subject: question about the code in SCTP-A reference Guide by Randall R. Stewart and Qiaobing Xie

From: "Lei Zhang" <[email-masked]>
Date: Tue, 4 Nov 2003 11:58:34 +0100

Hi, SCTP players:
 
I want to be sure if the maximum substreams in one association has been defined as 256 in the code of the book. Because I lost the code unfortunatly:((
 
If anyone knows its defination in other patchs, they are also very welcome...
 
Best Regards
 
Lei

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 04 Nov 2003 06:42:16 -0600

Lei Zhang wrote:

> Hi, SCTP players:
>  
> I want to be sure if the maximum substreams in one association has 
> been defined as 256 in the code of the book. Because I lost the code 
> unfortunatly:((
>  

Lei:

Looking down and digging in the old CVS repository (note that this is 
NOT the code
that went with the book.. 4.6 was being worked on and never 
released....sigh not
enough cycles..) I see:

/* How long a cookie lives */
#define SCTP_DEFAULT_COOKIE_LIFE 60 /* seconds */

/* resource limit of streams */
#define MAX_SCTP_STREAMS 2048

/* max number of unreliable streams sets */
#define MAX_UNRELSTREAM_SETS 10

/* guess at how big to make the TSN mapping array */
#define SCTP_STARTING_MAPARRAY 10000

(you can see how out of date it was since it had "max_unrelstreams_sets" 
which
 went away with PR-SCTP)... but here it looks like 2k..

Hope that helps..

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)