Subject: the problem happened in the unbundling

From: "Lei Zhang" <[email-masked]>
Date: Mon, 17 Nov 2003 13:03:30 +0100

Hi, 

I creats a SCTP segment bundling two data chunks, for instance. When the receiver unbundles the segments, it first sees the data chunk that was bundled at last. So, the receiver then sends a SACK chunk immediatly because it thinks the out-of-order happens. If things happen like that, there are two much SACK chunks being replied. 

Anyone meet such problem? any suggestions?

thanks!

Lei

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Mon, 17 Nov 2003 09:39:15 -0600

>Anyone meet such problem? any suggestions?
Lei:

I presume from your comments you are bundling DATA chunks in reverse 
order. This is
not how most implementations do this for just the reason you site.  I.e. 
you have

TSN=100
TSN=101
TSN=102

You then would bundle them:
---------
Com-hdr
-------
Data
TSN=100
------
Data
TSN=101
------
Data
TSN=102
-----

If you instead send a packet that looks like:

---------
Com-hdr
-------
Data
TSN=102
------
Data
TSN=101
------
Data
TSN=100
-----

Which I think you are implying that you are.. then yes if
one processed independantly each TSN one might reach
the wrong conclusion. But if you process the whole packet
before responding (which most implementations do) then I don't
even think this would be a problem (though it is a bit strange) in
theory it should not cause a problem.. since you would mark
102 then 101 then 100 and then move forward the cum-ack to 102
and realize there was no gap and so send a packet based on the delayed
sack algorithm.

I don't see either way as a problem.. even though I think most implementions
will send the first layout of packet I illustrate not the second.

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)