Subject: struct sctp_sndrcvinfo sinfo_ppid

From: "ROBERT MAGNUSSON" <[email-masked]>
Date: Wed, 21 Apr 2004 11:14:23 +0200

Hello ! 
We are using snap 20040405 freeBSD49 and patch.20040406 and have come 
accross a problem with the sctp_sendmsg and sctp_recvmsg. The received 
value of sinfo_ppid in the sctp_sndrcvinfo supplied by sctp_recvmsg is 
not matching the value of the corresponding argument supplied to 
sctp_sendmsg. Any ideas ? 
 
Regards  
Tomas Nilsson & Robert Magnusson 
Karlstad University Sweden

---

From: "ROBERT MAGNUSSON" <[email-masked]>
Date: Wed, 21 Apr 2004 12:01:59 +0200

The use of ntohl/htonl does not seem to make any difference. That's what 
makes it so strange.... 
 
Regards 
 
-----Original Message----- 
From: Michael Tuexen <[email-masked]> 
To: "ROBERT MAGNUSSON" <[email-masked]> 
Cc: [email-masked] 
Date: Wed, 21 Apr 2004 11:44:32 +0200 
Subject: Re: struct sctp_sndrcvinfo sinfo_ppid 
 
> Possibly it is a Little Endian / Big endian problem. Are they the 
> same after ntohl? The SCTP stack should not touch them, but possibly  
> that 
> is the problem. 
>  
> Best regards 
> Michael 
>  
> On Apr 21, 2004, at 11:14 AM, ROBERT MAGNUSSON wrote: 
>  
> > Hello !

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 21 Apr 2004 11:44:32 +0200

Best regards
Michael

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Wed, 21 Apr 2004 07:42:41 -0500

Hmmm the stack leaves these completely
alone.... send me (privately) your code
for this and I will do some testing locally and see
if we have a bug somewhere..

R

ROBERT MAGNUSSON wrote:

>>>accross a problem with the sctp_sendmsg and sctp_recvmsg. The 
>>>      
>>>
>>received 
>>    
>>
>>>value of sinfo_ppid in the sctp_sndrcvinfo supplied by sctp_recvmsg 
>>>      
>>>
>>is 
>>    
>>

-- 
Randall R. Stewart
ITD - Transport Technologies
815-477-2127(o) or 815-342-5222(c)