Subject: Wording in sections 8.2 and 8.3 should be harmonized

From: Andreas Jungmaier <[email-masked]>
Date: Thu, 1 Apr 2004 12:18:12 +0200

Hi list,

I don't know whether anyone has mentioned this before:

section 8.2 currently states 
"When the value in the error counter exceeds the protocol parameter
                                     ^^^^^^^
 'Path.Max.Retrans' of that destination address, the endpoint should
 mark the destination transport address as inactive, and a
 notification SHOULD be sent to the upper layer."

section 8.3 now says:
"When the value of this counter reaches the protocol parameter 
                                ^^^^^^^^
 'Path.Max.Retrans', the endpoint should mark the corresponding
 destination address as inactive if it is not so marked, and may also
 optionally report to the upper layer the change of reachability of
 this destination address."

I would suggest a modification of the section 8.2 to conform to the
latter specification.

Best regards,

Andreas

- -- 
Dipl.-Ing. Andreas Jungmaier              
Computer Networking Technology Group     
University of Duisburg-Essen                       
http://www.exp-math.uni-essen.de/~ajung   
PGP Key-ID: D382 4AC0             

PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 1 Apr 2004 03:42:38 -0700

Andreas,

I would say the other way around. (Because Path.Max.Retrans
could be set to zero!--see the MIB.)  Exceeds (>) was correct.
Reaches (==) is wrong.

The change from SHOULD to "optional" on reporting the fact
to the user is okay.

--brian

On Thu, 01 Apr 2004, Andreas Jungmaier wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi list,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.3 (GNU/Linux)
> 
> iD8DBQFAa+xkXAsLBNOCSsARAtHEAJ9nojaB3hTQq+nXzmCYf3o7bzR2WwCgyBFm
> fsN9Ln6iv88rKNxhjf5+YvY=
> =a8kB
> -----END PGP SIGNATURE-----

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Andreas Jungmaier <[email-masked]>
Date: Thu, 1 Apr 2004 13:40:01 +0200

Brian and Bernward,

I am perfectly happy with that as well. As long as it says the
same thing in both places.

Best regards,
Andreas

On Donnerstag 01 April 2004 13:04, Meyknecht Bernward wrote:
> Hi there,
>
> and ...in addition... the wording 'exceeds' corresponds to the
> wording for the association max.retrans case from section 8.1,
> should be the same understanding for both cases,
> so I also prefer the 'exceeds'.
>
> Best regards,
> Bernward
>
>
>
> -----Ursprüngliche Nachricht-----
> Von: Brian F. G. Bidulock [mailto:[email-masked]]
> Gesendet: Donnerstag, 1. April 2004 12:43
> An: Andreas Jungmaier
> Cc: SCTP Discussion List
> Betreff: Re: Wording in sections 8.2 and 8.3 should be harmonized
>
>
> Andreas,
>

- --

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Thu, 1 Apr 2004 20:57:33 -0500 (EST)

Just to _further_ strengthen the argument for keeping "exceeds"... the
term Path.Max.Retrans implies exceeds. Intuitively, it means the sender
_will_ retransmit to the destination a max of Path.Max.Retrans times.

On Thu, 1 Apr 2004, Andreas Jungmaier wrote:

> WARNING: Unsanitized content follows.
> iD8DBQFAa/+RXAsLBNOCSsARAnCeAKDI1AuIZjIFi5S7gqvvs6FgajHLtACg83Wj
> Ey3dhttIxbl52xbG5BZjHtg=
> =TM5S

~armando

0--                                              --0
| Armando L. Caro Jr.  |  Protocol Engineering Lab |
| www.armandocaro.net  |    University of Delaware |
0--                                              --0