Subject: cwnd and ssthreshold update following fast retransmit and rtx timeout

From: [email-masked]
Date: Fri, 7 May 2004 14:55:17 +0100

Hi All

I  have a question concerning SCTP behaviour following expiry of the T3-rtx timer.

Is fast recovery deemed to have ended on expiry of this timer? Consider the situation where a fast retransmitted packet is subsequently lost resulting in  further retransmission(s) with consequential timeout(s), would this result in 2 (or more) reductions in the ssthreshold (plus cwnd adjustment)?

	·	In section 7.2.4 it states:
	·	
	·	6) If not in Fast Recovery, enter Fast Recovery and mark the highest
	·	 outstanding TSN as the Fast Recovery exit point. When a SACK
	·	 acknowledges all TSNs up to and including this exit point, Fast
	·	 Recovery is exited. While in Fast Recovery, the ssthresh and cwnd SHOULD NOT change for any destinations.
	·	
	·	While in 7.2.3 it states:
	·	
	·	When the T3-rtx timer expires on an address, SCTP should perform slow
	·	   start by:
	·	ssthresh = max(cwnd/2, 2*MTU)
	·	cwnd = 1*MTU
	·	partial_bytes_acked = 0
	·	
	·	These appear to be incompatible unless the second statement implies exiting of FR or does not apply whilst in FR.

Thanks

Gino

BT Exact

This statement represents the views of the author and does not necessarily accurately represent the views of BT

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Fri, 07 May 2004 10:27:05 -0400

Gino:

I think the key question here is "Does fast recovery exit when an T3 timer
expires?"

IMO the answer is yes. All data outstanding is marked for
retransmission so at that stage I think you are at square one
so to speak.. with a cwnd == 1 MTU and everything waiting
to be sent..

R

-- 
Randall R. Stewart
ITD - Transport Technologies
815-477-2127(o) or 815-342-5222(c)

---

From: [email-masked]
Date: Fri, 7 May 2004 19:17:52 +0100

Thanks Randall

I agree and was kind of looking for some confirmation from the experts!

Perhaps another way of looking at it is that since chunks are eligible for fast retransmission only once then if they are lost again it doesn't make sense to consider FR active for these chunks. Following rtx expiry since the RTO > RTT there is no issue relating to multiple cwnd/ssthresh reductions within an RTT, which I believe was one of the reasons why the FR period was introduced

Gino

-----Original Message-----
From: Randall Stewart (cisco) [mailto:[email-masked]]
Sent: Friday, May 07, 2004 15:27
To: Martin,GAR,Gino,XSK2 R
Cc: [email-masked]
Subject: Re: cwnd and ssthreshold update following fast retransmit and
rtx timeout

Gino:

R