Subject: Installation question

From: Torbjörn Andersson <[email-masked]>
Date: Mon, 6 Sep 2004 11:53:14 +0200

Hi all.

I'm try to patch up to days (2004-09-06) kame snap with patch 21

Sadly I'm having problems with applying the patch and then compile the
kernel. I have tried with both freebsd 4.10 and 5.2.1 with a similar
result.

My question is, which snap is recommended to use?

I'm also uncertain of if I'm applying the patch in the right way. Is
"patch < patch04xxxx" enough if pwd says "/usr/src/kame"

/Thanks
--------------------------------------------------------------
| Torbjörn Andersson  phone: +46 54 700 11 61
| Computer Science    fax: +46 54 700 18 28
| Karlstad University URL: http://www.cs.kau.se/~tora
---------------------------------------------------------------

---

From: Randall Stewart <[email-masked]>
Date: Tue, 07 Sep 2004 12:08:09 -0400

Torbjörn:

If you are using the current snap (from yesterday) then I
don't think you need to apply any patch.. Itojun has
managed to get all of patch 21 incorporated into the
current snap... :->

I do have a few more bugs that we have found (in particular
Michael Tuexen has found a SCTP_PEER_ADDR_PARAMS with the
TCP model.. and of course we have some new changes for
the APPLE port that Michael has been working on).. I will
try to get a "current" patch up for the lastest issues
found and resolved.

But as long as you are not using that particiular socketopt with the TCP
model you should be fine with generic KAME :-D

R

-- 
Randall Stewart
ITD
803-345-0369 <or> 815-342-5222

---

From: Torbjörn Andersson <[email-masked]>
Date: Wed, 8 Sep 2004 09:37:22 +0200

Thank you for the quick answer.

Just a few follow ups down below.
> -----Ursprungligt meddelande-----
> Från: Randall Stewart [mailto:[email-masked]]
> Skickat: den 7 september 2004 18:08
> Till: Torbjörn Andersson
> Kopia: [email-masked]
> Ämne: Re: Installation question
> 
> Torbjörn:
> 
> 

The change-log of the kame-snap then seems to lag behind. It states that
the patch-level is 18.

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 8 Sep 2004 11:46:07 +0200

Just a question:

the ChangLog of that SNAP says:

A new KAME snap kit should be available by now.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

			CHANGELOG for KAME kit
$KAME: CHANGELOG,v 1.2665 2004/09/04 09:31:29 jinmei Exp $

<200409>
2004-09-04  JINMEI, Tatuya  <[email-masked]>
	* kame/kame/dhcp6: added the ability of dhcp6c to work on multiple
	interfaces simultaneously.

So no SCTP changes mentioned. This is the same for all SNAPs back to the
IETF...

Maybe it is only an error in the ChangeLog.

Best regards
Michael

---

From: Randall Stewart <[email-masked]>
Date: Wed, 08 Sep 2004 08:11:20 -0400

Interesting... Itojun must have forgotten to
update the change log.. I did see the commits
go into kame.. and I generated a patch yesterday
and it is all there... only a few minor
things in our patch (mostly the APPLE stuff).

R