Subject: socket api comment -09

From: Randall Stewart <[email-masked]>
Date: Fri, 08 Oct 2004 07:14:34 -0400

Hi all:

I just noticed an error or two and maybe the lack
of something while implementing sctp_sendx().

First of all the paragraph note at the end is a clone
error and does not belong with sctp_sendx().... opps..

Second the type value for the sndrcvinfo parameter is const. I
think this is incorrect since it would be nice if on return
from this call the sndrcvinfo structure would have the
association id populated in it.

And lastly .. I think we need a utility function that is

sctp_getassocid(int sd, struct sockaddr *);

I realize you can easily build this using SCTP_PEER_ADDR_PARAMS but
why not have a standard available method... I will provide this
with KAME no matter if its in the socket api or not... but I think
we should document it and standardize it...

Comments?

R
-- 
Randall Stewart
ITD
803-345-0369 <or> 815-342-5222

---

From: Michael Tuexen <[email-masked]>
Date: Sat, 9 Oct 2004 20:04:19 +0200

Hi Randy,

I agree with you and support the inclusion of the
sctp_getassocid in the socket API ID.

In addition I think it would be nice to have a way of
disabling the path MTU discovery and setting the
path MTU per path. Currently we can set only the
fragmentation point per assoc. The reason is that
in the SIGTRAN environment people might want to use
preconfigured MTUs and they might be different in
the different networks.

Best regards
Michael