Subject: Re: Host Name address handling

From: Randall Stewart <[email-masked]>
Date: Fri, 28 Jan 2005 11:47:55 -0500

Randall Stewart wrote:
> [email-masked] wrote:
> 
>> Hello Randall-san et al,
>>
>> Are there any sample implementation of handling "Host Name address" in
>> INIT/INIT_ACK messages?
>> xxxBSD or Linux??

The problem with the host-name-address parameter IMO is:

a) It servers little purpose since you can get through a
    NAT like the nat draft says by just NOT placing any
    addresses in your INIT.. yes you are singly homed.. but
    the HNA param would not help.. you have to have nat's
    cooperating to get M-homed..

b) It is very very difficult to implement in the kernel since
    when it is time to resolve the host name one must
    1) upcall to an app to do the DNS lookup
    2) sleep the kernel thread waiting for an app
       to write back
    3) when the app gets the DNS response have it
       write it down the "socket" or other special
       IPC mechanism
    4) Then proceed.

   This is very ugly and so far, we have not been able to
   test this feature at any interop since no one is implementing
   it.. and for good reason... I really think it should be something
   we drop from the protocol :-D

R

>>
>> Thank you in advance,
>>
>> chiba
>>
>>
> 
> Forwarding to my cisco account so I can answer
> 
> R
> 
> 

-- 
Randall Stewart
ITD
803-345-0369 <or> 815-342-5222

---

From: Qiaobing Xie <[email-masked]>
Date: Fri, 28 Jan 2005 13:44:35 -0600

Looking forward, it might become a very good place for passing host identifier if HIP gets 
their way.

-Q

Randall Stewart wrote:

>>> Are there any sample implementation of handling "Host Name address"
> 
> in
> 
>>> INIT/INIT_ACK messages?
>>> xxxBSD or Linux??
> 
>