Subject: Re: SCTP Performance measurements

From: Mark Butler <[email-masked]>
Date: Wed, 15 Feb 2006 21:18:25 -0700

Hello Michael,

  The measurements you did are very informative - Thank you.  I have one 
question and one suggestion.  First, what were the send and receive 
buffers set to one each platform, if other than the default values? 
Also, have you considered extending your tests for larger message sizes, 
such as up to 64K?

 - Mark

Michael Tuexen wrote:

> Dear all,
>
> I just wanted to let you know that some performance measurements of 
> SCTP on
> Solaris/LKSCTP/KAME are available at
>
> http://sctp.fh-muenster.de/Performance/index.html
>
> One suggestion to improve performance is not to compute the CRC32C 
> checksum
> on the loopback interface. Look at the measurements for *BSD to see 
> the difference.
>
> Please let me know when you have resolved the receiver side issue 
> which prevents
> some measurements.
>
> Best regards
> Michael

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 16 Feb 2006 09:42:08 +0100

Hi Mark,

see my comments in-line.

Best regards
Michael

On Feb 16, 2006, at 5:18 Uhr, Mark Butler wrote:

> Hello Michael,
>
>  The measurements you did are very informative - Thank you.  I have 
> one question and one suggestion.  First, what were the send and 
> receive buffers set to one each platform, if other than the default
On BSd and Solaris we used the defaults. On Linux we tried with the 
suggestions from the
LKSCTP devlist.
> values? Also, have you considered extending your tests for larger 
> message sizes, such as up to 64K?
Yes, we have plans to add
- larger message sizes
- usage of sctp_sendmsg/sctp_recvmsg instead of send/recv
- usage of limited links
- usage of multiple streams
- usage of multiple associations
- usage of the 1-many style API

But as you know we already run into serious problems with the most 
basic measurements.
I hope that LKSCTP resolves the recv buffer issues and Solaris becomes 
less varying.
We'll redo the measurements then and are extending the measurement in 
the meantime.

---

From: Randall Stewart <[email-masked]>
Date: Thu, 16 Feb 2006 04:31:26 -0500

Michael:

Interesting numbers.. I will ask you a
question too..

You show BSD-nocsum and BSD with the
loopback tests.. using the sysctl to turn
the csum on and off.

What about Solaris.. was the test with
the csum on or off? I realize that you
probably have no control variable.. but it would
be interesting to know if you got that performance
with a csum (I am guessing that an ethereal
shows it to have the csum off.. am I right)?

R

Michael Tuexen wrote:
> But as you know we already run into serious problems with the most basic 
> measurements.

-- 
Randall Stewart
ITD - Cisco Systems Inc.
803-345-0369 <or> 815-342-5222 (cell)

---

From: Randall Stewart <[email-masked]>
Date: Thu, 16 Feb 2006 05:33:09 -0500

Michael Tuexen wrote:
> Hi Randy,
> I have no control, but Kacheong told be that Solaris
> does not compute them on the loopback interface. So
> it is much like BSD with default sysctls.

Ahh.. so Kacheong confirms this.. which makes
sense.. otherwise the results would not
be so similar..

There is an interesting tail off at 16k or so
that I need to investagate too .. at least
for BSD...
> No, you can not capture packets on the loopback
> interface on Solaris, as far as I know. At
> least I can not do it with snoop or ethereal...
> 
Ahh.. thats a shame..

I sometimes like to do testing on my local box
and being able to sniff loopback in such
an instance is invaluable :-D

R

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 16 Feb 2006 11:30:37 +0100

Hi Randy,

see my comments in-line.

Best regards
Michael

>> I hope that LKSCTP resolves the recv buffer issues and Solaris 
>> becomes less varying.