Subject: value range for rto.alpha and rto.beta

From: Vlad Yasevich <[email-masked]>
Date: Tue, 18 Jul 2006 16:58:11 -0400

Hi All

I was wondering what the value range for RTO.alpha and RTO.beta
could be.  The reason for this questions is that Linux allows
one to modify these values and currently doesn't implement any
bounds checks.  This is bad from the implementation point of view
since we could end up with very large shifts and always end up using
clock granularity.

So, I was thinking that there might be a limited range from the protocol
side, but wanted to ask what other folks did.

Thanks
-vlad

---

From: Randall Stewart <[email-masked]>
Date: Wed, 19 Jul 2006 05:35:58 -0400

Vlad:

I have never heard of anyone playing with these
values... basically from what I understand.. Van
did a lot of work to tweak and tune to get the
numbers he came up with.. I vaguely remember Vern
saying something to the effect that to use different
values a lot of study would need to be done :-0

This is why very few implementations allow these to be
changed... IMO its better to make the researcher that
wants to play with these tweak these by hacking the
code...

Having these as open, changeable items is NOT a good
thing

R

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 815-342-5222 (cell)

---

From: Vlad Yasevich <[email-masked]>
Date: Wed, 19 Jul 2006 15:22:00 -0400

> wants to play with these tweak these by hacking the

Yeah, that was my opinion too.

> Having these as open, changeable items is NOT a good

Thanks for additional info.  I'll probably close that loophole.

-vlad

---

From: Vlad Yasevich <[email-masked]>
Date: Wed, 19 Jul 2006 15:22:00 -0400

-vlad

---

From: Vlad Yasevich <[email-masked]>
Date: Wed, 19 Jul 2006 15:22:00 -0400

-vlad

---

From: Vlad Yasevich <[email-masked]>
Date: Wed, 19 Jul 2006 15:22:00 -0400

-vlad