Subject: problem compliling new kernel for SCTP

From: [email-masked]
Date: Sat, 12 Aug 2006 21:09:16 -0700

Iam trying to install SCTP enabled Apache server and Mozilla browser on FreeBSD 6.0  
These are things that i have done:  
  
1) I downloaded the kernel patch (tarball)  from sctp.org and applied it.  (iam following the instructions from the readme file) 
2) Included the line "options SCTP" in MY kernel source code at  /usr/src/sys after making a copy of GENERIC and 
called it MYKERNEL 
3) ran config to generate kernel source code 
4) changed into the /usr/src/compileMYKERNEL. 
5) Ran the "make depend" command. 
6) Ran the make command

This gies the following error in mbuf.c

cc -c -O -pipe  -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual  -fformat-extensions -std=c99 -g -nostdinc -I-  -I. -I../../.. -I../../../contrib/altq -I../../../contrib/ipfilter -I../../../contrib/pf -I../../../contrib/dev/ath -I../../../contrib/dev/ath/freebsd -I../../../contrib/ngatm -I../../../dev/twa -D_KERNEL -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h -fno-common -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000  -mno-align-long-strings -mpreferred-stack-boundary=2  -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -ffreestanding -Werror  ../../../kern/kern_mbuf.c
./../../kern/kern_mbuf.c: In function `mbuf_init':
./../../kern/kern_mbuf.c:191: error: `MBUF_JUMBOP_MEM_NAME' undeclared (first use in this function)
./../../kern/kern_mbuf.c:191: error: (Each undeclared identifier is reported only once
./../../kern/kern_mbuf.c:191: error: for each function it appears in.)
./../../kern/kern_mbuf.c:202: error: `MBUF_JUMBO9_MEM_NAME' undeclared (first use in this function)
./../../kern/kern_mbuf.c:213: error: `MBUF_JUMBO16_MEM_NAME' undeclared (first use in this function)
./../../kern/kern_mbuf.c: In function `mb_ctor_mbuf':
./../../kern/kern_mbuf.c:284: error: `MT_NOINIT' undeclared (first use in this function)
./../../kern/kern_mbuf.c: In function `mb_ctor_clust':
./../../kern/kern_mbuf.c:380: error: `EXT_JUMBOP' undeclared (first use in this function)
./../../kern/kern_mbuf.c:384: error: `EXT_JUMBO9' undeclared (first use in this function)
./../../kern/kern_mbuf.c:387: error: `EXT_JUMBO16' undeclared (first use in this function)
*** Error code 1

Stop in /usr/src/sys/i386/compile/MYKERNEL.
# 

Can any1 please tell me what is going wrong. 
thanks
regards
swapna

---

From: Randall Stewart <[email-masked]>
Date: Sun, 13 Aug 2006 04:29:51 -0400

This look tom me that you are running the wrong setup and getting
a 6.1 patch.. or 7.0..

There are two links on sctp.org:

http://www.sctp.org/July25.patch.bz2
or
http://www.sctp.org/July25.tar.bz2

You do NOT use the patch for any system EXCEPT FreeBSD 7.0

If you are using 6.0 or 6.1 you MUST use the tar NOT THE PATCH.

After you untar the tar ball .. you must run a setup script.
The setup script ask's you questions...
---------------------------------------------------------------------
bash-stewlap: ./setup_freebsd_src.sh <--------------------enter
Where is your cvs path (e.g. /usr/rrs/sctpCVS)?
/usr/rrs/sctpCVS <-----------------I input + enter----------
Where is your kernel source code that you are using (e.g. /usr/src/sys)?
/usr/src/sys
Will you be using 7.0 Current or FreeBSD 6.1 or 6.0 (7 or 61 or 60)?
7 <----------------I input + enter
I will use 7.0 then, if unsure hit ctl-c else return
<-----I input an enter to confirm.
Linking /usr/rrs/sctpCVS/KERN/freebsd7/conf/files
Linking /usr/rrs/sctpCVS/KERN/freebsd7/conf/options
Linking /usr/rrs/sctpCVS/KERN/freebsd7/kern/syscalls.master
Linking /usr/rrs/sctpCVS/KERN/freebsd7/kern/uipc_syscalls.c
Linking /usr/rrs/sctpCVS/KERN/freebsd7/net/rtsock.c
Linking /usr/rrs/sctpCVS/KERN/freebsd7/netinet/in_proto.c
Linking /usr/rrs/sctpCVS/KERN/freebsd7/netinet6/in6_proto.c
Linking /usr/rrs/sctpCVS/KERN/freebsd7/sys/mbuf.h
Linking /usr/rrs/sctpCVS/KERN/freebsd7/sys/socket.h
Preparing kernel SCTP sources now
Linking in SCTP sources
mv -f init_sysent.c init_sysent.c.bak
mv -f syscalls.c syscalls.c.bak
mv -f ../sys/syscall.h ../sys/syscall.h.bak
mv -f ../sys/syscall.mk ../sys/syscall.mk.bak
mv -f ../sys/sysproto.h ../sys/sysproto.h.bak
sh makesyscalls.sh syscalls.master
You may now go to your kernel source tree /usr/src/sys
Configure a new kernel with:
options SCTP
And build as normal
This script as already did a
make sysent
In /usr/src/sys/kern so the syscalls are present
in the kernel. However you probably need to
copy these to /usr/include/sys and also
do a  make buildworld and make installworld
which will get the sctp_xxx calls into libc
bash-stewlap:
----------------------------------------------------------------------

Now I can build my 7.0 system for YOU DO NOT ENTER 7... you
enter "60" since you are building a 60 system.

If you were on the released version you would enter "61".

R

[email-masked] wrote:
> ../../../kern/kern_mbuf.c: In function `mbuf_init':
> ../../../kern/kern_mbuf.c:191: error: `MBUF_JUMBOP_MEM_NAME' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c:191: error: (Each undeclared identifier is reported only once
> ../../../kern/kern_mbuf.c:191: error: for each function it appears in.)
> ../../../kern/kern_mbuf.c:202: error: `MBUF_JUMBO9_MEM_NAME' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c:213: error: `MBUF_JUMBO16_MEM_NAME' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c: In function `mb_ctor_mbuf':
> ../../../kern/kern_mbuf.c:284: error: `MT_NOINIT' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c: In function `mb_ctor_clust':
> ../../../kern/kern_mbuf.c:380: error: `EXT_JUMBOP' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c:384: error: `EXT_JUMBO9' undeclared (first use in this function)
> ../../../kern/kern_mbuf.c:387: error: `EXT_JUMBO16' undeclared (first use in this function)
> *** Error code 1
> 

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 815-342-5222 (cell)