Subject: application buffer larger than socket sendbuffer

From: Oliver Kowalke <[email-masked]>
Date: Mon, 22 Jan 2007 17:50:28 +0100

Hello,
The application is put to sleep (for blocking SCTP sockets) if the 
application buffer is larger than the socket send buffer 
if write is called. Is this true for SOCK_STREAM and 
SOCK_SEQPACKET (using sendmsg) SCTP sockets?

regards,
Oliver

---

From: Randall Stewart <[email-masked]>
Date: Tue, 23 Jan 2007 09:34:08 -0500

> SOCK_SEQPACKET (using sendmsg) SCTP sockets?
So lets say the socket buffer is 100k

and I do

write (msg, 200k);

and the socket is in blocking mode.

I should be put to sleep while the first 100k is
sent and ack'd.. and then copy the rest of the
message down and then return..

This should work in either 1-2-1 or 1-2-M sockets.

R

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)