Subject: Re: [Fwd: Window updates in SCTP]

From: Randall Stewart <[email-masked]>
Date: Fri, 27 Apr 2007 17:43:17 -0400

Not sure why that would happen :-9 the guy
that did this has left cisco too.. I should move
the mailing list to lakerest.net... sigh..

comments in line..

Preethi Natarajan wrote:
> Randall,
> I tried to post the message below to the SCTP implementor's list, but 
> for some reason the mailguard rejected my message (I am subscribed to 
> the list). I will wait for a while and try posting again, meanwhile, was 
> wondering if you might have the time to answer my query.
> 
> 
> ------------------------------------------------------------------------
> 
> Subject:
> Window updates in SCTP
> From:
> Preethi Natarajan <[email-masked]>
> Date:
> Fri, 27 Apr 2007 15:50:30 -0400
> To:
> [email-masked]
> 
> To:
> [email-masked]
> 
> 
> Hello,
> 
> In SCTP, are SACKs generated for receive window (a_rwnd) updates? I.e., 
> if application reads 1MTU data and frees up that much rwnd space, will 
> the SCTP data receiver send a SACK to advertise the new a_rwnd even if 
> the delayed sack timer has not expired?
> 

Well yes and no.. yes you WILL get window update sacks.. but NO you
don't get them at 1k read.. Generating sacks is expensive.. so
these are done after reading more than 1k.. you will get them..
but NOT with such a small amount.. I think there may be
a sysctl threshold that controls this.. I will have to look.

Of course every implementation will do this differently..

> In my few experiments with the TCP stack on FreeBSD 6.1, it looks like 
> window updates (of atleast 1MSS) are advertised asap to the sender 
> (irrespective of the delayed ack algorithm). I know this is not the TCP 
> implementor's list, but any idea if this the expected TCP behavior?

I am not sure what to expect... except that your mileage will very based
on implementation surely..

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)

---

From: Preethi Natarajan <[email-masked]>
Date: Sun, 29 Apr 2007 09:34:44 -0400

> a sysctl threshold that controls this.. I will have to look.

I was looking at SCTP sysctls.. Is it net.inet.sctp.strict_sakcs?

Yes, the window updates in TCP does increase its cwnd faster, and I 
would like to minimize the differences between the two transport 
implementations...

Thanks,
Preethi

---

From: Randall Stewart <[email-masked]>
Date: Sun, 29 Apr 2007 10:23:58 -0400

> would like to minimize the differences between the two transport 
Opps.. I was wrong.. it takes a shift of your
socket buffer size..

Hmm.. let me see about making this into a sysctl and just
have it default to something reasonable.

R