Subject: Re: partial reliability and message fragments

From: Michael Tuexen <[email-masked]>
Date: Wed, 1 Aug 2007 10:49:56 +0200

Hi Vlad,

see my comment in-line.

Best regards
Michael

On Jul 31, 2007, at 11:28 PM, Vlad Yasevich wrote:

> Hi All
>
> Have a question regarding PR extensions and SCTP message fragments.
>
> If a fragment SCTP message times out in the middle of the  
> transmission, should
> the timed out fragments be sent or not?
I would say, that they are not sent. If the first chunks are already  
partially
delivered at the receiver side, the partial delivery needs to be  
aborted.
>
> For example, a user sends a large message that gets fragmented into  
> 3 SCTP chunks.
> After sending the first 2 of the chunks, the message expires.   
> Should the last chunk
> be transmitted as new even though it's now "abandoned"?
>
> Thanks
> -vlad
>

---

From: Randall Stewart <[email-masked]>
Date: Tue, 07 Aug 2007 14:13:52 -0400

Michael Tuexen wrote:
> delivered at the receiver side, the partial delivery needs to be  aborted.
> 

I believe this is one of the main purposes of the partial deliver
events.. at least its why I put it in place.. it can also be
used when an association goes away.. but the actual event showed
up with PR-SCTP.. since an abort notification would also tell the
same thing .. in the case of PR-SCTP... you have not aborted the
association so the PR event was needed :-D

R
>>
>> For example, a user sends a large message that gets fragmented into  3 
>> SCTP chunks.
>> After sending the first 2 of the chunks, the message expires.   Should 
>> the last chunk

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)